summaryrefslogtreecommitdiff
path: root/recipes-core
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-core')
-rw-r--r--recipes-core/multitech/config/config-mths/modprobe.d/omap-wdt.conf1
-rw-r--r--recipes-core/multitech/config/network/interfaces11
-rw-r--r--recipes-core/multitech/config_2.4.bb7
3 files changed, 18 insertions, 1 deletions
diff --git a/recipes-core/multitech/config/config-mths/modprobe.d/omap-wdt.conf b/recipes-core/multitech/config/config-mths/modprobe.d/omap-wdt.conf
new file mode 100644
index 0000000..ba99f03
--- /dev/null
+++ b/recipes-core/multitech/config/config-mths/modprobe.d/omap-wdt.conf
@@ -0,0 +1 @@
+options omap-wdt early_enable=1 timer_margin=600 \ No newline at end of file
diff --git a/recipes-core/multitech/config/network/interfaces b/recipes-core/multitech/config/network/interfaces
index 67c934b..04a1d3d 100644
--- a/recipes-core/multitech/config/network/interfaces
+++ b/recipes-core/multitech/config/network/interfaces
@@ -9,6 +9,7 @@ auto eth0
iface eth0 inet static
address 192.168.2.1
netmask 255.255.255.0
+post-up ip addr show eth0
# Forwarding packets on eth0
# gateway 192.168.2.2
# pre-up bash -c 'echo 1 >/proc/sys/net/ipv4/ip_forward'
@@ -62,12 +63,22 @@ netmask 255.255.255.0
#
# See https://busybox.net/downloads/BusyBox.html for more information.
#
+# Currently rsi-91x driver requires pre-down to remove the wifi0 link
# auto wifi0
# iface wifi0 inet dhcp
# wpa-conf /etc/wpa_supplicant.conf
# wpa-driver nl80211
# pre-up bash -c '([[ -d /sys/class/net/wifi0 ]] || /opt/rs9113/onebox_util rpine0 create_vap wifi0 sta sw_bmiss)'
# udhcpc_opts -t 10 -b
+# pre-down ip link set dev wifi0 down
+
+# wifi1 example for hostapd
+# Currently rsi-91x driver requires pre-down to remove the wifi1 link
+# auto wifi1
+# iface wifi1 inet static
+# address 10.0.0.1
+# netmask 255.0.0.0
+# pre-down ip link set dev wifi1 down
# The pan0 interface purpose is to support bluetooth pand
# If access to another network is required, the ip forwarding
diff --git a/recipes-core/multitech/config_2.4.bb b/recipes-core/multitech/config_2.4.bb
index d58bec1..6d6956b 100644
--- a/recipes-core/multitech/config_2.4.bb
+++ b/recipes-core/multitech/config_2.4.bb
@@ -4,7 +4,7 @@ LICENSE = "MIT"
RDEPENDS_${PN} += "bash"
LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
PACKAGE_ARCH = "all"
-PR = "r2"
+PR = "r3"
PACKAGES =+ "${PN}-mths"
inherit update-rc.d
inherit allarch
@@ -62,11 +62,16 @@ fakeroot do_install () {
install -m 0644 ${WORKDIR}/99_radio ${D}${sysconfdir}/default/volatiles
}
+fakeroot do_install_append_mtcpmhs () {
+ install -m 644 -D ${WORKDIR}/${CONFIGFILES_MTHS}/modprobe.d/omap-wdt.conf ${D}${sysconfdir}/modprobe.d/omap-wdt.conf
+}
+
FILES_${PN} = "${sysconfdir}/defaults.tar.gz ${sysconfdir}/default_pass"
FILES_${PN} += "${sysconfdir}/init.d/config ${sysconfdir}/default ${libexecdir}/ppp/chat_wrapper"
FILES_${PN} += "${sysconfdir}/default/volatiles"
FILES_${PN}-mths = "${sysconfdir}/defaults-mths.tar.gz"
+FILES_${PN}_append_mtcpmhs += "${sysconfdir}/modprobe.d/omap-wdt.conf"
# Create the hotspot version of defaults.tar.gz
pkg_postinst_${PN}-mths() {