summaryrefslogtreecommitdiff
path: root/recipes-core
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-core')
-rw-r--r--recipes-core/images/mlinux-factory-image.bb26
1 files changed, 19 insertions, 7 deletions
diff --git a/recipes-core/images/mlinux-factory-image.bb b/recipes-core/images/mlinux-factory-image.bb
index 20164e5..bc84786 100644
--- a/recipes-core/images/mlinux-factory-image.bb
+++ b/recipes-core/images/mlinux-factory-image.bb
@@ -15,7 +15,6 @@ IMAGE_INSTALL += "${LIGHTTPD}"
IMAGE_INSTALL += "sqlite3"
IMAGE_INSTALL += "autossh"
-IMAGE_INSTALL += "netcat"
# Perl support
IMAGE_INSTALL += "perl"
@@ -26,12 +25,25 @@ IMAGE_INSTALL += "perl-module-io perl-module-fcntl"
# Python support
IMAGE_INSTALL += "python"
-IMAGE_INSTALL += "python-pyserial"
-IMAGE_INSTALL += "python-simplejson"
-IMAGE_INSTALL += "python-unixadmin"
-IMAGE_INSTALL += "python-textutils"
-IMAGE_INSTALL += "python-html"
-IMAGE_INSTALL += "python-sqlite3"
+# Python modules
+IMAGE_INSTALL += "python-async \
+python-argparse \
+python-compression \
+python-dateutil \
+python-html \
+python-psutil \
+python-pycurl \
+python-pyopenssl \
+python-pyserial \
+python-pyudev \
+python-pyusb \
+python-simplejson \
+python-sqlite3 \
+python-syslog \
+python-textutils \
+python-unixadmin \
+python-xml \
+"
# Ruby support
IMAGE_INSTALL += "ruby"