summaryrefslogtreecommitdiff
path: root/recipes-core/useradd/useradd.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-core/useradd/useradd.bb')
-rw-r--r--recipes-core/useradd/useradd.bb20
1 files changed, 10 insertions, 10 deletions
diff --git a/recipes-core/useradd/useradd.bb b/recipes-core/useradd/useradd.bb
index d229a2f..29d6508 100644
--- a/recipes-core/useradd/useradd.bb
+++ b/recipes-core/useradd/useradd.bb
@@ -7,7 +7,9 @@ LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=4d92cd373abda3937c2bc47fbc49d
file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
S = "${WORKDIR}"
-
+user = "mtadm"
+home = "/home/${user}"
+FILES_${PN} = "${home}/.ssh"
inherit useradd
# You must set USERADD_PACKAGES when you inherit useradd. This
@@ -28,30 +30,28 @@ GROUPADD_PARAM_${PN} = "-r -g 27 sudo"
# useradd command. Multiple users can be created by separating
# the commands with a semicolon. Here we'll create two users,
# user1 and user2:
-USERADD_PARAM_${PN} = "-u 50 -G sudo,disk,dialout -m -r -s /bin/bash mtadm"
+USERADD_PARAM_${PN} = "-u 50 -G sudo,disk,dialout -m -r -s /bin/bash ${user}"
do_install () {
# If the recipe doesn't have a file, the ipk
# is deleted, and it does nothing.
# Create a .ssh directory for mtadm.
- install -d 0700 ${D}/home/mtadm/.ssh
- chown mtadm:mtadm ${D}/home/mtadm
- chown mtadm:mtadm ${D}/home/mtadm/.ssh
+ install -d 0700 ${D}/${FILES_${PN}}
+ chown mtadm:mtadm ${D}/${home}
+ chown mtadm:mtadm ${D}/${FILES_${PN}}
}
-FILES_${PN} = "/home/mtadm/.ssh"
-
# Prevents do_package failures with:
# debugsources.list: No such file or directory:
INHIBIT_PACKAGE_DEBUG_SPLIT = "1"
pkg_postinst_${PN} () {
- profile=$D/home/mtadm/.profile
+ profile=${home}/.profile
if ! grep 'sbin' ${profile} ; then
Sub='${PA'
Sub=${Sub}'TH}:/sbin:/usr/sbin'
- echo 'PATH='${Sub} >>${profile}
- echo 'export PATH' >>${profile}
+ echo 'PATH='${Sub} >>$D/${home}/.profile
+ echo 'export PATH' >>$D/${home}/.profile
fi
# If doing an update, we need to add mtadm to dialout.
# If the admin has been changed, then the user must