summaryrefslogtreecommitdiff
path: root/recipes-core/multitech/config_2.3.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-core/multitech/config_2.3.bb')
-rw-r--r--recipes-core/multitech/config_2.3.bb6
1 files changed, 5 insertions, 1 deletions
diff --git a/recipes-core/multitech/config_2.3.bb b/recipes-core/multitech/config_2.3.bb
index 784b55e..0cbae96 100644
--- a/recipes-core/multitech/config_2.3.bb
+++ b/recipes-core/multitech/config_2.3.bb
@@ -4,7 +4,7 @@ LICENSE = "MIT"
RDEPENDS_${PN} += "bash"
LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
PACKAGE_ARCH = "all"
-PR = "r3"
+PR = "r4"
PACKAGES =+ "${PN}-mths"
inherit update-rc.d
@@ -21,6 +21,7 @@ SRC_URI = "\
file://config-mths \
file://chat_wrapper \
file://chat_wrapper.default \
+ file://99_radio \
"
RDEPENDS_${PN}-mths += "${PN}"
@@ -53,13 +54,16 @@ fakeroot do_install () {
install -m 0644 ${WORKDIR}/defaults-mths.tar.gz ${D}${sysconfdir}/defaults-mths.tar.gz
install -d ${D}${sysconfdir}/default
+ install -d ${D}${sysconfdir}/default/volatiles
install -d ${D}${libexecdir}/ppp
install -m 0755 ${WORKDIR}/chat_wrapper ${D}${libexecdir}/ppp/
install -m 0644 ${WORKDIR}/chat_wrapper.default ${D}${sysconfdir}/default/chat_wrapper
+ install -m 0644 ${WORKDIR}/99_radio ${D}${sysconfdir}/default/volatiles
}
FILES_${PN} = "${sysconfdir}/defaults.tar.gz ${sysconfdir}/default_pass"
FILES_${PN} += "${sysconfdir}/init.d/config ${sysconfdir}/default ${libexecdir}/ppp/chat_wrapper"
+FILES_${PN} += "${sysconfdir}/default/volatiles"
FILES_${PN}-mths = "${sysconfdir}/defaults-mths.tar.gz"