summaryrefslogtreecommitdiff
path: root/recipes-core/lighttpd
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-core/lighttpd')
-rw-r--r--recipes-core/lighttpd/lighttpd/0001-lighttpd-pcre-use-pkg-config.patch (renamed from recipes-core/lighttpd/files/0001-lighttpd-pcre-use-pkg-config.patch)0
-rw-r--r--recipes-core/lighttpd/lighttpd/0002_extended_tls_conf.patch (renamed from recipes-core/lighttpd/files/0002_extended_tls_conf.patch)0
-rw-r--r--recipes-core/lighttpd/lighttpd/0004_fastcgi_env_with_unixsocket.patch (renamed from recipes-core/lighttpd/files/0004_fastcgi_env_with_unixsocket.patch)0
-rw-r--r--recipes-core/lighttpd/lighttpd/lighttpd.conf (renamed from recipes-core/lighttpd/files/lighttpd.conf)0
-rw-r--r--recipes-core/lighttpd/lighttpd/lighttpd.init34
-rw-r--r--recipes-core/lighttpd/lighttpd/lighttpd_custom_images_setup (renamed from recipes-core/lighttpd/files/lighttpd_custom_images_setup)0
-rw-r--r--recipes-core/lighttpd/lighttpd/lighttpd_nrs.conf (renamed from recipes-core/lighttpd/files/lighttpd_nrs.conf)0
-rw-r--r--recipes-core/lighttpd/lighttpd_1.4.48.bb13
8 files changed, 37 insertions, 10 deletions
diff --git a/recipes-core/lighttpd/files/0001-lighttpd-pcre-use-pkg-config.patch b/recipes-core/lighttpd/lighttpd/0001-lighttpd-pcre-use-pkg-config.patch
index 48be920..48be920 100644
--- a/recipes-core/lighttpd/files/0001-lighttpd-pcre-use-pkg-config.patch
+++ b/recipes-core/lighttpd/lighttpd/0001-lighttpd-pcre-use-pkg-config.patch
diff --git a/recipes-core/lighttpd/files/0002_extended_tls_conf.patch b/recipes-core/lighttpd/lighttpd/0002_extended_tls_conf.patch
index 1a216dd..1a216dd 100644
--- a/recipes-core/lighttpd/files/0002_extended_tls_conf.patch
+++ b/recipes-core/lighttpd/lighttpd/0002_extended_tls_conf.patch
diff --git a/recipes-core/lighttpd/files/0004_fastcgi_env_with_unixsocket.patch b/recipes-core/lighttpd/lighttpd/0004_fastcgi_env_with_unixsocket.patch
index c265066..c265066 100644
--- a/recipes-core/lighttpd/files/0004_fastcgi_env_with_unixsocket.patch
+++ b/recipes-core/lighttpd/lighttpd/0004_fastcgi_env_with_unixsocket.patch
diff --git a/recipes-core/lighttpd/files/lighttpd.conf b/recipes-core/lighttpd/lighttpd/lighttpd.conf
index a3e02da..a3e02da 100644
--- a/recipes-core/lighttpd/files/lighttpd.conf
+++ b/recipes-core/lighttpd/lighttpd/lighttpd.conf
diff --git a/recipes-core/lighttpd/lighttpd/lighttpd.init b/recipes-core/lighttpd/lighttpd/lighttpd.init
new file mode 100644
index 0000000..bf89a60
--- /dev/null
+++ b/recipes-core/lighttpd/lighttpd/lighttpd.init
@@ -0,0 +1,34 @@
+#!/bin/sh
+
+PATH=/sbin:/bin:/usr/sbin:/usr/bin
+DAEMON=/usr/sbin/lighttpd
+NAME=lighttpd
+DESC="Lighttpd Web Server"
+OPTS="-f /etc/lighttpd.conf"
+
+case "$1" in
+ start)
+ echo -n "Starting $DESC: "
+ start-stop-daemon --start -x "$DAEMON" -- $OPTS
+ echo "$NAME."
+ ;;
+ stop)
+ echo -n "Stopping $DESC: "
+ start-stop-daemon --stop -x "$DAEMON"
+ echo "$NAME."
+ ;;
+ restart|force-reload)
+ echo -n "Restarting $DESC: "
+ start-stop-daemon --stop -x "$DAEMON"
+ sleep 1
+ start-stop-daemon --start -x "$DAEMON" -- $OPTS
+ echo "$NAME."
+ ;;
+ *)
+ N=/etc/init.d/$NAME
+ echo "Usage: $N {start|stop|restart|force-reload}" >&2
+ exit 1
+ ;;
+esac
+
+exit 0
diff --git a/recipes-core/lighttpd/files/lighttpd_custom_images_setup b/recipes-core/lighttpd/lighttpd/lighttpd_custom_images_setup
index ecd5f46..ecd5f46 100644
--- a/recipes-core/lighttpd/files/lighttpd_custom_images_setup
+++ b/recipes-core/lighttpd/lighttpd/lighttpd_custom_images_setup
diff --git a/recipes-core/lighttpd/files/lighttpd_nrs.conf b/recipes-core/lighttpd/lighttpd/lighttpd_nrs.conf
index 8c23747..8c23747 100644
--- a/recipes-core/lighttpd/files/lighttpd_nrs.conf
+++ b/recipes-core/lighttpd/lighttpd/lighttpd_nrs.conf
diff --git a/recipes-core/lighttpd/lighttpd_1.4.48.bb b/recipes-core/lighttpd/lighttpd_1.4.48.bb
index 776acc9..19e6cf2 100644
--- a/recipes-core/lighttpd/lighttpd_1.4.48.bb
+++ b/recipes-core/lighttpd/lighttpd_1.4.48.bb
@@ -5,7 +5,6 @@ BUGTRACKER = "http://redmine.lighttpd.net/projects/lighttpd/issues"
LICENSE = "BSD"
LIC_FILES_CHKSUM = "file://COPYING;md5=e4dac5c6ab169aa212feb5028853a579"
-PR .= ".mts21"
SECTION = "net"
DEPENDS = "zlib libpcre openssl"
@@ -22,13 +21,11 @@ RDEPENDS_${PN} += " \
"
RDEPENDS_${PN} += " openssl"
# for lighttpd_custom_images_setup script
-RDEPENDS_${PN} += "bash file file-magic-db-images"
SRC_URI = "http://download.lighttpd.net/lighttpd/releases-1.4.x/lighttpd-${PV}.tar.gz \
file://lighttpd.conf \
- file://lighttpd_nrs.conf \
- file://lighttpd_custom_images_setup \
+ file://lighttpd.init \
file://0001-lighttpd-pcre-use-pkg-config.patch;apply=true \
file://0004_fastcgi_env_with_unixsocket.patch;apply=true \
"
@@ -64,16 +61,13 @@ do_install_append() {
install -d ${D}${sysconfdir}/init.d ${D}${sysconfdir}/lighttpd.d ${D}/www/pages/dav
install -d 0644 ${D}${sysconfdir}/ssl
install -m 0755 --group www -d ${D}${localstatedir}/www
+# install -m 0755 ${WORKDIR}/lighttpd.init ${D}${sysconfdir}/init.d/lighttpd
install -m 0644 --group www ${WORKDIR}/lighttpd.conf ${D}${sysconfdir}
- install -m 0644 --group www ${WORKDIR}/lighttpd_nrs.conf ${D}${sysconfdir}
#For FHS compliance, create symbolic links to /var/log and /var/tmp for logs and temporary data
ln -sf ${localstatedir}/log ${D}/www/logs
ln -sf ${localstatedir}/tmp ${D}/www/var
- ln -snf ../volatile/www/tmp ${D}${localstatedir}/www/tmp
-
- install -d ${D}/${base_sbindir}
- install -m 755 ${WORKDIR}/lighttpd_custom_images_setup ${D}/${base_sbindir}/lighttpd_custom_images_setup
+ ln -snf ../volatile/www/tmp ${D}${localstatedir}/www/tmp}
}
do_install_append_mtr() {
@@ -87,7 +81,6 @@ do_install_append_mtrv1() {
FILES_${PN} += "${sysconfdir} /www"
CONFFILES_${PN} = "${sysconfdir}/lighttpd.conf \
- ${sysconfdir}/lighttpd_nrs.conf \
"
PACKAGES_DYNAMIC += "^lighttpd-module-.*"