summaryrefslogtreecommitdiff
path: root/recipes-core/libusb/usb-tools/001-nohidapi.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-core/libusb/usb-tools/001-nohidapi.patch')
-rw-r--r--recipes-core/libusb/usb-tools/001-nohidapi.patch57
1 files changed, 57 insertions, 0 deletions
diff --git a/recipes-core/libusb/usb-tools/001-nohidapi.patch b/recipes-core/libusb/usb-tools/001-nohidapi.patch
new file mode 100644
index 0000000..a065494
--- /dev/null
+++ b/recipes-core/libusb/usb-tools/001-nohidapi.patch
@@ -0,0 +1,57 @@
+*
+* Openembedded does not appear to have an HID API (Human Interface Devices).
+* We should not need those tests.
+*
+====================================================================================
+diff --git a/README.md b/README.md
+index 7feb63d..4ae3d1d 100644
+--- a/README.md
++++ b/README.md
+@@ -21,7 +21,7 @@ debian-based distros, the following command should do the right thing:
+
+ ```
+ $ sudo apt-get update
+-$ sudo apt install libusb-1.0-0-dev libssl-dev libhidapi-dev
++$ sudo apt install libusb-1.0-0-dev libssl-dev
+ ```
+
+ After these are installed, the usual autotools-based setup should be followed:
+diff --git a/configure.ac b/configure.ac
+index b34b6be..b5956ea 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -33,10 +33,6 @@ PKG_CHECK_MODULES([libusb], [libusb-1.0])
+ # libssl
+ PKG_CHECK_MODULES([ssl], [openssl])
+
+-# hidapi
+-PKG_CHECK_MODULES([hid], [hidapi], [], [
+- PKG_CHECK_MODULES([hid], [hidapi-hidraw], [], [
+- PKG_CHECK_MODULES([hid], [hidapi-libusb])])])
+
+ # libpthread
+ m4_include([m4/ax_pthread.m4])
+diff --git a/src/Makefile.am b/src/Makefile.am
+index cb55f05..072e564 100644
+--- a/src/Makefile.am
++++ b/src/Makefile.am
+@@ -9,7 +9,6 @@ dist_bin_SCRIPTS = msc.sh scptest.sh test.sh usbpwrtest
+ bin_PROGRAMS = \
+ acmc \
+ acmd \
+- cleware \
+ companion-desc \
+ control \
+ device-reset \
+@@ -44,11 +43,6 @@ switchbox_SOURCES = switchbox.c
+ switchbox_CFLAGS = $(AM_CFLAGS)
+ switchbox_LDADD =
+
+-# This needs HIDAPI
+-cleware_SOURCES = cleware.c
+-cleware_CFLAGS = $(AM_CFLAGS) $(hid_CFLAGS)
+-cleware_LDADD = $(hid_LIBS)
+-
+ # These need libusb-1.0
+ companion_desc_SOURCES = companion-desc.c
+ companion_desc_CFLAGS = $(AM_CFLAGS) $(libusb_CFLAGS)