summaryrefslogtreecommitdiff
path: root/recipes-core/images/mlinux-mtcap-image.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-core/images/mlinux-mtcap-image.bb')
-rw-r--r--recipes-core/images/mlinux-mtcap-image.bb22
1 files changed, 10 insertions, 12 deletions
diff --git a/recipes-core/images/mlinux-mtcap-image.bb b/recipes-core/images/mlinux-mtcap-image.bb
index ec161bd..1c0c94f 100644
--- a/recipes-core/images/mlinux-mtcap-image.bb
+++ b/recipes-core/images/mlinux-mtcap-image.bb
@@ -5,18 +5,19 @@ require mtcap-modules.inc
# For now we don't put this in MTR or AEP
# Password restrictions library from Redhat
-IMAGE_INSTALL += "libpwquality"
+IMAGE_INSTALL_append = " libpwquality"
FILESYSTEM_FEATURES = "dosfstools \
cifs-utils \
lsof \
"
-NETWORKING_FEATURES += "bridge-utils \
+NETWORKING_FEATURES_append = " \
+ bridge-utils \
inetutils-ftp \
openssl \
rsync \
- iperf \
+ iperf3 \
mii-diag \
tcpdump \
netcat \
@@ -25,9 +26,6 @@ NETWORKING_FEATURES += "bridge-utils \
busybox-ifplugd \
"
-# No accessory cards for MTAC
-MULTITECH_MTAC = ""
-
TIME_FEATURES = "tzdata tzdata-africa tzdata-americas tzdata-antarctica tzdata-arctic \
tzdata-asia tzdata-atlantic tzdata-australia tzdata-europe tzdata-pacific \
tzdata-misc \
@@ -37,13 +35,12 @@ TIME_FEATURES = "tzdata tzdata-africa tzdata-americas tzdata-antarctica tzdata-a
WIFI_FEATURES = "libnl \
wpa-supplicant \
- wireless-tools \
iw \
- hostap-daemon hostap-utils \
+ hostapd \
wilc1000 \
"
-MULTITECH_FEATURES += " \
+MULTITECH_FEATURES_append = " \
u-boot-linux-utils \
mlinux-scripts \
reset-handler \
@@ -54,7 +51,8 @@ MULTITECH_FEATURES += " \
annex-client \
"
-IMAGE_INSTALL += "lora-gateway-utils \
+IMAGE_INSTALL_append = " \
+ lora-gateway-utils \
lora-query \
lora-packet-forwarder \
lora-network-server \
@@ -68,11 +66,11 @@ MISC_FEATURES = "minicom lrzsz nano lxfp"
# Someday add wifi features
# ${WIFI_FEATURES}
#
-IMAGE_INSTALL += " \
+IMAGE_INSTALL_append = " \
${FILESYSTEM_FEATURES} \
${TIME_FEATURES} \
${MISC_FEATURES} \
"
# Multi-Tech SMS Utility (see http://git.multitech.net)
-IMAGE_INSTALL += "sms-utils"
+IMAGE_INSTALL_append = " sms-utils"