summaryrefslogtreecommitdiff
path: root/recipes-core/images/mlinux-mtcap-image.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-core/images/mlinux-mtcap-image.bb')
-rw-r--r--recipes-core/images/mlinux-mtcap-image.bb54
1 files changed, 54 insertions, 0 deletions
diff --git a/recipes-core/images/mlinux-mtcap-image.bb b/recipes-core/images/mlinux-mtcap-image.bb
new file mode 100644
index 0000000..610fe08
--- /dev/null
+++ b/recipes-core/images/mlinux-mtcap-image.bb
@@ -0,0 +1,54 @@
+DESCRIPTION = "mLinux Conduit Access Point image"
+
+require mlinux-minimal-image.bb
+
+FILESYSTEM_FEATURES = "dosfstools \
+ cifs-utils \
+ lsof \
+ "
+
+NETWORKING_FEATURES += "bridge-utils \
+ inetutils-ftp \
+ openssl \
+ rsync \
+ iperf \
+ mii-diag \
+ tcpdump \
+ netcat \
+ wget \
+ strongswan \
+ "
+
+TIME_FEATURES = "tzdata tzdata-africa tzdata-americas tzdata-antarctica tzdata-arctic \
+ tzdata-asia tzdata-atlantic tzdata-australia tzdata-europe tzdata-pacific \
+ tzdata-misc \
+ cronie \
+ ntpdate \
+ "
+
+MULTITECH_FEATURES += " \
+ u-boot-linux-utils \
+ mlinux-scripts \
+ reset-handler \
+ radio-cmd radio-query \
+ jsparser \
+ protobuf \
+ annex-client \
+ "
+
+LORA_FEATURES = "lora-packet-forwarder \
+ lora-packet-forwarder-dbg \
+ lora-gateway-utils"
+
+MISC_FEATURES = "minicom lrzsz nano"
+
+# Extra stuff to install
+IMAGE_INSTALL += " \
+ ${FILESYSTEM_FEATURES} \
+ ${TIME_FEATURES} \
+ ${LORA_FEATURES} \
+ ${MISC_FEATURES} \
+ "
+
+# Multi-Tech SMS Utility (see http://git.multitech.net)
+IMAGE_INSTALL += "sms-utils"