summaryrefslogtreecommitdiff
path: root/recipes-core/busybox/busybox_%.bbappend
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-core/busybox/busybox_%.bbappend')
-rw-r--r--recipes-core/busybox/busybox_%.bbappend4
1 files changed, 4 insertions, 0 deletions
diff --git a/recipes-core/busybox/busybox_%.bbappend b/recipes-core/busybox/busybox_%.bbappend
index b8bbdf7..31b58fa 100644
--- a/recipes-core/busybox/busybox_%.bbappend
+++ b/recipes-core/busybox/busybox_%.bbappend
@@ -2,6 +2,7 @@ PR .= ".mlinux3"
PACKAGES =+ "busybox-ifplugd"
FILESEXTRAPATHS_prepend := ":${THISDIR}/files:"
RDEPENDS_${PN} += "bash"
+DEPENDS += "libtirpc"
SRC_URI += "file://udhcpd.conf.example \
file://ifplugd.action \
@@ -24,6 +25,9 @@ do_install_append () {
install -m 644 ${WORKDIR}/eth1.conf.example ${D}${sysconfdir}/ifplugd
}
+export EXTRA_CFLAGS += "-I${STAGING_INCDIR}/tirpc"
+
+
RDEPENDS_${PN}-ifplugd += "bash"
# PACKAGES =+ "${PN}-ifplugd"
inherit update-rc.d