summaryrefslogtreecommitdiff
path: root/recipes-core/annex-proto/annex-proto.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-core/annex-proto/annex-proto.bb')
-rw-r--r--recipes-core/annex-proto/annex-proto.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/recipes-core/annex-proto/annex-proto.bb b/recipes-core/annex-proto/annex-proto.bb
new file mode 100644
index 0000000..cbb6fb2
--- /dev/null
+++ b/recipes-core/annex-proto/annex-proto.bb
@@ -0,0 +1,24 @@
+DESCRIPTION = "Provides the Multi-Tech MDM client protobuffer definitions"
+SECTION = "remote-management"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
+PR = "r20"
+PROVIDES = "annex_proto"
+DEPENDS = "protobuf"
+SRCREV = "7ad3f17a59d3fe564da099518310d61ad1304913"
+
+SRC_URI = "git://git@${MTS_INTERNAL_GIT}/annex/proto.git;protocol=ssh;branch=master \
+"
+S = "${WORKDIR}/git"
+
+# don't use cli here
+do_compile() {
+ echo "directory: `pwd`"
+}
+
+do_install() {
+ install annex.proto ${STAGING_DIR_NATIVE}
+}
+
+
+