summaryrefslogtreecommitdiff
path: root/recipes-connectivity
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-connectivity')
-rw-r--r--recipes-connectivity/bluez/bluez5_%.bbappend4
-rw-r--r--recipes-connectivity/hostapd/hostapd_%.bbappend4
2 files changed, 6 insertions, 2 deletions
diff --git a/recipes-connectivity/bluez/bluez5_%.bbappend b/recipes-connectivity/bluez/bluez5_%.bbappend
index 87cc0bf..c484558 100644
--- a/recipes-connectivity/bluez/bluez5_%.bbappend
+++ b/recipes-connectivity/bluez/bluez5_%.bbappend
@@ -74,7 +74,9 @@ INITSCRIPT_PARAMS_${PN}-rfcomm = "defaults 22 22"
INITSCRIPT_NAME_${PN}-mlinit = "bluetooth"
pkg_postinst_${PN}-bt-name() {
cd /$D
- patch -Np1 < $D/usr/share/bluez5/BT-Name.patch
+ if patch --dry-run -p1 < $D/usr/share/bluez5/BT-Name.patch ; then
+ patch -p1 < $D/usr/share/bluez5/BT-Name.patch
+ fi
}
pkg_prerm_${PN}-bt-name() {
diff --git a/recipes-connectivity/hostapd/hostapd_%.bbappend b/recipes-connectivity/hostapd/hostapd_%.bbappend
index 3c69a72..2686fa3 100644
--- a/recipes-connectivity/hostapd/hostapd_%.bbappend
+++ b/recipes-connectivity/hostapd/hostapd_%.bbappend
@@ -53,7 +53,9 @@ FILES_${PN}-cfg = "/etc/init.d/hostapd /etc/default/hostapd /etc/hostapd.conf"
pkg_postinst_${PN}-extra() {
cd /$D
- patch -Np1 < $D/usr/share/hostapd/WiFi-SSID.patch
+ if patch --dry-run -p1 < $D/usr/share/hostapd/WiFi-SSID.patch ; then
+ patch -p1 < $D/usr/share/hostapd/WiFi-SSID.patch
+ fi
}
pkg_prerm_${PN}-extra() {