summaryrefslogtreecommitdiff
path: root/recipes-connectivity/lora
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-connectivity/lora')
-rw-r--r--recipes-connectivity/lora/lora-packet-forwarder_3.0.0.bb9
1 files changed, 5 insertions, 4 deletions
diff --git a/recipes-connectivity/lora/lora-packet-forwarder_3.0.0.bb b/recipes-connectivity/lora/lora-packet-forwarder_3.0.0.bb
index 8042d50..3f5be37 100644
--- a/recipes-connectivity/lora/lora-packet-forwarder_3.0.0.bb
+++ b/recipes-connectivity/lora/lora-packet-forwarder_3.0.0.bb
@@ -38,9 +38,10 @@ do_install() {
install -m 755 ${WORKDIR}/global_conf.json.3.0.0.PCB_E336.EU868.basic.clksrc0 ${D}${LORA_DIR}/global_conf.json
install -m 755 ${WORKDIR}/local_conf.json ${D}${LORA_DIR}/
- install -m 755 util_sink/util_sink ${D}${LORA_DIR}/
- install -m 755 util_ack/util_ack ${D}${LORA_DIR}/
- install -m 755 util_tx_test/util_tx_test ${D}${LORA_DIR}/
+ install -d ${D}${LORA_DIR}/forwarder-utils
+ install -m 755 util_sink/util_sink ${D}${LORA_DIR}/forwarder-utils/
+ install -m 755 util_ack/util_ack ${D}${LORA_DIR}/forwarder-utils/
+ install -m 755 util_tx_test/util_tx_test ${D}${LORA_DIR}/forwarder-utils/
install -m 755 ${WORKDIR}/README.md ${D}${LORA_DIR}/
}
@@ -52,7 +53,7 @@ do_install_append_mtp() {
}
FILES_${PN} += "${LORA_DIR}"
-FILES_${PN}-dbg += "${LORA_DIR}/.debug"
+FILES_${PN}-dbg += "${LORA_DIR}/.debug ${LORA_DIR}/forwarder-utils/.debug"
# disable this on purpose for dev purposes
do_rm_work() {