summaryrefslogtreecommitdiff
path: root/recipes-connectivity/lora
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-connectivity/lora')
-rw-r--r--recipes-connectivity/lora/lora-network-server-mtcap/local_conf.json (renamed from recipes-connectivity/lora/lora-network-server-mtp/local_conf.json)0
-rw-r--r--recipes-connectivity/lora/lora-network-server-mtcap/lora-network-server.conf36
-rw-r--r--recipes-connectivity/lora/lora-network-server-mtcap/lora-network-server.default (renamed from recipes-connectivity/lora/lora-network-server-mtp/lora-network-server.default)0
-rwxr-xr-xrecipes-connectivity/lora/lora-network-server-mtcap/lora-network-server.init (renamed from recipes-connectivity/lora/lora-network-server-mtp/lora-network-server.init)0
-rw-r--r--recipes-connectivity/lora/lora-network-server-mtcap/lora-network-server.logrotate.conf (renamed from recipes-connectivity/lora/lora-network-server-mtp/lora-network-server.logrotate.conf)0
-rw-r--r--recipes-connectivity/lora/lora-network-server-mtcap_1.0.15.bb (renamed from recipes-connectivity/lora/lora-network-server-mtp_1.0.14.bb)10
-rw-r--r--recipes-connectivity/lora/lora-network-server-mtp/lora-network-server.conf35
-rw-r--r--recipes-connectivity/lora/lora-network-server_1.0.16.bb (renamed from recipes-connectivity/lora/lora-network-server_1.0.15.bb)4
-rwxr-xr-xrecipes-connectivity/lora/lora-packet-forwarder/lora-packet-forwarder.init8
-rw-r--r--recipes-connectivity/lora/lora-packet-forwarder_3.0.0.bb2
10 files changed, 51 insertions, 44 deletions
diff --git a/recipes-connectivity/lora/lora-network-server-mtp/local_conf.json b/recipes-connectivity/lora/lora-network-server-mtcap/local_conf.json
index 3c2af80..3c2af80 100644
--- a/recipes-connectivity/lora/lora-network-server-mtp/local_conf.json
+++ b/recipes-connectivity/lora/lora-network-server-mtcap/local_conf.json
diff --git a/recipes-connectivity/lora/lora-network-server-mtcap/lora-network-server.conf b/recipes-connectivity/lora/lora-network-server-mtcap/lora-network-server.conf
new file mode 100644
index 0000000..448b3db
--- /dev/null
+++ b/recipes-connectivity/lora/lora-network-server-mtcap/lora-network-server.conf
@@ -0,0 +1,36 @@
+{
+ "lora": {
+ "netID": "010203", /* netID for beacon packets */
+ "frequencyBand": "868", /* US="915", EU="868" */
+ "rx1DatarateOffset": 0, /* Datarate offset for mote rx window 1 sent in join response (0-3) */
+ "rx2Datarate": 12, /* Datarate for mote rx window 2 sent in join response (7-12) */
+ "maxTxPower": 26, /* Max Tx power (dBm), -6 to 26 */
+ "frequencyEU": 867500000, /* center freq for extra EU channels (Hz) */
+ "antennaGain": 0
+ },
+ "udp": {
+ "appPortUp": 1784, /* port for user-developed application use */
+ "appPortDown": 1786, /* port for user-developed application use */
+ "upstreamPort": 1780, /* ports for LoRa network communication */
+ "downstreamPort": 1782 /* ports for LoRa network communication */
+ },
+ "addressRange": {
+ "start": "00:00:00:01", /* address range used for mDots */
+ "end": "FF:FF:FF:FE"
+ },
+ "network": {
+ "public": true, /* set to false for private LoRa network with mDots + Conduit */
+ "leasetime": 0, /* time until mDot join expires (minutes) or 0 for no expiration */
+ "name": "YOUR-NETWORK-NAME", /* configure network security */
+ "passphrase": "YOUR-NETWORK-PASSPHRASE"
+ },
+ "log" : {
+ "console" : true,
+ "syslog" : false,
+ "level" : 30, /* error=10, warn=20, info=30, debug=50, trace=60, max=100 */
+ "path": "/var/log/lora-network-server.log"
+ },
+ "mqtt": {
+ "enabled": true
+ }
+}
diff --git a/recipes-connectivity/lora/lora-network-server-mtp/lora-network-server.default b/recipes-connectivity/lora/lora-network-server-mtcap/lora-network-server.default
index be7dcd5..be7dcd5 100644
--- a/recipes-connectivity/lora/lora-network-server-mtp/lora-network-server.default
+++ b/recipes-connectivity/lora/lora-network-server-mtcap/lora-network-server.default
diff --git a/recipes-connectivity/lora/lora-network-server-mtp/lora-network-server.init b/recipes-connectivity/lora/lora-network-server-mtcap/lora-network-server.init
index 86d731b..86d731b 100755
--- a/recipes-connectivity/lora/lora-network-server-mtp/lora-network-server.init
+++ b/recipes-connectivity/lora/lora-network-server-mtcap/lora-network-server.init
diff --git a/recipes-connectivity/lora/lora-network-server-mtp/lora-network-server.logrotate.conf b/recipes-connectivity/lora/lora-network-server-mtcap/lora-network-server.logrotate.conf
index d2b6c9a..d2b6c9a 100644
--- a/recipes-connectivity/lora/lora-network-server-mtp/lora-network-server.logrotate.conf
+++ b/recipes-connectivity/lora/lora-network-server-mtcap/lora-network-server.logrotate.conf
diff --git a/recipes-connectivity/lora/lora-network-server-mtp_1.0.14.bb b/recipes-connectivity/lora/lora-network-server-mtcap_1.0.15.bb
index 2f5e0bf..56fda88 100644
--- a/recipes-connectivity/lora/lora-network-server-mtp_1.0.14.bb
+++ b/recipes-connectivity/lora/lora-network-server-mtcap_1.0.15.bb
@@ -1,5 +1,5 @@
# THIS RECIPE FOR PICOCELL USES PATCHED LORA NETWORK SERVER THAT SUPPORTS
-# MTP HARDWARE AND V2 PACKET FORWARDER PROTOCOL
+# MTCAP HARDWARE AND V2 PACKET FORWARDER PROTOCOL
DESCRIPTION = "MultiTech LoRa Network Server"
PRIORITY = "optional"
SECTION = "console/utils"
@@ -7,9 +7,9 @@ LICENSE = "Proprietary"
LIC_FILES_CHKSUM = "file://LICENSE;md5=7ffae4666a986c4ccf45e99e464f8402"
DEPENDS = "jsoncpp libmts mosquitto sqlite3"
RDEPENDS_${PN} += "lora-packet-forwarder logrotate"
-PR = "r1"
+PR = "r2"
-SRC_URI = "http://multitech.net/downloads/lora-network-server_${TUNE_PKGARCH}_${PV}.tar.gz \
+SRC_URI = "http://multitech.net/downloads/lora-network-server_arm926ejste_1.0.15-2-g642a748.tar.gz \
file://lora-network-server.conf \
file://lora-network-server.init \
file://lora-network-server.default \
@@ -17,8 +17,8 @@ SRC_URI = "http://multitech.net/downloads/lora-network-server_${TUNE_PKGARCH}_${
file://local_conf.json \
"
-SRC_URI[md5sum] = "6cbae4e82503c5b5078b4ffadcda05a0"
-SRC_URI[sha256sum] = "707e919b02f1f7d3ef8ed66f26b7e8749f4d0db55288062f1aa4c04e5ceccf34"
+SRC_URI[md5sum] = "28db13a45497d678e071a6062a1cc486"
+SRC_URI[sha256sum] = "7558391a635f5c47723d6bd56831d3aa9420169572914b0c8fa6f01aa1730677"
# binaries are already stripped, so suppress warning
INSANE_SKIP_${PN} = "already-stripped"
diff --git a/recipes-connectivity/lora/lora-network-server-mtp/lora-network-server.conf b/recipes-connectivity/lora/lora-network-server-mtp/lora-network-server.conf
deleted file mode 100644
index b018478..0000000
--- a/recipes-connectivity/lora/lora-network-server-mtp/lora-network-server.conf
+++ /dev/null
@@ -1,35 +0,0 @@
-{
- "lora": {
- "netID": "010203", /* netID for beacon packets */
- "frequencyBand": "868", /* US="915", EU="868" */
- "rx1DatarateOffset": 0, /* Datarate offset for mote rx window 1 sent in join response (0-3) */
- "rx2Datarate": 12, /* Datarate for mote rx window 2 sent in join response (7-12) */
- "maxTxPower": 14, /* Max Tx power (dBm), -6 to 26 */
- "frequencyEU": 867500000 /* center freq for extra EU channels (Hz) */
- },
- "udp": {
- "appPortUp": 1784, /* port for user-developed application use */
- "appPortDown": 1786, /* port for user-developed application use */
- "upstreamPort": 1780, /* ports for LoRa network communication */
- "downstreamPort": 1782 /* ports for LoRa network communication */
- },
- "addressRange": {
- "start": "00:00:00:01", /* address range used for mDots */
- "end": "FF:FF:FF:FE"
- },
- "network": {
- "public": true, /* set to false for private LoRa network with mDots + Conduit */
- "leasetime": 0, /* time until mDot join expires (minutes) or 0 for no expiration */
- "name": "YOUR-NETWORK-NAME", /* configure network security */
- "passphrase": "YOUR-NETWORK-PASSPHRASE"
- },
- "log" : {
- "console" : true,
- "syslog" : false,
- "level" : 30, /* error=10, warn=20, info=30, debug=50, trace=60, max=100 */
- "path": "/var/log/lora-network-server.log"
- },
- "mqtt": {
- "enabled": true
- }
-}
diff --git a/recipes-connectivity/lora/lora-network-server_1.0.15.bb b/recipes-connectivity/lora/lora-network-server_1.0.16.bb
index b0adb07..7a3d27c 100644
--- a/recipes-connectivity/lora/lora-network-server_1.0.15.bb
+++ b/recipes-connectivity/lora/lora-network-server_1.0.16.bb
@@ -13,8 +13,8 @@ SRC_URI = "http://multitech.net/downloads/lora-network-server_${TUNE_PKGARCH}_${
file://lora-network-server.logrotate.conf \
"
-SRC_URI[md5sum] = "4afcfa7fd30fadf439b5fb6218d140bd"
-SRC_URI[sha256sum] = "fc15d9e777959dc541c0fa5cd506c8c1047cfddd6b97c344361defc3f84a4098"
+SRC_URI[md5sum] = "3169970ea9b96656847d7472a2cf1f0f"
+SRC_URI[sha256sum] = "81b3c348911464fccbb70e3ff0c60dbcf77af69c2205aec3591fc2ceff7a5c52"
# binaries are already stripped, so suppress warning
INSANE_SKIP_${PN} = "already-stripped"
diff --git a/recipes-connectivity/lora/lora-packet-forwarder/lora-packet-forwarder.init b/recipes-connectivity/lora/lora-packet-forwarder/lora-packet-forwarder.init
index 259243e..8c0894a 100755
--- a/recipes-connectivity/lora/lora-packet-forwarder/lora-packet-forwarder.init
+++ b/recipes-connectivity/lora/lora-packet-forwarder/lora-packet-forwarder.init
@@ -13,7 +13,13 @@ pkt_fwd_pidfile=$run_dir/lora-pkt-fwd-1.pid
log_file=/var/log/lora-pkt-fwd.log
do_start() {
- echo -n "Starting $NAME: "
+ echo "Starting $NAME: "
+
+ eui=$(mts-io-sysfs show lora/eui)
+ # Remove colons
+ clean_eui="${eui//:/}"
+ echo "Setting gateway_id in global_conf.json to $clean_eui"
+ sed -i "s/\"gateway_ID\": \".*\"/\"gateway_ID\": \"$clean_eui\"/" global_conf.json
mkdir -p $run_dir
diff --git a/recipes-connectivity/lora/lora-packet-forwarder_3.0.0.bb b/recipes-connectivity/lora/lora-packet-forwarder_3.0.0.bb
index 588795c..07ba4a8 100644
--- a/recipes-connectivity/lora/lora-packet-forwarder_3.0.0.bb
+++ b/recipes-connectivity/lora/lora-packet-forwarder_3.0.0.bb
@@ -49,7 +49,7 @@ do_install() {
install -m 755 ${WORKDIR}/README.md ${D}${LORA_DIR}/
}
-do_install_append_mtp() {
+do_install_append_mtcap() {
install -d ${D}${sysconfdir}/default
install -m 0644 ${WORKDIR}/lora-packet-forwarder.default ${D}${sysconfdir}/default/lora-packet-forwarder
install -d ${D}${sysconfdir}/init.d