summaryrefslogtreecommitdiff
path: root/recipes-connectivity/lora/lora-packet-forwarder_4.0.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-connectivity/lora/lora-packet-forwarder_4.0.1.bb')
-rw-r--r--recipes-connectivity/lora/lora-packet-forwarder_4.0.1.bb17
1 files changed, 17 insertions, 0 deletions
diff --git a/recipes-connectivity/lora/lora-packet-forwarder_4.0.1.bb b/recipes-connectivity/lora/lora-packet-forwarder_4.0.1.bb
index 18947ec..ce75f25 100644
--- a/recipes-connectivity/lora/lora-packet-forwarder_4.0.1.bb
+++ b/recipes-connectivity/lora/lora-packet-forwarder_4.0.1.bb
@@ -34,6 +34,14 @@ SRC_URI = "git://github.com/Lora-net/packet_forwarder.git;protocol=git \
file://global_conf.json.3.1.0.MTCAP-LORA-1-5.IN865.basic \
file://global_conf.json.3.1.0.MTCAP-LORA-1-5.KR920-LBT.basic \
file://global_conf.json.3.1.0.MTCAP-LORA-1-5.RU864.basic \
+ file://global_conf.json.MTCAP2-LORA-1.5.AS923 \
+ file://global_conf.json.MTCAP2-LORA-1.5.AS923-LBT \
+ file://global_conf.json.MTCAP2-LORA-1.5.AU915 \
+ file://global_conf.json.MTCAP2-LORA-1.5.EU868 \
+ file://global_conf.json.MTCAP2-LORA-1.5.IN865 \
+ file://global_conf.json.MTCAP2-LORA-1.5.KR920-LBT \
+ file://global_conf.json.MTCAP2-LORA-1.5.RU864 \
+ file://global_conf.json.MTCAP2-LORA-1.5.US915 \
file://local_conf.json \
file://lora-packet-forwarder-add-spi-dev-path.patch \
file://lora-packet-forwarder-remove-jit-power-check.patch \
@@ -102,6 +110,15 @@ do_install_append_mtcap() {
install -m 755 ${WORKDIR}/global_conf.json.3.1.0.MTCAP-LORA-1-5.AS923-LBT.basic ${D}${LORA_DIR}/global_conf.json.MTCAP_LORA_1_5.AS923-LBT
install -m 755 ${WORKDIR}/global_conf.json.3.1.0.MTCAP-LORA-1-5.KR920-LBT.basic ${D}${LORA_DIR}/global_conf.json.MTCAP_LORA_1_5.KR920-LBT
install -m 755 ${WORKDIR}/global_conf.json.3.1.0.MTCAP-LORA-1-5.IN865.basic ${D}${LORA_DIR}/global_conf.json.MTCAP_LORA_1_5.IN865
+
+ install -m 755 ${WORKDIR}/global_conf.json.MTCAP2-LORA-1.5.EU868 ${D}${LORA_DIR}/global_conf.json.MTCAP2_LORA_1_5.EU868
+ install -m 755 ${WORKDIR}/global_conf.json.MTCAP2-LORA-1.5.RU864 ${D}${LORA_DIR}/global_conf.json.MTCAP2_LORA_1_5.RU864
+ install -m 755 ${WORKDIR}/global_conf.json.MTCAP2-LORA-1.5.US915 ${D}${LORA_DIR}/global_conf.json.MTCAP2_LORA_1_5.US915
+ install -m 755 ${WORKDIR}/global_conf.json.MTCAP2-LORA-1.5.AU915 ${D}${LORA_DIR}/global_conf.json.MTCAP2_LORA_1_5.AU915
+ install -m 755 ${WORKDIR}/global_conf.json.MTCAP2-LORA-1.5.AS923 ${D}${LORA_DIR}/global_conf.json.MTCAP2_LORA_1_5.AS923
+ install -m 755 ${WORKDIR}/global_conf.json.MTCAP2-LORA-1.5.AS923-LBT ${D}${LORA_DIR}/global_conf.json.MTCAP2_LORA_1_5.AS923-LBT
+ install -m 755 ${WORKDIR}/global_conf.json.MTCAP2-LORA-1.5.KR920-LBT ${D}${LORA_DIR}/global_conf.json.MTCAP2_LORA_1_5.KR920-LBT
+ install -m 755 ${WORKDIR}/global_conf.json.MTCAP2-LORA-1.5.IN865 ${D}${LORA_DIR}/global_conf.json.MTCAP2_LORA_1_5.IN865
}
FILES_${PN} += "${LORA_DIR}"