summaryrefslogtreecommitdiff
path: root/recipes-connectivity/lora/lora-network-server_1.0.22.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-connectivity/lora/lora-network-server_1.0.22.bb')
-rw-r--r--recipes-connectivity/lora/lora-network-server_1.0.22.bb49
1 files changed, 0 insertions, 49 deletions
diff --git a/recipes-connectivity/lora/lora-network-server_1.0.22.bb b/recipes-connectivity/lora/lora-network-server_1.0.22.bb
deleted file mode 100644
index c6b90d6..0000000
--- a/recipes-connectivity/lora/lora-network-server_1.0.22.bb
+++ /dev/null
@@ -1,49 +0,0 @@
-DESCRIPTION = "MultiTech LoRa Network Server"
-PRIORITY = "optional"
-SECTION = "console/utils"
-LICENSE = "Proprietary"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=7ffae4666a986c4ccf45e99e464f8402"
-DEPENDS = "jsoncpp libmts mosquitto sqlite3"
-RDEPENDS_${PN} += "lora-packet-forwarder logrotate"
-PR = "r1"
-
-SRC_URI = "http://multitech.net/downloads/lora-network-server_${TUNE_PKGARCH}_${PV}.tar.gz \
- file://lora-network-server.init \
- file://lora-network-server.default \
- file://lora-network-server.logrotate.conf \
- "
-
-SRC_URI[md5sum] = "100b46847aedf418b07e4a02986f7133"
-SRC_URI[sha256sum] = "3da7223de83b558f4e1689c0d8f0fa34c2e4e7faecaa1372495c0e579db96efc"
-
-# binaries are already stripped, so suppress warning
-INSANE_SKIP_${PN} = "already-stripped"
-
-S = "${WORKDIR}"
-
-LORA_DIR = "/opt/lora"
-
-do_compile() {
-}
-
-inherit update-rc.d
-
-INITSCRIPT_NAME = "lora-network-server"
-INITSCRIPT_PARAMS = "defaults 80 30"
-
-do_install() {
- install -d ${D}${LORA_DIR}
- install -m 0755 lora-network-server ${D}${LORA_DIR}/
- install -m 0644 lora-network-server.conf.sample ${D}${LORA_DIR}/lora-network-server.conf.sample
-
- install -d ${D}${sysconfdir}/default
- install -m 0644 ${WORKDIR}/lora-network-server.default ${D}${sysconfdir}/default/lora-network-server
- install -d ${D}${sysconfdir}/init.d
- install -m 0755 ${WORKDIR}/lora-network-server.init ${D}${sysconfdir}/init.d/lora-network-server
- install -d ${D}${sysconfdir}/logrotate.d
- install -m 0644 ${WORKDIR}/lora-network-server.logrotate.conf ${D}${sysconfdir}/logrotate.d/lora-network-server.conf
-}
-
-CONFFILES_${PN} = "${sysconfdir}/default/lora-network-server"
-FILES_${PN} += "${LORA_DIR}"
-FILES_${PN}-dbg += "${LORA_DIR}/.debug"