summaryrefslogtreecommitdiff
path: root/recipes-connectivity/lora/lora-network-server-mtcap_2.0.13.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-connectivity/lora/lora-network-server-mtcap_2.0.13.bb')
-rw-r--r--recipes-connectivity/lora/lora-network-server-mtcap_2.0.13.bb49
1 files changed, 49 insertions, 0 deletions
diff --git a/recipes-connectivity/lora/lora-network-server-mtcap_2.0.13.bb b/recipes-connectivity/lora/lora-network-server-mtcap_2.0.13.bb
new file mode 100644
index 0000000..7523cbf
--- /dev/null
+++ b/recipes-connectivity/lora/lora-network-server-mtcap_2.0.13.bb
@@ -0,0 +1,49 @@
+# THIS RECIPE FOR PICOCELL USES PATCHED LORA NETWORK SERVER THAT SUPPORTS
+# MTCAP HARDWARE AND V2 PACKET FORWARDER PROTOCOL
+DESCRIPTION = "MultiTech LoRa Network Server"
+PRIORITY = "optional"
+SECTION = "console/utils"
+LICENSE = "Proprietary"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=7ffae4666a986c4ccf45e99e464f8402"
+DEPENDS = "jsoncpp libmts mosquitto sqlite3 curl gnutls"
+RDEPENDS_${PN} += "lora-packet-forwarder logrotate bash"
+PR = "r3"
+
+SRC_URI = "http://multitech.net/downloads/lora-network-server_${TUNE_PKGARCH}_${PV}.tar.gz \
+ file://lora-network-server.conf \
+ file://lora-network-server.init \
+ file://lora-network-server.default \
+ file://lora-network-server.logrotate.conf \
+ file://local_conf.json \
+ "
+
+SRC_URI[md5sum] = "3c9c62d0e721a4b588d602cc36052798"
+SRC_URI[sha256sum] = "3499b14fc84c241401cf13089298192e1e3c4df2b977381f823b4aa82263b781"
+
+# binaries are already stripped, so suppress warning
+INSANE_SKIP_${PN} = "already-stripped"
+
+S = "${WORKDIR}"
+
+LORA_DIR = "/opt/lora"
+
+do_compile() {
+}
+
+do_install() {
+ install -d ${D}${LORA_DIR}
+ install -m 0755 lora-network-server ${D}${LORA_DIR}/
+ install -m 0644 ${WORKDIR}/lora-network-server.conf ${D}${LORA_DIR}/
+ install -m 0755 ${WORKDIR}/local_conf.json ${D}${LORA_DIR}/
+
+ install -d ${D}${sysconfdir}/default
+ install -m 0644 ${WORKDIR}/lora-network-server.default ${D}${sysconfdir}/default/lora-network-server
+ install -d ${D}${sysconfdir}/init.d
+ install -m 0755 ${WORKDIR}/lora-network-server.init ${D}${sysconfdir}/init.d/lora-network-server
+ install -d ${D}${sysconfdir}/logrotate.d
+ install -m 0644 ${WORKDIR}/lora-network-server.logrotate.conf ${D}${sysconfdir}/logrotate.d/lora-network-server.conf
+}
+
+CONFFILES_${PN} = "${sysconfdir}/default/lora-network-server"
+FILES_${PN} += "${LORA_DIR}"
+FILES_${PN}-dbg += "${LORA_DIR}/.debug"