summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rwxr-xr-xrecipes-core/multitech/config/chat_wrapper4
-rw-r--r--recipes-core/multitech/config_2.3.bb2
2 files changed, 5 insertions, 1 deletions
diff --git a/recipes-core/multitech/config/chat_wrapper b/recipes-core/multitech/config/chat_wrapper
index 3c05622..bb25d38 100755
--- a/recipes-core/multitech/config/chat_wrapper
+++ b/recipes-core/multitech/config/chat_wrapper
@@ -144,6 +144,10 @@ if [[ $MPDP != $PDP ]] || [[ $MAPN != $APN ]] || \
LOGMSG=$(/usr/bin/radio-cmd ${RADIOOPTION} -t10000 "${CMDSTR}" 2>&1)
${LOG} "Got response ${LOGMSG}"
/usr/bin/radio-cmd ${RADIOOPTION} -t10000 'AT+COPS=0'
+ sleep 1
+ /usr/bin/radio-cmd ${RADIOOPTION} -t10000 'AT+CFUN=0'
+ /usr/bin/radio-cmd ${RADIOOPTION} -t10000 'AT+CFUN=1'
+ sleep 1
${LOG} "New context is set. Wait up to $REGWAITTIME seconds to register"
# Wait for registration
uptime=$(cat /proc/uptime)
diff --git a/recipes-core/multitech/config_2.3.bb b/recipes-core/multitech/config_2.3.bb
index 9a4dabf..84721a7 100644
--- a/recipes-core/multitech/config_2.3.bb
+++ b/recipes-core/multitech/config_2.3.bb
@@ -4,7 +4,7 @@ LICENSE = "MIT"
RDEPENDS_${PN} += "bash"
LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
PACKAGE_ARCH = "all"
-PR = "r5"
+PR = "r6"
PACKAGES =+ "${PN}-mths"
inherit update-rc.d