summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--recipes-ruby/ruby-sqlite3/ruby-sqlite3_1.3.13.bb (renamed from recipes-ruby/ruby-sqlite3/ruby-sqlite3_1.3.7.bb)11
1 files changed, 7 insertions, 4 deletions
diff --git a/recipes-ruby/ruby-sqlite3/ruby-sqlite3_1.3.7.bb b/recipes-ruby/ruby-sqlite3/ruby-sqlite3_1.3.13.bb
index d0cb2b6..fa1ff9e 100644
--- a/recipes-ruby/ruby-sqlite3/ruby-sqlite3_1.3.7.bb
+++ b/recipes-ruby/ruby-sqlite3/ruby-sqlite3_1.3.13.bb
@@ -1,21 +1,24 @@
DESCRIPTION = "Ruby bindings for the SQLite3 embedded database"
-HOMEPAGE = "https://github.com/luislavena/sqlite3-ruby"
+HOMEPAGE = "https://github.com/sparklemotion/sqlite3-ruby"
LICENSE = "custom-freely-distributable"
LIC_FILES_CHKSUM = "file://LICENSE;md5=f24ce0d57c8f8576a36e2803d35bcfec"
SECTION = "console/utils"
PRIORITY = "optional"
-
DEPENDS = "ruby sqlite3"
PR = "r0"
-SRC_URI = "git://github.com/luislavena/sqlite3-ruby.git;tag=v${PV};protocol=git"
+SRC_URI = "git://github.com/sparklemotion/sqlite3-ruby.git;tag=v${PV};branch=1-3-stable;protocol=git"
S = "${WORKDIR}/git"
B = "${S}"
+# RUBY_VERSION
do_compile() {
- ${CC} ${CFLAGS} ${LDFLAGS} -Iext/sqlite3 -Iext/native -I${STAGING_INCDIR}/ruby-1.9.1 -I${STAGING_INCDIR}/ruby-1.9.1/arm-linux-eabi -c ext/sqlite3/*.c
+ fn=$(ls ${STAGING_INCDIR}/ruby-*/ruby.h | head -1)
+ pn=$(dirname $fn)
+ pn2=$(ls -d ${STAGING_INCDIR}/ruby-*/arm-linux-*)
+ ${CC} ${CFLAGS} ${LDFLAGS} -Iext/sqlite3 -Iext/native -I${pn} -I${pn2} -c ext/sqlite3/*.c
${CC} ${CFLAGS} ${LDFLAGS} --shared -o ext/sqlite3/sqlite3_native.so *.o -lsqlite3
}