summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--recipes-connectivity/hostapd/hostap-daemon.inc1
-rw-r--r--recipes-connectivity/hostapd/hostap-daemon_2.4.bb2
-rw-r--r--recipes-connectivity/lora/lora-gateway/library_4.0.cfg16
-rw-r--r--recipes-connectivity/lora/lora-gateway_1.7.0mts.bb60
-rw-r--r--recipes-connectivity/lora/lora-gateway_4.0.1.bb (renamed from recipes-connectivity/lora/lora-gateway.inc)29
-rwxr-xr-xrecipes-connectivity/lora/lora-network-server/lora-network-server.init4
-rw-r--r--recipes-connectivity/lora/lora-network-server_1.0.12.bb (renamed from recipes-connectivity/lora/lora-network-server_1.0.11.bb)4
-rw-r--r--recipes-connectivity/lora/lora-network-server_1.0.13.bb49
-rw-r--r--recipes-connectivity/lora/lora-packet-forwarder/README.md38
-rw-r--r--recipes-connectivity/lora/lora-packet-forwarder_1.4.1.bb5
-rw-r--r--recipes-connectivity/lora/lora-packet-forwarder_3.0.0.bb47
-rw-r--r--recipes-connectivity/usb-gadget-mode/files/usb-gadget.conf3
-rwxr-xr-xrecipes-connectivity/usb-gadget-mode/files/usb-gadget.init5
-rw-r--r--recipes-connectivity/usb-gadget-mode/usb-gadget-mode.bb7
-rw-r--r--recipes-core/images/mlinux-picocell-image.bb52
-rwxr-xr-xscripts/build-feed-extras.sh3
16 files changed, 295 insertions, 30 deletions
diff --git a/recipes-connectivity/hostapd/hostap-daemon.inc b/recipes-connectivity/hostapd/hostap-daemon.inc
index bee65fb..4f8ae21 100644
--- a/recipes-connectivity/hostapd/hostap-daemon.inc
+++ b/recipes-connectivity/hostapd/hostap-daemon.inc
@@ -6,7 +6,6 @@ do_install() {
install -m 0755 ${S}/hostapd ${D}${sbindir}
install -m 0755 ${S}/hostapd_cli ${D}${sbindir}
install -m 755 ${WORKDIR}/init ${D}${sysconfdir}/init.d/hostapd
- echo "WORKDIR is ${WORKDIR}, S is ${S}" >/tmp/jak.txt
install -m 644 -D ${WORKDIR}/cfg80211.conf ${D}${sysconfdir}/modprobe.d/cfg80211.conf
}
diff --git a/recipes-connectivity/hostapd/hostap-daemon_2.4.bb b/recipes-connectivity/hostapd/hostap-daemon_2.4.bb
index df9d305..e64704a 100644
--- a/recipes-connectivity/hostapd/hostap-daemon_2.4.bb
+++ b/recipes-connectivity/hostapd/hostap-daemon_2.4.bb
@@ -4,7 +4,7 @@ HOMEPAGE = "http://hostap.epitest.fi"
SECTION = "kernel/userland"
LICENSE = "BSD-3-Clause"
LIC_FILES_CHKSUM = "file://README;md5=4d53178f44d4b38418a4fa8de365e11c"
-DEPENDS = "libnl openssl"
+DEPENDS = "libnl openssl sqlite3"
SUMMARY = "User space daemon for extended IEEE 802.11 management"
inherit update-rc.d
diff --git a/recipes-connectivity/lora/lora-gateway/library_4.0.cfg b/recipes-connectivity/lora/lora-gateway/library_4.0.cfg
new file mode 100644
index 0000000..d9d3055
--- /dev/null
+++ b/recipes-connectivity/lora/lora-gateway/library_4.0.cfg
@@ -0,0 +1,16 @@
+# That file will be included in the Makefile files that have hardware dependencies
+
+### Debug options ###
+# Set the DEBUG_* to 1 to activate debug mode in individual modules.
+# Warning: that makes the module *very verbose*, do not use for production
+
+DEBUG_AUX= 0
+DEBUG_SPI= 0
+DEBUG_REG= 0
+# jjg - turning this on is useful to get HAL-related error messages that
+# don't print out otherwise. It doesn't seem to add that much printing
+# under normal operation.
+DEBUG_HAL= 1
+DEBUG_LBT= 0
+DEBUG_GPS= 0
+
diff --git a/recipes-connectivity/lora/lora-gateway_1.7.0mts.bb b/recipes-connectivity/lora/lora-gateway_1.7.0mts.bb
index d032f62..13cffd8 100644
--- a/recipes-connectivity/lora/lora-gateway_1.7.0mts.bb
+++ b/recipes-connectivity/lora/lora-gateway_1.7.0mts.bb
@@ -1,7 +1,59 @@
-require lora-gateway.inc
-
+DESCRIPTION = "LoRa Gateway library"
+HOMEPAGE = "https://www.semtech.com/"
+PRIORITY = "optional"
+SECTION = "console/utils"
+# Semtech license is a modified BSD-style license
+LICENSE = "SEMTECH"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=a2bdef95625509f821ba00460e3ae0eb"
+DEPENDS = "libftdi libmpsse libusb1"
+INC_PR = "r9"
PR = "${INC_PR}.1"
-
-SRCREV = "631dfedf1b535b6c3861d3c3868e02f48a84fb06"
BRANCH = "1.7.0-mts"
+SRCREV = "631dfedf1b535b6c3861d3c3868e02f48a84fb06"
+
+SRC_URI = "git://git.multitech.net/lora_gateway;protocol=git;branch=${BRANCH} \
+ file://lora-gateway-debug.patch \
+ file://lora-gateway-sync-word.patch \
+ file://library.cfg \
+ "
+
+S = "${WORKDIR}/git"
+
+CFLAGS += "-Iinc -I. -DLIBFTDI1=1"
+
+do_configure_append() {
+ # copy over custom library.cfg
+ cp ${WORKDIR}/library.cfg ${S}/libloragw/
+}
+
+do_compile() {
+ oe_runmake
+}
+
+do_install() {
+ install -d ${D}${includedir}/lora
+ install -d ${D}${libdir}/lora
+ install -m 0644 libloragw/libloragw.a ${D}${libdir}/lora
+ install -m 0644 libloragw/library.cfg ${D}${libdir}/lora
+ install -m 0644 libloragw/inc/* ${D}${includedir}/lora
+
+ install -d ${D}/opt/lora
+ install -m 0755 libloragw/test_* ${D}/opt/lora/
+ install -m 0755 util_pkt_logger/util_pkt_logger ${D}/opt/lora/
+ install -m 0755 util_band_survey/util_band_survey ${D}/opt/lora/
+ install -m 0755 util_spi_stress/util_spi_stress ${D}/opt/lora/
+ install -m 0755 util_tx_test/util_tx_test ${D}/opt/lora/
+}
+
+PACKAGES += "${PN}-utils ${PN}-utils-dbg"
+
+FILES_${PN}-utils = "/opt/lora/*"
+FILES_${PN}-utils-dbg = "/opt/lora/.debug"
+FILES_${PN}-dev = "${includedir}/lora ${libdir}/lora/library.cfg"
+FILES_${PN}-staticdev = "${libdir}/lora/libloragw.a"
+
+# disable this on purpose for dev purposes
+do_rm_work() {
+ echo "skipping"
+}
diff --git a/recipes-connectivity/lora/lora-gateway.inc b/recipes-connectivity/lora/lora-gateway_4.0.1.bb
index b2dea9a..5175c1f 100644
--- a/recipes-connectivity/lora/lora-gateway.inc
+++ b/recipes-connectivity/lora/lora-gateway_4.0.1.bb
@@ -1,27 +1,28 @@
DESCRIPTION = "LoRa Gateway library"
-HOMEPAGE = "https://www.semtech.com/"
+HOMEPAGE = "https://github.com/Lora-net/lora_gateway"
PRIORITY = "optional"
SECTION = "console/utils"
# Semtech license is a modified BSD-style license
LICENSE = "SEMTECH"
LIC_FILES_CHKSUM = "file://LICENSE;md5=a2bdef95625509f821ba00460e3ae0eb"
-DEPENDS = "libftdi libmpsse libusb1"
-INC_PR = "r9"
-BRANCH ?= "master"
-
-SRC_URI = "git://git.multitech.net/lora_gateway;protocol=git;branch=${BRANCH} \
- file://lora-gateway-debug.patch \
- file://lora-gateway-sync-word.patch \
- file://library.cfg \
+DEPENDS = ""
+PR = "r1"
+SRCREV = "v${PV}"
+
+SRC_URI = "git://github.com/Lora-net/lora_gateway.git;protocol=git \
+ file://library_4.0.cfg \
"
+SRC_URI[md5sum] = "9e06a3733a9fea39a3d61f77b412badf"
+SRC_URI[sha256sum] = "28fbfe098013908794b32e51d1fed4427f20dd6c8adbbca78df2e1800f5c84dc"
+
S = "${WORKDIR}/git"
-CFLAGS += "-Iinc -I. -DLIBFTDI1=1"
+CFLAGS += "-Iinc -I."
do_configure_append() {
- # copy over custom library.cfg
- cp ${WORKDIR}/library.cfg ${S}/libloragw/
+ # copy over custom library_4.0.cfg
+ cp ${WORKDIR}/library_4.0.cfg ${S}/libloragw/library.cfg
}
do_compile() {
@@ -34,11 +35,12 @@ do_install() {
install -m 0644 libloragw/libloragw.a ${D}${libdir}/lora
install -m 0644 libloragw/library.cfg ${D}${libdir}/lora
install -m 0644 libloragw/inc/* ${D}${includedir}/lora
+ install -m 0644 libloragw/readme.md ${D}${libdir}/lora
install -d ${D}/opt/lora
install -m 0755 libloragw/test_* ${D}/opt/lora/
install -m 0755 util_pkt_logger/util_pkt_logger ${D}/opt/lora/
- install -m 0755 util_band_survey/util_band_survey ${D}/opt/lora/
+ install -m 0755 util_spectral_scan/util_spectral_scan ${D}/opt/lora/
install -m 0755 util_spi_stress/util_spi_stress ${D}/opt/lora/
install -m 0755 util_tx_test/util_tx_test ${D}/opt/lora/
}
@@ -54,3 +56,4 @@ FILES_${PN}-staticdev = "${libdir}/lora/libloragw.a"
do_rm_work() {
echo "skipping"
}
+
diff --git a/recipes-connectivity/lora/lora-network-server/lora-network-server.init b/recipes-connectivity/lora/lora-network-server/lora-network-server.init
index 4baad10..4b80dc7 100755
--- a/recipes-connectivity/lora/lora-network-server/lora-network-server.init
+++ b/recipes-connectivity/lora/lora-network-server/lora-network-server.init
@@ -55,9 +55,9 @@ do_start() {
mkdir -p $run_dir/1
# start network server
start-stop-daemon --start --background --make-pidfile \
- --pidfile $net_server_pidfile --exec $net_server -- \
+ --pidfile $net_server_pidfile --startas /bin/bash -- -c "exec $net_server \
-c $conf_file --lora-eui $lora_eui --lora-path $run_dir --db $conf_db \
- --noconsole -l $net_server_log
+ --noconsole -l $net_server_log >> $net_server_log 2>&1"
sleep 2
# start packet forwarder
start-stop-daemon --start --background --make-pidfile \
diff --git a/recipes-connectivity/lora/lora-network-server_1.0.11.bb b/recipes-connectivity/lora/lora-network-server_1.0.12.bb
index 05e392b..4873822 100644
--- a/recipes-connectivity/lora/lora-network-server_1.0.11.bb
+++ b/recipes-connectivity/lora/lora-network-server_1.0.12.bb
@@ -13,8 +13,8 @@ SRC_URI = "http://multitech.net/downloads/lora-network-server_${TUNE_PKGARCH}_${
file://lora-network-server.logrotate.conf \
"
-SRC_URI[md5sum] = "87f2412864a5174b3c2b8a0f2da96fc1"
-SRC_URI[sha256sum] = "fc400cac0af7e69ae3d016d3ea9a2bdda310afb4ed6089bfed923509f0f46623"
+SRC_URI[md5sum] = "4d9e6a1b5e121f9af77b4257d7972f1d"
+SRC_URI[sha256sum] = "c625ed2414c8e1711a3da1cec4c8ced70bcbbab24c9461106cdf9576ca3f2864"
# binaries are already stripped, so suppress warning
INSANE_SKIP_${PN} = "already-stripped"
diff --git a/recipes-connectivity/lora/lora-network-server_1.0.13.bb b/recipes-connectivity/lora/lora-network-server_1.0.13.bb
new file mode 100644
index 0000000..1cf41f7
--- /dev/null
+++ b/recipes-connectivity/lora/lora-network-server_1.0.13.bb
@@ -0,0 +1,49 @@
+DESCRIPTION = "MultiTech LoRa Network Server"
+PRIORITY = "optional"
+SECTION = "console/utils"
+LICENSE = "Proprietary"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=7ffae4666a986c4ccf45e99e464f8402"
+DEPENDS = "jsoncpp libmts mosquitto sqlite3"
+RDEPENDS_${PN} += "lora-packet-forwarder logrotate"
+PR = "r0"
+
+SRC_URI = "http://multitech.net/downloads/lora-network-server_${TUNE_PKGARCH}_${PV}.tar.gz \
+ file://lora-network-server.init \
+ file://lora-network-server.default \
+ file://lora-network-server.logrotate.conf \
+ "
+
+SRC_URI[md5sum] = "8785cbe4a70ee288fa09f00593b1fdb1"
+SRC_URI[sha256sum] = "5e6450244f21b4c28e780f36b3d1e7bf502ab25f835a0c21295caac11faec69b"
+
+# binaries are already stripped, so suppress warning
+INSANE_SKIP_${PN} = "already-stripped"
+
+S = "${WORKDIR}"
+
+LORA_DIR = "/opt/lora"
+
+do_compile() {
+}
+
+inherit update-rc.d
+
+INITSCRIPT_NAME = "lora-network-server"
+INITSCRIPT_PARAMS = "defaults 80 30"
+
+do_install() {
+ install -d ${D}${LORA_DIR}
+ install -m 0755 lora-network-server ${D}${LORA_DIR}/
+ install -m 0644 lora-network-server.conf.sample ${D}${LORA_DIR}/lora-network-server.conf.sample
+
+ install -d ${D}${sysconfdir}/default
+ install -m 0644 ${WORKDIR}/lora-network-server.default ${D}${sysconfdir}/default/lora-network-server
+ install -d ${D}${sysconfdir}/init.d
+ install -m 0755 ${WORKDIR}/lora-network-server.init ${D}${sysconfdir}/init.d/lora-network-server
+ install -d ${D}${sysconfdir}/logrotate.d
+ install -m 0644 ${WORKDIR}/lora-network-server.logrotate.conf ${D}${sysconfdir}/logrotate.d/lora-network-server.conf
+}
+
+CONFFILES_${PN} = "${sysconfdir}/default/lora-network-server"
+FILES_${PN} += "${LORA_DIR}"
+FILES_${PN}-dbg += "${LORA_DIR}/.debug"
diff --git a/recipes-connectivity/lora/lora-packet-forwarder/README.md b/recipes-connectivity/lora/lora-packet-forwarder/README.md
new file mode 100644
index 0000000..c927c60
--- /dev/null
+++ b/recipes-connectivity/lora/lora-packet-forwarder/README.md
@@ -0,0 +1,38 @@
+
+
+(c) Senet, Inc 2016
+
+
+
+3rd Party Licenses
+------------------
+
+This software incorporates the lora_gateway software which requires the
+following statement to be included in its distribution.
+
+Copyright (c) 2013, SEMTECH S.A.
+All rights reserved.
+
+Redistribution and use in source and binary forms, with or without
+modification, are permitted provided that the following conditions are met:
+ * Redistributions of source code must retain the above copyright
+ notice, this list of conditions and the following disclaimer.
+ * Redistributions in binary form must reproduce the above copyright
+ notice, this list of conditions and the following disclaimer in the
+ documentation and/or other materials provided with the distribution.
+ * Neither the name of the Semtech corporation nor the
+ names of its contributors may be used to endorse or promote products
+ derived from this software without specific prior written permission.
+
+THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS" AND
+ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED
+WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE
+DISCLAIMED. IN NO EVENT SHALL SEMTECH S.A. BE LIABLE FOR ANY
+DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES
+(INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES;
+LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND
+ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
+(INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
+SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+
diff --git a/recipes-connectivity/lora/lora-packet-forwarder_1.4.1.bb b/recipes-connectivity/lora/lora-packet-forwarder_1.4.1.bb
index bbb379d..62e6f4c 100644
--- a/recipes-connectivity/lora/lora-packet-forwarder_1.4.1.bb
+++ b/recipes-connectivity/lora/lora-packet-forwarder_1.4.1.bb
@@ -6,7 +6,7 @@ SECTION = "console/utils"
LICENSE = "SEMTECH"
LIC_FILES_CHKSUM = "file://LICENSE;md5=22af7693d7b76ef0fc76161c4be76c45"
DEPENDS = "lora-gateway"
-PR = "r9"
+PR = "r10"
# tag v1.4.1
SRCREV = "0011a60759a7d81656a5393e97089daab1ff1a81"
@@ -19,6 +19,7 @@ SRC_URI = "git://github.com/Lora-net/packet_forwarder.git;protocol=git \
file://lora-packet-forwarder-mts-enhancements.patch \
file://lora-packet-forwarder-synch-word.patch \
file://lora-packet-forwarder-add-queue.patch \
+ file://README.md \
"
S = "${WORKDIR}/git"
@@ -41,6 +42,8 @@ do_install() {
install -m 755 beacon_pkt_fwd/beacon_pkt_fwd ${D}${LORA_DIR}/
install -m 755 util_sink/util_sink ${D}${LORA_DIR}/
install -m 755 util_ack/util_ack ${D}${LORA_DIR}/
+ install -m 755 ${WORKDIR}/README.md ${D}${LORA_DIR}/
+
# skip util_tx_test since it conflicts with one in lora-gateway
# install -m 755 util_tx_test/util_tx_test ${D}${LORA_DIR}/
diff --git a/recipes-connectivity/lora/lora-packet-forwarder_3.0.0.bb b/recipes-connectivity/lora/lora-packet-forwarder_3.0.0.bb
new file mode 100644
index 0000000..ba5aa40
--- /dev/null
+++ b/recipes-connectivity/lora/lora-packet-forwarder_3.0.0.bb
@@ -0,0 +1,47 @@
+DESCRIPTION = "LoRa Packet Forwarder"
+HOMEPAGE = "https://github.com/Lora-net/packet_forwarder"
+PRIORITY = "optional"
+SECTION = "console/utils"
+# Semtech license is a modified BSD-style license
+LICENSE = "SEMTECH"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=22af7693d7b76ef0fc76161c4be76c45"
+DEPENDS = "lora-gateway"
+PR = "r0"
+
+SRCREV = "v${PV}"
+
+SRC_URI = "git://github.com/Lora-net/packet_forwarder.git;protocol=git \
+ file://README.md \
+"
+
+S = "${WORKDIR}/git"
+
+LORA_DIR = "/opt/lora"
+
+export LGW_PATH = "${STAGING_LIBDIR}/lora"
+export LGW_INC = "${STAGING_INCDIR}/lora"
+
+CFLAGS += "-I${LGW_INC} -Iinc -I."
+
+do_compile() {
+ oe_runmake
+}
+
+do_install() {
+ install -d ${D}${LORA_DIR}
+ install -m 755 lora_pkt_fwd/lora_pkt_fwd ${D}${LORA_DIR}/
+ install -m 755 lora_pkt_fwd/cfg/global_conf.json.PCB_E336.EU868.basic ${D}${LORA_DIR}/global_conf.json
+
+ install -m 755 util_sink/util_sink ${D}${LORA_DIR}/
+ install -m 755 util_ack/util_ack ${D}${LORA_DIR}/
+ install -m 755 util_tx_test/util_tx_test ${D}${LORA_DIR}/
+ install -m 755 ${WORKDIR}/README.md ${D}${LORA_DIR}/
+}
+
+FILES_${PN} += "${LORA_DIR}"
+FILES_${PN}-dbg += "${LORA_DIR}/.debug"
+
+# disable this on purpose for dev purposes
+do_rm_work() {
+ echo "skipping"
+}
diff --git a/recipes-connectivity/usb-gadget-mode/files/usb-gadget.conf b/recipes-connectivity/usb-gadget-mode/files/usb-gadget.conf
index ecf0844..f3a7a6b 100644
--- a/recipes-connectivity/usb-gadget-mode/files/usb-gadget.conf
+++ b/recipes-connectivity/usb-gadget-mode/files/usb-gadget.conf
@@ -1,3 +1,6 @@
+# set to "no" to disable usb-gadget
+ENABLED="yes"
+
USB_MODE="serial"
MODULE_OPTIONS=""
diff --git a/recipes-connectivity/usb-gadget-mode/files/usb-gadget.init b/recipes-connectivity/usb-gadget-mode/files/usb-gadget.init
index 7bf456b..403fd23 100755
--- a/recipes-connectivity/usb-gadget-mode/files/usb-gadget.init
+++ b/recipes-connectivity/usb-gadget-mode/files/usb-gadget.init
@@ -10,6 +10,11 @@
#
# 20070606 - v0.0.1 - Initial release
+ENABLED="yes"
+
+[ -r /etc/default/usb-gadget ] && source /etc/default/usb-gadget
+[ "$ENABLED" == "yes" ] || exit 0
+
case "$1" in
start) usb-gadget ;;
esac
diff --git a/recipes-connectivity/usb-gadget-mode/usb-gadget-mode.bb b/recipes-connectivity/usb-gadget-mode/usb-gadget-mode.bb
index 3b547cb..6887089 100644
--- a/recipes-connectivity/usb-gadget-mode/usb-gadget-mode.bb
+++ b/recipes-connectivity/usb-gadget-mode/usb-gadget-mode.bb
@@ -10,7 +10,7 @@ SECTION = "console/network"
LICENSE = "GPLv2"
LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
PV = "0.0.2"
-PR = "r2"
+PR = "r3"
SRC_URI = "\
file://usb-gadget.conf \
@@ -29,6 +29,11 @@ do_install() {
install -m 0755 ${WORKDIR}/usb-gadget ${D}${bindir}
}
+# disbale usb-gadget for mtp hardware
+do_install_append_mtp() {
+ sed -i 's/ENABLED="yes"/ENABLED="no"/g' ${D}${sysconfdir}/default/usb-gadget
+}
+
pkg_postinst_${PN}() {
test -n "$D" && opt="-r $D"
update-rc.d $opt usb-gadget defaults 50
diff --git a/recipes-core/images/mlinux-picocell-image.bb b/recipes-core/images/mlinux-picocell-image.bb
index 09e0fd6..d839260 100644
--- a/recipes-core/images/mlinux-picocell-image.bb
+++ b/recipes-core/images/mlinux-picocell-image.bb
@@ -1,7 +1,51 @@
-require mlinux-base-image.bb
+DESCRIPTION = "mLinux PicoCell image"
+
+require mlinux-minimal-image.bb
+
+FILESYSTEM_FEATURES = "dosfstools \
+ cifs-utils \
+ lsof \
+ "
+
+NETWORKING_FEATURES += "bridge-utils \
+ inetutils-ftp \
+ openssl \
+ rsync \
+ iperf \
+ mii-diag \
+ tcpdump \
+ netcat \
+ wget \
+ strongswan \
+ "
+
+TIME_FEATURES = "tzdata tzdata-africa tzdata-americas tzdata-antarctica tzdata-arctic \
+ tzdata-asia tzdata-atlantic tzdata-australia tzdata-europe tzdata-pacific \
+ tzdata-misc \
+ cronie \
+ ntpdate \
+ "
+
+MULTITECH_FEATURES += " \
+ u-boot-linux-utils \
+ mlinux-scripts \
+ reset-handler \
+ radio-cmd radio-query \
+ jsparser \
+ "
+
+LORA_FEATURES = "lora-packet-forwarder \
+ lora-packet-forwarder-dbg"
+
+MISC_FEATURES = "minicom lrzsz nano"
+
+# Extra stuff to install
+IMAGE_INSTALL += " \
+ ${FILESYSTEM_FEATURES} \
+ ${TIME_FEATURES} \
+ ${LORA_FEATURES} \
+ ${MISC_FEATURES} \
+ "
# Multi-Tech SMS Utility (see http://git.multitech.net)
IMAGE_INSTALL += "sms-utils"
-
-# MQTT server
-IMAGE_INSTALL += "mosquitto mosquitto-clients"
diff --git a/scripts/build-feed-extras.sh b/scripts/build-feed-extras.sh
index 6ec3359..be3b86c 100755
--- a/scripts/build-feed-extras.sh
+++ b/scripts/build-feed-extras.sh
@@ -5,5 +5,6 @@ FS_PACKAGES="sshfs-fuse fuse-exfat exfat-utils"
NET_PACKAGES="wget netcat ipsec-tools openvpn iftop dnsmasq strongswan stunnel tunctl"
UTIL_PACKAGES="logrotate fatrace stressapptest gawk rsyslog zip gnupg rrdtool"
DEV_PACKAGES="node-red mono gdb git vim python-pip python-pyopenssl"
+SUP_PACKAGES="pps-tools"
-bitbake linux-firmware $FS_PACKAGES $NET_PACKAGES $UTIL_PACKAGES $DEV_PACKAGES
+bitbake linux-firmware $FS_PACKAGES $NET_PACKAGES $UTIL_PACKAGES $DEV_PACKAGES $SUP_PACKAGES