summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--recipes-connectivity/lora/lora-gateway/ln-lora-spi-dev.sh12
-rw-r--r--recipes-connectivity/lora/lora-gateway_4.0.1.bb13
-rwxr-xr-xrecipes-connectivity/lora/lora-network-server/lora-network-server.init28
-rw-r--r--recipes-connectivity/lora/lora-network-server_1.0.16.bb (renamed from recipes-connectivity/lora/lora-network-server_1.0.14.bb)4
-rw-r--r--recipes-connectivity/lora/lora-packet-forwarder/global_conf.json.3.0.0.MTAC_LORA_1_0.EU868.basic.clksrc0225
-rw-r--r--recipes-connectivity/lora/lora-packet-forwarder/global_conf.json.3.0.0.MTAC_LORA_1_5.EU868.basic.clksrc0225
-rw-r--r--recipes-connectivity/lora/lora-packet-forwarder_3.0.0.bb17
-rw-r--r--recipes-core/images/mlinux-base-image.bb2
-rw-r--r--recipes-core/images/mlinux-factory-image.bb2
-rw-r--r--recipes-core/images/mlinux-xrs9113-base-image.bb65
-rw-r--r--recipes-core/images/mlinux-xrs9113-factory-image.bb83
11 files changed, 651 insertions, 25 deletions
diff --git a/recipes-connectivity/lora/lora-gateway/ln-lora-spi-dev.sh b/recipes-connectivity/lora/lora-gateway/ln-lora-spi-dev.sh
new file mode 100644
index 0000000..c350fff
--- /dev/null
+++ b/recipes-connectivity/lora/lora-gateway/ln-lora-spi-dev.sh
@@ -0,0 +1,12 @@
+#!/bin/bash
+
+port1=/sys/devices/platform/mts-io/ap1
+port2=/sys/devices/platform/mts-io/ap2
+
+lora_hw=$(mts-io-sysfs show lora/hw-version 2> /dev/null)
+
+if [ -d $port1 ] && [[ $(cat $port1/hw-version) = $lora_hw ]]; then
+ ln -sf /dev/spidev32766.2 /dev/spidev0.0
+elif [ -d $port2 ] && [[ $(cat $port2/hw-version) = $lora_hw ]]; then
+ ln -sf /dev/spidev32765.2 /dev/spidev0.0
+fi
diff --git a/recipes-connectivity/lora/lora-gateway_4.0.1.bb b/recipes-connectivity/lora/lora-gateway_4.0.1.bb
index ce6dd89..5e269e1 100644
--- a/recipes-connectivity/lora/lora-gateway_4.0.1.bb
+++ b/recipes-connectivity/lora/lora-gateway_4.0.1.bb
@@ -6,13 +6,14 @@ SECTION = "console/utils"
LICENSE = "SEMTECH"
LIC_FILES_CHKSUM = "file://LICENSE;md5=a2bdef95625509f821ba00460e3ae0eb"
DEPENDS = ""
-PR = "r6"
+PR = "r8"
SRCREV = "v${PV}"
SRC_URI = "git://github.com/Lora-net/lora_gateway.git;protocol=git \
file://lora-gateway-add-fpga-version-28.patch \
file://library_4.0.cfg \
file://lora-gateway-add-spi-path-function.patch \
+ file://ln-lora-spi-dev.sh \
file://lora-gateway-change-util-tx-continuous-clksrc.patch \
"
@@ -38,7 +39,10 @@ do_install() {
install -m 0644 libloragw/libloragw.a ${D}${libdir}/lora
install -m 0644 libloragw/library.cfg ${D}${libdir}/lora
install -m 0644 libloragw/inc/* ${D}${includedir}/lora
- install -m 0644 libloragw/readme.md ${D}${libdir}/lora
+ install -m 0644 libloragw/readme.md ${D}${libdir}/lora/lora-gw-readme.md
+
+ install -d ${D}/opt/lora/
+ install -m 0755 ${WORKDIR}/ln-lora-spi-dev.sh ${D}/opt/lora/
install -d ${D}/opt/lora/gateway-utils
install -m 0755 libloragw/test_* ${D}/opt/lora/gateway-utils/
@@ -52,8 +56,9 @@ do_install() {
PACKAGES += "${PN}-utils ${PN}-utils-dbg"
-FILES_${PN}-utils = "/opt/lora/gateway-utils/*"
-FILES_${PN}-utils-dbg = "/opt/lora/gateway-utils/.debug"
+FILES_${PN} = "${libdir}/lora/lora-gw-readme.md"
+FILES_${PN}-utils = "/opt/lora/gateway-utils/* /opt/lora/ln-lora-spi-dev.sh"
+FILES_${PN}-utils-dbg = "/opt/lora/gateway-utils/.debug /opt/lora/ln-lora-spi-dev.sh"
FILES_${PN}-dev = "${includedir}/lora ${libdir}/lora/library.cfg"
FILES_${PN}-staticdev = "${libdir}/lora/libloragw.a"
diff --git a/recipes-connectivity/lora/lora-network-server/lora-network-server.init b/recipes-connectivity/lora/lora-network-server/lora-network-server.init
index 7a72b34..d59a851 100755
--- a/recipes-connectivity/lora/lora-network-server/lora-network-server.init
+++ b/recipes-connectivity/lora/lora-network-server/lora-network-server.init
@@ -30,9 +30,8 @@ port2=/sys/devices/platform/mts-io/ap2
lora_us_id="MTAC-LORA-915"
lora_eu_id="MTAC-LORA-868"
-lora_usb_hw="MTAC-LORA-1.0"
-lora_spi_hw="MTAC-LORA-1.1"
-lora_h_hw="MTAC-LORA-1.5"
+lora_1_0_hw="MTAC-LORA-1.0"
+lora_1_5_h_hw="MTAC-LORA-1.5"
read_card_info() {
@@ -52,16 +51,23 @@ card_found() {
ln -sf /dev/spidev32765.2 /dev/spidev0.0
fi
- if [ "$lora_id" = "$lora_us_id" ] || [ "$lora_id" = "$lora_eu_id" ]; then
- if [ "$lora_hw" = "$lora_spi_hw" ] || [ "$lora_hw" = "$lora_h_hw" ]; then
- ln -sf /opt/lora/lora_pkt_fwd $pkt_fwd
- return 0
- elif [ "$lora_hw" = "$lora_usb_hw" ]; then
+ if [[ "$lora_id" =~ "$lora_us_id" ]] || [[ "$lora_id" =~ "$lora_eu_id" ]]; then
+ GLOBAL_CONF=/opt/lora/global_conf.json.MTAC_LORA_1_0
+ if [ "$lora_hw" = "$lora_hw" ] && [[ ! "$lora_id" =~ .*-SPI ]]; then
ln -sf /opt/lora/basic_pkt_fwd-usb $pkt_fwd
- return 0
- else
- return 1
+ else
+ if [ "$lora_hw" = "$lora_1_5_h_hw" ]; then
+ GLOBAL_CONF=/opt/lora/global_conf.json.MTAC_LORA_1_5
+ fi
+ ln -sf /opt/lora/lora_pkt_fwd $pkt_fwd
fi
+
+ diff $GLOBAL_CONF /opt/lora/global_conf.json
+ if [ $? -ne 0 ]; then
+ cp $GLOBAL_CONF /opt/lora/global_conf.json
+ fi
+
+ return 0
else
return 1
fi
diff --git a/recipes-connectivity/lora/lora-network-server_1.0.14.bb b/recipes-connectivity/lora/lora-network-server_1.0.16.bb
index 36d493c..7a3d27c 100644
--- a/recipes-connectivity/lora/lora-network-server_1.0.14.bb
+++ b/recipes-connectivity/lora/lora-network-server_1.0.16.bb
@@ -13,8 +13,8 @@ SRC_URI = "http://multitech.net/downloads/lora-network-server_${TUNE_PKGARCH}_${
file://lora-network-server.logrotate.conf \
"
-SRC_URI[md5sum] = "6cbae4e82503c5b5078b4ffadcda05a0"
-SRC_URI[sha256sum] = "707e919b02f1f7d3ef8ed66f26b7e8749f4d0db55288062f1aa4c04e5ceccf34"
+SRC_URI[md5sum] = "3169970ea9b96656847d7472a2cf1f0f"
+SRC_URI[sha256sum] = "81b3c348911464fccbb70e3ff0c60dbcf77af69c2205aec3591fc2ceff7a5c52"
# binaries are already stripped, so suppress warning
INSANE_SKIP_${PN} = "already-stripped"
diff --git a/recipes-connectivity/lora/lora-packet-forwarder/global_conf.json.3.0.0.MTAC_LORA_1_0.EU868.basic.clksrc0 b/recipes-connectivity/lora/lora-packet-forwarder/global_conf.json.3.0.0.MTAC_LORA_1_0.EU868.basic.clksrc0
new file mode 100644
index 0000000..5e8bec0
--- /dev/null
+++ b/recipes-connectivity/lora/lora-packet-forwarder/global_conf.json.3.0.0.MTAC_LORA_1_0.EU868.basic.clksrc0
@@ -0,0 +1,225 @@
+{
+ "SX1301_conf": {
+ "lorawan_public": true,
+ "clksrc": 0, /* radio_1 provides clock to concentrator */
+ "lbt_cfg": {
+ "enable": false,
+ "rssi_target": 160, /* rssi in dBm = -lbt_rssi_target/2 */
+ "nb_channel": 1,
+ "start_freq": 869525000,
+ "scan_time_us": 5000,
+ "tx_delay_1ch_us": 4000000,
+ "tx_delay_2ch_us": 4000000
+ },
+ "antenna_gain": 0, /* antenna gain, in dBi */
+ "radio_0": {
+ "enable": true,
+ "type": "SX1257",
+ "freq": 867500000,
+ "rssi_offset": -165.0,
+ "tx_enable": true,
+ "tx_freq_min": 863000000,
+ "tx_freq_max": 870000000
+ },
+ "radio_1": {
+ "enable": true,
+ "type": "SX1257",
+ "freq": 868500000,
+ "rssi_offset": -165.0,
+ "tx_enable": false
+ },
+ "chan_multiSF_0": {
+ /* Lora MAC channel, 125kHz, all SF, 868.1 MHz */
+ "enable": true,
+ "radio": 1,
+ "if": -400000
+ },
+ "chan_multiSF_1": {
+ /* Lora MAC channel, 125kHz, all SF, 868.3 MHz */
+ "enable": true,
+ "radio": 1,
+ "if": -200000
+ },
+ "chan_multiSF_2": {
+ /* Lora MAC channel, 125kHz, all SF, 868.5 MHz */
+ "enable": true,
+ "radio": 1,
+ "if": 0
+ },
+ "chan_multiSF_3": {
+ /* Lora MAC channel, 125kHz, all SF, 867.1 MHz */
+ "enable": true,
+ "radio": 0,
+ "if": -400000
+ },
+ "chan_multiSF_4": {
+ /* Lora MAC channel, 125kHz, all SF, 867.3 MHz */
+ "enable": true,
+ "radio": 0,
+ "if": -200000
+ },
+ "chan_multiSF_5": {
+ /* Lora MAC channel, 125kHz, all SF, 867.5 MHz */
+ "enable": true,
+ "radio": 0,
+ "if": 0
+ },
+ "chan_multiSF_6": {
+ /* Lora MAC channel, 125kHz, all SF, 867.7 MHz */
+ "enable": true,
+ "radio": 0,
+ "if": 200000
+ },
+ "chan_multiSF_7": {
+ /* Lora MAC channel, 125kHz, all SF, 867.9 MHz */
+ "enable": true,
+ "radio": 0,
+ "if": 400000
+ },
+ "chan_Lora_std": {
+ /* Lora MAC channel, 250kHz, SF7, 868.3 MHz */
+ "enable": true,
+ "radio": 1,
+ "if": -200000,
+ "bandwidth": 250000,
+ "spread_factor": 7
+ },
+ "chan_FSK": {
+ /* FSK 50kbps channel, 868.8 MHz */
+ "enable": true,
+ "radio": 1,
+ "if": 300000,
+ "bandwidth": 125000,
+ "datarate": 50000
+ },
+ "tx_lut_0": {
+ /* TX gain table, index 0 */
+ "pa_gain": 0,
+ "mix_gain": 8,
+ "rf_power": -6,
+ "dig_gain": 3
+ },
+ "tx_lut_1": {
+ /* TX gain table, index 1 */
+ "pa_gain": 0,
+ "mix_gain": 10,
+ "rf_power": -3,
+ "dig_gain": 3
+ },
+ "tx_lut_2": {
+ /* TX gain table, index 2 */
+ "pa_gain": 0,
+ "mix_gain": 12,
+ "rf_power": 0,
+ "dig_gain": 3
+ },
+ "tx_lut_3": {
+ /* TX gain table, index 3 */
+ "pa_gain": 1,
+ "mix_gain": 8,
+ "rf_power": 3,
+ "dig_gain": 3
+ },
+ "tx_lut_4": {
+ /* TX gain table, index 4 */
+ "pa_gain": 1,
+ "mix_gain": 10,
+ "rf_power": 6,
+ "dig_gain": 3
+ },
+ "tx_lut_5": {
+ /* TX gain table, index 5 */
+ "pa_gain": 1,
+ "mix_gain": 12,
+ "rf_power": 10,
+ "dig_gain": 3
+ },
+ "tx_lut_6": {
+ /* TX gain table, index 6 */
+ "pa_gain": 1,
+ "mix_gain": 12,
+ "rf_power": 11,
+ "dig_gain": 3
+ },
+ "tx_lut_7": {
+ /* TX gain table, index 7 */
+ "pa_gain": 2,
+ "mix_gain": 9,
+ "rf_power": 12,
+ "dig_gain": 3
+ },
+ "tx_lut_8": {
+ /* TX gain table, index 8 */
+ "pa_gain": 1,
+ "mix_gain": 15,
+ "rf_power": 13,
+ "dig_gain": 3
+ },
+ "tx_lut_9": {
+ /* TX gain table, index 9 */
+ "pa_gain": 2,
+ "mix_gain": 10,
+ "rf_power": 14,
+ "dig_gain": 3
+ },
+ "tx_lut_10": {
+ /* TX gain table, index 10 */
+ "pa_gain": 2,
+ "mix_gain": 11,
+ "rf_power": 16,
+ "dig_gain": 3
+ },
+ "tx_lut_11": {
+ /* TX gain table, index 11 */
+ "pa_gain": 3,
+ "mix_gain": 10,
+ "rf_power": 20,
+ "dig_gain": 3
+ },
+ "tx_lut_12": {
+ /* TX gain table, index 12 */
+ "pa_gain": 3,
+ "mix_gain": 11,
+ "rf_power": 23,
+ "dig_gain": 3
+ },
+ "tx_lut_13": {
+ /* TX gain table, index 13 */
+ "pa_gain": 3,
+ "mix_gain": 12,
+ "rf_power": 24,
+ "dig_gain": 3
+ },
+ "tx_lut_14": {
+ /* TX gain table, index 14 */
+ "pa_gain": 3,
+ "mix_gain": 13,
+ "rf_power": 25,
+ "dig_gain": 3
+ },
+ "tx_lut_15": {
+ /* TX gain table, index 15 */
+ "pa_gain": 3,
+ "mix_gain": 15,
+ "rf_power": 26,
+ "dig_gain": 3
+ }
+ },
+
+ "gateway_conf": {
+ "gateway_ID": "AA555A0000000000",
+ /* change with default server address/ports, or overwrite in local_conf.json */
+ "server_address": "localhost",
+ "serv_port_up": 1680,
+ "serv_port_down": 1680,
+ /* adjust the following parameters for your network */
+ "keepalive_interval": 10,
+ "stat_interval": 30,
+ "push_timeout_ms": 100,
+ /* forward only valid packets */
+ "forward_crc_valid": true,
+ "forward_crc_error": false,
+ "forward_crc_disabled": false
+ }
+}
+
diff --git a/recipes-connectivity/lora/lora-packet-forwarder/global_conf.json.3.0.0.MTAC_LORA_1_5.EU868.basic.clksrc0 b/recipes-connectivity/lora/lora-packet-forwarder/global_conf.json.3.0.0.MTAC_LORA_1_5.EU868.basic.clksrc0
new file mode 100644
index 0000000..5e8bec0
--- /dev/null
+++ b/recipes-connectivity/lora/lora-packet-forwarder/global_conf.json.3.0.0.MTAC_LORA_1_5.EU868.basic.clksrc0
@@ -0,0 +1,225 @@
+{
+ "SX1301_conf": {
+ "lorawan_public": true,
+ "clksrc": 0, /* radio_1 provides clock to concentrator */
+ "lbt_cfg": {
+ "enable": false,
+ "rssi_target": 160, /* rssi in dBm = -lbt_rssi_target/2 */
+ "nb_channel": 1,
+ "start_freq": 869525000,
+ "scan_time_us": 5000,
+ "tx_delay_1ch_us": 4000000,
+ "tx_delay_2ch_us": 4000000
+ },
+ "antenna_gain": 0, /* antenna gain, in dBi */
+ "radio_0": {
+ "enable": true,
+ "type": "SX1257",
+ "freq": 867500000,
+ "rssi_offset": -165.0,
+ "tx_enable": true,
+ "tx_freq_min": 863000000,
+ "tx_freq_max": 870000000
+ },
+ "radio_1": {
+ "enable": true,
+ "type": "SX1257",
+ "freq": 868500000,
+ "rssi_offset": -165.0,
+ "tx_enable": false
+ },
+ "chan_multiSF_0": {
+ /* Lora MAC channel, 125kHz, all SF, 868.1 MHz */
+ "enable": true,
+ "radio": 1,
+ "if": -400000
+ },
+ "chan_multiSF_1": {
+ /* Lora MAC channel, 125kHz, all SF, 868.3 MHz */
+ "enable": true,
+ "radio": 1,
+ "if": -200000
+ },
+ "chan_multiSF_2": {
+ /* Lora MAC channel, 125kHz, all SF, 868.5 MHz */
+ "enable": true,
+ "radio": 1,
+ "if": 0
+ },
+ "chan_multiSF_3": {
+ /* Lora MAC channel, 125kHz, all SF, 867.1 MHz */
+ "enable": true,
+ "radio": 0,
+ "if": -400000
+ },
+ "chan_multiSF_4": {
+ /* Lora MAC channel, 125kHz, all SF, 867.3 MHz */
+ "enable": true,
+ "radio": 0,
+ "if": -200000
+ },
+ "chan_multiSF_5": {
+ /* Lora MAC channel, 125kHz, all SF, 867.5 MHz */
+ "enable": true,
+ "radio": 0,
+ "if": 0
+ },
+ "chan_multiSF_6": {
+ /* Lora MAC channel, 125kHz, all SF, 867.7 MHz */
+ "enable": true,
+ "radio": 0,
+ "if": 200000
+ },
+ "chan_multiSF_7": {
+ /* Lora MAC channel, 125kHz, all SF, 867.9 MHz */
+ "enable": true,
+ "radio": 0,
+ "if": 400000
+ },
+ "chan_Lora_std": {
+ /* Lora MAC channel, 250kHz, SF7, 868.3 MHz */
+ "enable": true,
+ "radio": 1,
+ "if": -200000,
+ "bandwidth": 250000,
+ "spread_factor": 7
+ },
+ "chan_FSK": {
+ /* FSK 50kbps channel, 868.8 MHz */
+ "enable": true,
+ "radio": 1,
+ "if": 300000,
+ "bandwidth": 125000,
+ "datarate": 50000
+ },
+ "tx_lut_0": {
+ /* TX gain table, index 0 */
+ "pa_gain": 0,
+ "mix_gain": 8,
+ "rf_power": -6,
+ "dig_gain": 3
+ },
+ "tx_lut_1": {
+ /* TX gain table, index 1 */
+ "pa_gain": 0,
+ "mix_gain": 10,
+ "rf_power": -3,
+ "dig_gain": 3
+ },
+ "tx_lut_2": {
+ /* TX gain table, index 2 */
+ "pa_gain": 0,
+ "mix_gain": 12,
+ "rf_power": 0,
+ "dig_gain": 3
+ },
+ "tx_lut_3": {
+ /* TX gain table, index 3 */
+ "pa_gain": 1,
+ "mix_gain": 8,
+ "rf_power": 3,
+ "dig_gain": 3
+ },
+ "tx_lut_4": {
+ /* TX gain table, index 4 */
+ "pa_gain": 1,
+ "mix_gain": 10,
+ "rf_power": 6,
+ "dig_gain": 3
+ },
+ "tx_lut_5": {
+ /* TX gain table, index 5 */
+ "pa_gain": 1,
+ "mix_gain": 12,
+ "rf_power": 10,
+ "dig_gain": 3
+ },
+ "tx_lut_6": {
+ /* TX gain table, index 6 */
+ "pa_gain": 1,
+ "mix_gain": 12,
+ "rf_power": 11,
+ "dig_gain": 3
+ },
+ "tx_lut_7": {
+ /* TX gain table, index 7 */
+ "pa_gain": 2,
+ "mix_gain": 9,
+ "rf_power": 12,
+ "dig_gain": 3
+ },
+ "tx_lut_8": {
+ /* TX gain table, index 8 */
+ "pa_gain": 1,
+ "mix_gain": 15,
+ "rf_power": 13,
+ "dig_gain": 3
+ },
+ "tx_lut_9": {
+ /* TX gain table, index 9 */
+ "pa_gain": 2,
+ "mix_gain": 10,
+ "rf_power": 14,
+ "dig_gain": 3
+ },
+ "tx_lut_10": {
+ /* TX gain table, index 10 */
+ "pa_gain": 2,
+ "mix_gain": 11,
+ "rf_power": 16,
+ "dig_gain": 3
+ },
+ "tx_lut_11": {
+ /* TX gain table, index 11 */
+ "pa_gain": 3,
+ "mix_gain": 10,
+ "rf_power": 20,
+ "dig_gain": 3
+ },
+ "tx_lut_12": {
+ /* TX gain table, index 12 */
+ "pa_gain": 3,
+ "mix_gain": 11,
+ "rf_power": 23,
+ "dig_gain": 3
+ },
+ "tx_lut_13": {
+ /* TX gain table, index 13 */
+ "pa_gain": 3,
+ "mix_gain": 12,
+ "rf_power": 24,
+ "dig_gain": 3
+ },
+ "tx_lut_14": {
+ /* TX gain table, index 14 */
+ "pa_gain": 3,
+ "mix_gain": 13,
+ "rf_power": 25,
+ "dig_gain": 3
+ },
+ "tx_lut_15": {
+ /* TX gain table, index 15 */
+ "pa_gain": 3,
+ "mix_gain": 15,
+ "rf_power": 26,
+ "dig_gain": 3
+ }
+ },
+
+ "gateway_conf": {
+ "gateway_ID": "AA555A0000000000",
+ /* change with default server address/ports, or overwrite in local_conf.json */
+ "server_address": "localhost",
+ "serv_port_up": 1680,
+ "serv_port_down": 1680,
+ /* adjust the following parameters for your network */
+ "keepalive_interval": 10,
+ "stat_interval": 30,
+ "push_timeout_ms": 100,
+ /* forward only valid packets */
+ "forward_crc_valid": true,
+ "forward_crc_error": false,
+ "forward_crc_disabled": false
+ }
+}
+
diff --git a/recipes-connectivity/lora/lora-packet-forwarder_3.0.0.bb b/recipes-connectivity/lora/lora-packet-forwarder_3.0.0.bb
index c5c9f64..07ba4a8 100644
--- a/recipes-connectivity/lora/lora-packet-forwarder_3.0.0.bb
+++ b/recipes-connectivity/lora/lora-packet-forwarder_3.0.0.bb
@@ -6,7 +6,7 @@ SECTION = "console/utils"
LICENSE = "SEMTECH"
LIC_FILES_CHKSUM = "file://LICENSE;md5=22af7693d7b76ef0fc76161c4be76c45"
DEPENDS = "lora-gateway"
-PR = "r4"
+PR = "r5"
SRCREV = "v${PV}"
@@ -15,6 +15,8 @@ SRC_URI = "git://github.com/Lora-net/packet_forwarder.git;protocol=git \
file://lora-packet-forwarder.init \
file://lora-packet-forwarder.default \
file://global_conf.json.3.0.0.PCB_E336.EU868.basic.clksrc0 \
+ file://global_conf.json.3.0.0.MTAC_LORA_1_0.EU868.basic.clksrc0 \
+ file://global_conf.json.3.0.0.MTAC_LORA_1_5.EU868.basic.clksrc0 \
file://local_conf.json \
file://lora-packet-forwarder-add-spi-dev-path.patch \
"
@@ -35,12 +37,15 @@ do_compile() {
do_install() {
install -d ${D}${LORA_DIR}
install -m 755 lora_pkt_fwd/lora_pkt_fwd ${D}${LORA_DIR}/
- install -m 755 ${WORKDIR}/global_conf.json.3.0.0.PCB_E336.EU868.basic.clksrc0 ${D}${LORA_DIR}/global_conf.json
+ install -m 755 ${WORKDIR}/global_conf.json.3.0.0.MTAC_LORA_1_5.EU868.basic.clksrc0 ${D}${LORA_DIR}/global_conf.json
+ install -m 755 ${WORKDIR}/global_conf.json.3.0.0.MTAC_LORA_1_0.EU868.basic.clksrc0 ${D}${LORA_DIR}/global_conf.json.MTAC_LORA_1_0
+ install -m 755 ${WORKDIR}/global_conf.json.3.0.0.MTAC_LORA_1_5.EU868.basic.clksrc0 ${D}${LORA_DIR}/global_conf.json.MTAC_LORA_1_5
install -m 755 ${WORKDIR}/local_conf.json ${D}${LORA_DIR}/
- install -m 755 util_sink/util_sink ${D}${LORA_DIR}/
- install -m 755 util_ack/util_ack ${D}${LORA_DIR}/
- install -m 755 util_tx_test/util_tx_test ${D}${LORA_DIR}/
+ install -d ${D}${LORA_DIR}/forwarder-utils
+ install -m 755 util_sink/util_sink ${D}${LORA_DIR}/forwarder-utils/
+ install -m 755 util_ack/util_ack ${D}${LORA_DIR}/forwarder-utils/
+ install -m 755 util_tx_test/util_tx_test ${D}${LORA_DIR}/forwarder-utils/
install -m 755 ${WORKDIR}/README.md ${D}${LORA_DIR}/
}
@@ -52,7 +57,7 @@ do_install_append_mtcap() {
}
FILES_${PN} += "${LORA_DIR}"
-FILES_${PN}-dbg += "${LORA_DIR}/.debug"
+FILES_${PN}-dbg += "${LORA_DIR}/.debug ${LORA_DIR}/forwarder-utils/.debug"
# disable this on purpose for dev purposes
do_rm_work() {
diff --git a/recipes-core/images/mlinux-base-image.bb b/recipes-core/images/mlinux-base-image.bb
index 84cead8..6423237 100644
--- a/recipes-core/images/mlinux-base-image.bb
+++ b/recipes-core/images/mlinux-base-image.bb
@@ -54,7 +54,7 @@ MULTITECH_FEATURES += " \
annex-client \
"
-MISC_FEATURES = "minicom lrzsz nano"
+MISC_FEATURES = "minicom lrzsz nano rs9113"
# Extra stuff to install
IMAGE_INSTALL += " \
diff --git a/recipes-core/images/mlinux-factory-image.bb b/recipes-core/images/mlinux-factory-image.bb
index 2a3bef4..6cc7197 100644
--- a/recipes-core/images/mlinux-factory-image.bb
+++ b/recipes-core/images/mlinux-factory-image.bb
@@ -20,7 +20,7 @@ IMAGE_INSTALL += "autossh"
IMAGE_INSTALL += "monit"
# LoRa support (MTAC-LORA accessory card)
-IMAGE_INSTALL += "lora-gateway-utils lora-gateway-usb-utils lora-network-server lora-query lora-packet-forwarder"
+IMAGE_INSTALL += "lora-gateway-utils lora-network-server lora-query"
# MQTT server
IMAGE_INSTALL += "mosquitto mosquitto-clients"
diff --git a/recipes-core/images/mlinux-xrs9113-base-image.bb b/recipes-core/images/mlinux-xrs9113-base-image.bb
new file mode 100644
index 0000000..b90903a
--- /dev/null
+++ b/recipes-core/images/mlinux-xrs9113-base-image.bb
@@ -0,0 +1,65 @@
+DESCRIPTION = "mLinux base image"
+LICENSE = "MIT"
+
+require mlinux-minimal-image.bb
+
+FILESYSTEM_FEATURES = "dosfstools \
+ cifs-utils \
+ lsof \
+ "
+
+NETWORKING_FEATURES += "bridge-utils \
+ inetutils-ftp \
+ openssl \
+ rsync \
+ iperf \
+ mii-diag \
+ tcpdump \
+ netcat \
+ wget \
+ strongswan \
+ "
+
+WIFI_FEATURES = " \
+ libnl \
+ wpa-supplicant \
+ wireless-tools \
+ iw \
+ hostap-daemon hostap-utils \
+ "
+
+BLUETOOTH_FEATURES = "bluez4"
+
+# Add all timezones available
+# ntpdate will sync time every 30 min by default via cron
+TIME_FEATURES = "tzdata tzdata-africa tzdata-americas tzdata-antarctica tzdata-arctic \
+ tzdata-asia tzdata-atlantic tzdata-australia tzdata-europe tzdata-pacific \
+ tzdata-misc \
+ cronie \
+ ntpdate \
+ "
+
+# u-boot-linux-utils: U-Boot environment access from Linux
+# mlinux-scripts: sample scripts for setting up Conduit for various tasks
+# reset-handler: default reset button handler
+# radio-cmd: supports cellular radio activation and other configuration commands
+# radio-query: queries cellular radio for common info (IMEI, RSSI, etc)
+# jsparser: command line tool to parse JSON files
+MULTITECH_FEATURES += " \
+ u-boot-linux-utils \
+ mlinux-scripts \
+ reset-handler \
+ radio-cmd radio-query \
+ jsparser \
+ "
+
+MISC_FEATURES = "minicom lrzsz nano"
+
+# Extra stuff to install
+IMAGE_INSTALL += " \
+ ${WIFI_FEATURES} \
+ ${BLUETOOTH_FEATURES} \
+ ${FILESYSTEM_FEATURES} \
+ ${TIME_FEATURES} \
+ ${MISC_FEATURES} \
+ "
diff --git a/recipes-core/images/mlinux-xrs9113-factory-image.bb b/recipes-core/images/mlinux-xrs9113-factory-image.bb
new file mode 100644
index 0000000..fe2e698
--- /dev/null
+++ b/recipes-core/images/mlinux-xrs9113-factory-image.bb
@@ -0,0 +1,83 @@
+require mlinux-xrs9113-base-image.bb
+
+LIGHTTPD = "lighttpd \
+ lighttpd-module-cgi lighttpd-module-indexfile \
+ lighttpd-module-redirect lighttpd-module-auth \
+ lighttpd-module-access lighttpd-module-accesslog \
+ lighttpd-module-rewrite lighttpd-module-proxy lighttpd-module-fastcgi \
+ lighttpd-module-scgi lighttpd-module-alias \
+ lighttpd-module-dirlisting lighttpd-module-staticfile \
+ "
+
+# Lighttpd web server
+IMAGE_INSTALL += "${LIGHTTPD}"
+
+IMAGE_INSTALL += "sqlite3"
+
+IMAGE_INSTALL += "autossh"
+
+# Monit system/process monitor
+IMAGE_INSTALL += "monit"
+
+# LoRa support (MTAC-LORA accessory card)
+IMAGE_INSTALL += "lora-gateway-utils lora-network-server lora-query"
+
+# MQTT server
+IMAGE_INSTALL += "mosquitto mosquitto-clients"
+
+# Perl support
+IMAGE_INSTALL += "perl"
+IMAGE_INSTALL += "perl-module-io perl-module-fcntl"
+# not in meta-oe or oe-core...
+#IMAGE_INSTALL += "libdevice-serialport-perl"
+#IMAGE_INSTALL += "libexpect-perl"
+
+# Python support
+IMAGE_INSTALL += "python"
+# Python modules
+IMAGE_INSTALL += "python-async \
+python-argparse \
+python-compression \
+python-dateutil \
+python-html \
+python-psutil \
+python-pycurl \
+python-pyopenssl \
+python-pyserial \
+python-pyudev \
+python-pyusb \
+python-simplejson \
+python-sqlite3 \
+python-syslog \
+python-textutils \
+python-unixadmin \
+python-xml \
+"
+
+# Ruby support
+IMAGE_INSTALL += "ruby"
+IMAGE_INSTALL += "ruby-sqlite3"
+IMAGE_INSTALL += "ruby-serialport"
+
+# OpenJDK Java runtime
+IMAGE_INSTALL += "openjdk-7-jre"
+# OpenJDK with JamVM VM (Multi-Tech default)
+IMAGE_INSTALL += "openjdk-7-vm-jamvm"
+# OpenJDK with CACAO VM (run with 'java -cacao')
+IMAGE_INSTALL += "openjdk-7-vm-cacao"
+# OpenJDK Zero VM (run with 'java -zero')
+IMAGE_INSTALL += "openjdk-7-vm-zero"
+
+# PHP support
+IMAGE_INSTALL += "php php-cli php-cgi"
+
+# Node.js support
+IMAGE_INSTALL += "nodejs nodejs-npm"
+
+# Multi-Tech SMS Utility (see http://git.multitech.net)
+IMAGE_INSTALL += "sms-utils"
+# Multi-Tech GPS Utility
+IMAGE_INSTALL += "venus-gps"
+
+IMAGE_INSTALL += "uvccapture"
+