summaryrefslogtreecommitdiff
path: root/recipes-support
diff options
context:
space:
mode:
authorJesse Gilles <jgilles@multitech.com>2014-11-04 11:51:34 -0600
committerJesse Gilles <jgilles@multitech.com>2014-11-04 11:51:34 -0600
commite243c30f04c18722dc65effe6d4f275a3f35de46 (patch)
tree807610ce8af0ead02681d6c3cc89d902ec941652 /recipes-support
downloadmeta-mlinux-e243c30f04c18722dc65effe6d4f275a3f35de46.tar.gz
meta-mlinux-e243c30f04c18722dc65effe6d4f275a3f35de46.tar.bz2
meta-mlinux-e243c30f04c18722dc65effe6d4f275a3f35de46.zip
initial commit of mLinux layer
Diffstat (limited to 'recipes-support')
-rw-r--r--recipes-support/jsoncpp/jsoncpp-0.5.0/Makefile46
-rw-r--r--recipes-support/jsoncpp/jsoncpp-0.5.0/jsoncpp-0.5.0-p1.patch13
-rw-r--r--recipes-support/jsoncpp/jsoncpp_0.5.0.bb32
-rw-r--r--recipes-support/libesmtp/libesmtp_1.0.6.bb25
4 files changed, 116 insertions, 0 deletions
diff --git a/recipes-support/jsoncpp/jsoncpp-0.5.0/Makefile b/recipes-support/jsoncpp/jsoncpp-0.5.0/Makefile
new file mode 100644
index 0000000..bee6876
--- /dev/null
+++ b/recipes-support/jsoncpp/jsoncpp-0.5.0/Makefile
@@ -0,0 +1,46 @@
+includedir ?= /usr/include
+libdir ?= /usr/lib
+
+CPP_SRCS += \
+src/lib_json/json_reader.cpp \
+src/lib_json/json_value.cpp \
+src/lib_json/json_writer.cpp
+
+OBJS += \
+json_reader.o \
+json_value.o \
+json_writer.o
+
+CPP_DEPS += \
+json_reader.d \
+json_value.d \
+json_writer.d
+
+all: libjsoncpp.a
+
+libjsoncpp.a: $(OBJS)
+ @echo 'Building target: $@'
+ $(AR) -r libjsoncpp.a $(OBJS)
+ @echo 'Finished building target: $@'
+ @echo ' '
+
+%.o: src/lib_json/%.cpp
+ @echo 'Building file: $<'
+ $(CXX) $(CFLAGS) -Iinclude -Wall -c -fmessage-length=0 -MMD -MP -MF"$(@:%.o=%.d)" -MT"$(@:%.o=%.d)" -o "$@" "$<"
+ @echo 'Finished building: $<'
+ @echo ' '
+
+install:
+ mkdir -p $(DESTDIR)$(libdir)
+ mkdir -p $(DESTDIR)$(includedir)/json
+ cp libjsoncpp.a $(DESTDIR)$(libdir)/
+ cp include/json/* $(DESTDIR)$(includedir)/json/
+
+# Other Targets
+clean:
+ -$(RM) $(OBJS)$(CPP_DEPS) libjsoncpp.a
+ -@echo ' '
+
+.PHONY: all clean dependents
+.SECONDARY:
+
diff --git a/recipes-support/jsoncpp/jsoncpp-0.5.0/jsoncpp-0.5.0-p1.patch b/recipes-support/jsoncpp/jsoncpp-0.5.0/jsoncpp-0.5.0-p1.patch
new file mode 100644
index 0000000..ce0f890
--- /dev/null
+++ b/recipes-support/jsoncpp/jsoncpp-0.5.0/jsoncpp-0.5.0-p1.patch
@@ -0,0 +1,13 @@
+Index: jsoncpp-src-0.5.0/include/json/value.h
+===================================================================
+--- jsoncpp-src-0.5.0.orig/include/json/value.h 2012-07-11 10:26:55.766138435 -0500
++++ jsoncpp-src-0.5.0/include/json/value.h 2012-07-11 10:30:09.816144678 -0500
+@@ -204,7 +204,7 @@
+ # endif
+ Value( bool value );
+ Value( const Value &other );
+- ~Value();
++ virtual ~Value();
+
+ Value &operator=( const Value &other );
+ /// Swap values.
diff --git a/recipes-support/jsoncpp/jsoncpp_0.5.0.bb b/recipes-support/jsoncpp/jsoncpp_0.5.0.bb
new file mode 100644
index 0000000..18f1c86
--- /dev/null
+++ b/recipes-support/jsoncpp/jsoncpp_0.5.0.bb
@@ -0,0 +1,32 @@
+DESCRIPTION = "Json C++ Library"
+HOMEPAGE = "http://jsoncpp.sourceforge.net/"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
+DEPENDS = ""
+BBCLASSEXTEND = "native"
+NATIVE_INSTALL_WORKS = "1"
+
+SRC_URI = " \
+ http://sw.multitech.prv/openembedded/sources/jsoncpp-src-0.5.0.tar.gz \
+ file://jsoncpp-0.5.0-p1.patch \
+ file://Makefile \
+"
+
+PR = "r2"
+
+# For tarball packages (as opposed to git / svn which include the commit in the URI)
+SRC_URI[md5sum] = "24482b67c1cb17aac1ed1814288a3a8f"
+SRC_URI[sha256sum] = "22b14ecd0de8cdad2b6b6839f6d0804d3b84e91f42861ebd843832a26a927433"
+
+S = "${WORKDIR}/jsoncpp-src-${PV}"
+
+do_compile() {
+ cp ../Makefile .
+ oe_runmake
+}
+
+do_install() {
+ oe_runmake install DESTDIR=${D}
+}
+
+
diff --git a/recipes-support/libesmtp/libesmtp_1.0.6.bb b/recipes-support/libesmtp/libesmtp_1.0.6.bb
new file mode 100644
index 0000000..e421e63
--- /dev/null
+++ b/recipes-support/libesmtp/libesmtp_1.0.6.bb
@@ -0,0 +1,25 @@
+DESCRIPTION = "LibESMTP is a library to manage posting \
+(or submission of) electronic mail using SMTP to a \
+preconfigured Mail Transport Agent (MTA) such as Exim or PostFix."
+LICENSE = "LGPLv2.1 GPLv2"
+LIC_FILES_CHKSUM= "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \
+ file://COPYING.LIB;md5=e3eda01d9815f8d24aae2dbd89b68b06 \
+"
+SECTION = "libs/network"
+DEPENDS = "openssl"
+PR = "r0"
+
+SRC_URI = "http://www.stafford.uklinux.net/libesmtp/libesmtp-${PV}.tar.bz2"
+
+inherit autotools binconfig
+
+EXTRA_OECONF = "--disable-isoc --with-openssl=${STAGING_LIBDIR}/.."
+
+FILES_${PN} = "${libdir}/lib*${SOLIBS} \
+ ${libdir}/esmtp-plugins/*${SOLIBSDEV}"
+FILES_${PN}-dev += "${libdir}/esmtp-plugins/*.la"
+FILES_${PN}-staticdev += "${libdir}/esmtp-plugins/*.a"
+FILES_${PN}-dbg += "${libdir}/esmtp-plugins/.debug/"
+
+SRC_URI[md5sum] = "bf3915e627fd8f35524a8fdfeed979c8"
+SRC_URI[sha256sum] = "d0a61a5c52d99fa7ce7d00ed0a07e341dbda67101dbed1ab0cdae3f37db4eb0b"