summaryrefslogtreecommitdiff
path: root/recipes-support
diff options
context:
space:
mode:
authorJason Reiss <jreiss@multitech.com>2019-12-31 14:32:12 -0600
committerJohn Klug <john.klug@multitech.com>2020-06-18 20:22:07 -0500
commitddf781899382e04ab5c2084cb7d07bb30975eff6 (patch)
treedd349c2c025dfc617d774ac2c9a8bce8687a4ded /recipes-support
parenta91b3b04960f7b2e6c6bf13a83339ecb64c5f8c3 (diff)
downloadmeta-mlinux-ddf781899382e04ab5c2084cb7d07bb30975eff6.tar.gz
meta-mlinux-ddf781899382e04ab5c2084cb7d07bb30975eff6.tar.bz2
meta-mlinux-ddf781899382e04ab5c2084cb7d07bb30975eff6.zip
lora: update to LNS 2.3.3, requires mosquitto 1.5.1 and jsoncpp changes
Diffstat (limited to 'recipes-support')
-rw-r--r--recipes-support/jsoncpp/jsoncpp-1.6.0/Makefile21
-rw-r--r--recipes-support/jsoncpp/jsoncpp_1.6.0.bb19
2 files changed, 21 insertions, 19 deletions
diff --git a/recipes-support/jsoncpp/jsoncpp-1.6.0/Makefile b/recipes-support/jsoncpp/jsoncpp-1.6.0/Makefile
index 3be3743..7df3d63 100644
--- a/recipes-support/jsoncpp/jsoncpp-1.6.0/Makefile
+++ b/recipes-support/jsoncpp/jsoncpp-1.6.0/Makefile
@@ -16,29 +16,32 @@ json_reader.d \
json_value.d \
json_writer.d
-all: libjsoncpp.a
+TARGET = libjsoncpp.so
-libjsoncpp.a: $(OBJS)
+all: $(TARGET)
+
+libjsoncpp.so: $(OBJS)
@echo 'Building target: $@'
- $(AR) -r libjsoncpp.a $(OBJS)
+ #$(AR) -r libjsoncpp.a $(OBJS)
+ $(CXX) ${LDFLAGS} -shared -o $@ $^
@echo 'Finished building target: $@'
@echo ' '
%.o: src/lib_json/%.cpp
@echo 'Building file: $<'
- $(CXX) $(CFLAGS) -Iinclude -Wall -c -fmessage-length=0 -MMD -MP -MF"$(@:%.o=%.d)" -MT"$(@:%.o=%.d)" -o "$@" "$<"
+ $(CXX) $(CFLAGS) -Iinclude -Wall -c -fmessage-length=0 -MMD -MP -MF"$(@:%.o=%.d)" -MT"$(@:%.o=%.d)" -fPIC -o "$@" "$<"
@echo 'Finished building: $<'
@echo ' '
install:
- mkdir -p $(DESTDIR)$(libdir)
- mkdir -p $(DESTDIR)$(includedir)/jsoncpp/json
- cp libjsoncpp.a $(DESTDIR)$(libdir)/
- cp include/json/* $(DESTDIR)$(includedir)/jsoncpp/json/
+ install -d $(DESTDIR)/usr/include/json
+ install -m 644 include/json/*.h $(DESTDIR)/usr/include/json
+ mkdir -p $(DESTDIR)/usr/lib
+ cp libjsoncpp.so $(DESTDIR)/usr/lib
# Other Targets
clean:
- -$(RM) $(OBJS)$(CPP_DEPS) libjsoncpp.a
+ -$(RM) $(OBJS)$(CPP_DEPS) libjsoncpp.so
-@echo ' '
.PHONY: all clean dependents
diff --git a/recipes-support/jsoncpp/jsoncpp_1.6.0.bb b/recipes-support/jsoncpp/jsoncpp_1.6.0.bb
index 80f3f70..8c8454d 100644
--- a/recipes-support/jsoncpp/jsoncpp_1.6.0.bb
+++ b/recipes-support/jsoncpp/jsoncpp_1.6.0.bb
@@ -4,10 +4,6 @@ HOMEPAGE = "https://github.com/open-source-parsers/jsoncpp"
LICENSE = "PD"
LIC_FILES_CHKSUM = "file://LICENSE;md5=c56ee55c03a55f8105b969d8270632ce"
DEPENDS = ""
-BBCLASSEXTEND = "native"
-
-# static lib only, require staticdev
-RDEPENDS_${PN}-dev = "${PN}-staticdev"
#tag 1.6.0
SRCREV="cbe7e7c9cbd39d864588c5cf2436690634562d3f"
@@ -16,7 +12,7 @@ SRC_URI = " git://github.com/open-source-parsers/jsoncpp.git;protocol=git \
file://Makefile \
"
-PR = "r1"
+PR = "r6"
S = "${WORKDIR}/git"
@@ -25,10 +21,13 @@ do_compile() {
oe_runmake
}
-do_install() {
- oe_runmake install DESTDIR=${D}
+do_install () {
+ install -d ${D}/usr/lib
+ install -m 0755 ${S}/libjsoncpp.so ${D}/usr/lib
+ install -d ${D}${includedir}/jsoncpp/json
+ install -m 0755 ${S}/include/json/*.h ${D}${includedir}/jsoncpp/json
}
-# this recipe provides dev packages only (static lib)
-PACKAGES = "${PN}-dev ${PN}-staticdev ${PN}-dbg"
-
+FILES_SOLIBSDEV = ""
+FILES_${PN} += "${libdir}/*.so"
+FILES_{PN}-dev += "${libdir}/*.so"