summaryrefslogtreecommitdiff
path: root/recipes-support
diff options
context:
space:
mode:
authorJohn Klug <john.klug@multitech.com>2018-04-24 11:20:56 -0500
committerJohn Klug <john.klug@multitech.com>2018-04-24 11:23:14 -0500
commit7de868f89557a71ce65464f8fea2d26809dd5a58 (patch)
treecae3178a190644b9986086eb647e720364f0f66a /recipes-support
parent6a08ab9ea295df1e82c9379172d26dd045fab42d (diff)
downloadmeta-mlinux-7de868f89557a71ce65464f8fea2d26809dd5a58.tar.gz
meta-mlinux-7de868f89557a71ce65464f8fea2d26809dd5a58.tar.bz2
meta-mlinux-7de868f89557a71ce65464f8fea2d26809dd5a58.zip
Telit firmware flashing program, lxfp
Diffstat (limited to 'recipes-support')
-rw-r--r--recipes-support/lxfp/lxfp-src_23a2843.bb33
-rw-r--r--recipes-support/lxfp/lxfp_23a2843.bb17
2 files changed, 50 insertions, 0 deletions
diff --git a/recipes-support/lxfp/lxfp-src_23a2843.bb b/recipes-support/lxfp/lxfp-src_23a2843.bb
new file mode 100644
index 0000000..b2258b7
--- /dev/null
+++ b/recipes-support/lxfp/lxfp-src_23a2843.bb
@@ -0,0 +1,33 @@
+# This recipe needs a manual download of
+# the proprietary Telit firmware flashing
+# program into build/downloads
+# Then it will be able to compile an
+# ipk. The current lxfp recipe requires
+# a tar file of bin/lxfp object module.
+# This is here is an example only.
+DESCRIPTION = "Telit LXFP modem flashing tools"
+LICENSE = ""
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Proprietary;md5=0557f9d92cf58f2ccdd50f62f8ac0b28"
+
+PR = "r1"
+
+SRC_URI = " \
+ file://lxfp-${PV}.tar.gz;md5=b4dc2f536658b3f82c91b68af1bf3dc3 \
+"
+
+S = "${WORKDIR}/lxfp-${PV}"
+
+do_compile() {
+ CC="${CC} --sysroot=${STAGING_DIR_HOST}"
+ LD="${LD} --sysroot=${STAGING_DIR_HOST}"
+ CXX="${CXX} --sysroot=${STAGING_DIR_HOST}"
+ echo "CXX is ${CXX}"
+ oe_runmake CC="${CC}" LD="${LD}" CXX="${CXX}"
+}
+
+do_install() {
+ install -d ${D}${sbindir}
+ install -m 0755 bin/lxfp ${D}${sbindir}
+}
+
+FILES_${PN} = "${sbindir}/lxfp"
diff --git a/recipes-support/lxfp/lxfp_23a2843.bb b/recipes-support/lxfp/lxfp_23a2843.bb
new file mode 100644
index 0000000..ecfdcca
--- /dev/null
+++ b/recipes-support/lxfp/lxfp_23a2843.bb
@@ -0,0 +1,17 @@
+DESCRIPTION = "Telit LXFP modem flashing tool"
+LICENSE = ""
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Proprietary;md5=0557f9d92cf58f2ccdd50f62f8ac0b28"
+
+PR = "r1"
+
+SRC_URI = "http://www.multitech.net/downloads/lxfp-arm926ejste-23a2843.tar.gz"
+SRC_URI[md5sum] = "4ef5d0907a880f9acdc345d57e08c53b"
+SRC_URI[sha256sum] = "09d3fd2d7102343d727fe36c818854183eaa7cdeced1af810786a9d1509541cf"
+
+do_install() {
+ install -d ${D}${sbindir}
+ echo "do_install: directory is $(pwd)"
+ install -m 0755 ${WORKDIR}/bin/lxfp ${D}${sbindir}
+}
+
+FILES_${PN} = "${sbindir}/lxfp"