summaryrefslogtreecommitdiff
path: root/recipes-support
diff options
context:
space:
mode:
authorJesse Gilles <jgilles@multitech.com>2015-04-30 17:01:28 -0500
committerJesse Gilles <jgilles@multitech.com>2015-04-30 17:01:28 -0500
commite98a76f48a683056be716c78fb342127cee0bc15 (patch)
treeb1db3eab7d511b5cddfa702950d5eb51e6d641dc /recipes-support
parentfc50030ce81f0aea0dbfdc8325aa19f7d54877f8 (diff)
downloadmeta-mlinux-e98a76f48a683056be716c78fb342127cee0bc15.tar.gz
meta-mlinux-e98a76f48a683056be716c78fb342127cee0bc15.tar.bz2
meta-mlinux-e98a76f48a683056be716c78fb342127cee0bc15.zip
add recipes for MultiTech libmts, libmts-io, radio-cmd, radio-query, jsparser
Diffstat (limited to 'recipes-support')
-rwxr-xr-xrecipes-support/multitech/jsparser/jspp9
-rw-r--r--recipes-support/multitech/jsparser_0.2.bb22
-rw-r--r--recipes-support/multitech/libmts-io_0.1.bb30
-rw-r--r--recipes-support/multitech/libmts_0.3.bb30
-rw-r--r--recipes-support/multitech/radio-cmd_0.2.bb22
-rw-r--r--recipes-support/multitech/radio-query_0.2.bb22
6 files changed, 135 insertions, 0 deletions
diff --git a/recipes-support/multitech/jsparser/jspp b/recipes-support/multitech/jsparser/jspp
new file mode 100755
index 0000000..16b60e1
--- /dev/null
+++ b/recipes-support/multitech/jsparser/jspp
@@ -0,0 +1,9 @@
+#!/bin/bash
+
+if [ $# -lt 1 ]; then
+ echo "usage: $0 <filepath>"
+ echo " prints json in readable format"
+ exit 1
+fi
+
+cat $1 | jsparser --jsobj
diff --git a/recipes-support/multitech/jsparser_0.2.bb b/recipes-support/multitech/jsparser_0.2.bb
new file mode 100644
index 0000000..b3c7313
--- /dev/null
+++ b/recipes-support/multitech/jsparser_0.2.bb
@@ -0,0 +1,22 @@
+DESCRIPTION = "MultiTech Command Line JSON Parser"
+LICENSE = "GPL-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=94d55d512a9ba36caa9b7df079bae19f"
+DEPENDS = "jsoncpp libmts"
+
+PR = "r0"
+SRCREV="${PV}"
+
+SRC_URI = "git://git.multitech.net/jsparser;branch=master \
+ file://jspp \
+"
+
+S = "${WORKDIR}/git"
+
+inherit autotools
+
+do_install_append() {
+ install -d ${D}/usr/bin
+ install -m 755 ${WORKDIR}/jspp ${D}/usr/bin/jspp
+}
+
+
diff --git a/recipes-support/multitech/libmts-io_0.1.bb b/recipes-support/multitech/libmts-io_0.1.bb
new file mode 100644
index 0000000..9863237
--- /dev/null
+++ b/recipes-support/multitech/libmts-io_0.1.bb
@@ -0,0 +1,30 @@
+DESCRIPTION = "MultiTech IO C++ Library"
+HOMEPAGE = "http://www.multitech.net/"
+LICENSE = "LGPL-2.1"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=4fbd65380cdd255951079008b364516c"
+
+DEPENDS = "libmts jsoncpp cmake-native cppunit"
+BBCLASSEXTEND = "native"
+
+PR = "r1"
+SRCREV = "${PV}"
+SRC_URI = "git://git.multitech.net/libmts-io;branch=master"
+
+S = "${WORKDIR}/git"
+
+do_compile() {
+ oe_runmake
+}
+
+# build and run tests for native recipe
+do_compile_append_virtclass-native() {
+ cd test
+ cmake .
+ oe_runmake
+ ./TestRunnerClient
+}
+
+do_install() {
+ oe_runmake install DESTDIR=${D}
+}
+
diff --git a/recipes-support/multitech/libmts_0.3.bb b/recipes-support/multitech/libmts_0.3.bb
new file mode 100644
index 0000000..b599395
--- /dev/null
+++ b/recipes-support/multitech/libmts_0.3.bb
@@ -0,0 +1,30 @@
+DESCRIPTION = "MultiTech Core C++ Library"
+HOMEPAGE = "http://www.multitech.net/"
+LICENSE = "LGPL-2.1"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=4fbd65380cdd255951079008b364516c"
+
+DEPENDS = "cmake-native cppunit"
+BBCLASSEXTEND = "native"
+
+PR = "r1"
+SRCREV = "${PV}"
+SRC_URI = "git://git.multitech.net/libmts;branch=master"
+
+S = "${WORKDIR}/git"
+
+do_compile() {
+ oe_runmake
+}
+
+# build and run tests for native recipe
+do_compile_append_virtclass-native() {
+ cd test
+ cmake .
+ oe_runmake
+ ./TestRunnerClient
+}
+
+do_install() {
+ oe_runmake install DESTDIR=${D}
+}
+
diff --git a/recipes-support/multitech/radio-cmd_0.2.bb b/recipes-support/multitech/radio-cmd_0.2.bb
new file mode 100644
index 0000000..b8e5b23
--- /dev/null
+++ b/recipes-support/multitech/radio-cmd_0.2.bb
@@ -0,0 +1,22 @@
+DESCRIPTION = "MultiTech cellular radio command tool"
+HOMEPAGE = "http://www.multitech.net/"
+LICENSE = "GPL-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=94d55d512a9ba36caa9b7df079bae19f"
+
+DEPENDS = "jsoncpp libmts libmts-io"
+
+PR = "r0"
+SRCREV = "${PV}"
+
+SRC_URI = "git://git.multitech.net/radio-cmd;branch=master"
+
+S = "${WORKDIR}/git"
+
+do_compile() {
+ oe_runmake
+}
+
+do_install() {
+ oe_runmake install DESTDIR=${D}
+}
+
diff --git a/recipes-support/multitech/radio-query_0.2.bb b/recipes-support/multitech/radio-query_0.2.bb
new file mode 100644
index 0000000..5e0b60a
--- /dev/null
+++ b/recipes-support/multitech/radio-query_0.2.bb
@@ -0,0 +1,22 @@
+DESCRIPTION = "MultiTech cellular radio query tool"
+HOMEPAGE = "http://www.multitech.net/"
+LICENSE = "GPL-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=94d55d512a9ba36caa9b7df079bae19f"
+
+DEPENDS = "jsoncpp libmts libmts-io"
+
+PR = "r0"
+SRCREV = "${PV}"
+
+SRC_URI = "git://git.multitech.net/radio-query;branch=master"
+
+S = "${WORKDIR}/git"
+
+do_compile() {
+ oe_runmake
+}
+
+do_install() {
+ oe_runmake install DESTDIR=${D}
+}
+