summaryrefslogtreecommitdiff
path: root/recipes-support
diff options
context:
space:
mode:
authorJohn Klug <john.klug@multitech.com>2016-12-19 19:27:22 -0600
committerJohn Klug <john.klug@multitech.com>2016-12-19 19:27:22 -0600
commit32721433e01f18dd83a295ed4e3579ad40537354 (patch)
tree32ce844e0197fad4e66dfb7e631c6c1ecd8729c3 /recipes-support
parent95c4072bd3f08b2bd57a626e6411e17efd9af251 (diff)
downloadmeta-mlinux-32721433e01f18dd83a295ed4e3579ad40537354.tar.gz
meta-mlinux-32721433e01f18dd83a295ed4e3579ad40537354.tar.bz2
meta-mlinux-32721433e01f18dd83a295ed4e3579ad40537354.zip
add features to busybox to debug ntp and set nice to -20 for ntp
Diffstat (limited to 'recipes-support')
-rw-r--r--recipes-support/ntp/files/ntpd-init.patch11
-rw-r--r--recipes-support/ntp/ntp_4.2.6p5.bbappend11
2 files changed, 22 insertions, 0 deletions
diff --git a/recipes-support/ntp/files/ntpd-init.patch b/recipes-support/ntp/files/ntpd-init.patch
new file mode 100644
index 0000000..fc388f8
--- /dev/null
+++ b/recipes-support/ntp/files/ntpd-init.patch
@@ -0,0 +1,11 @@
+--- old/ntpd 2016-12-19 18:11:58.022663976 -0600
++++ new/ntpd 2016-12-19 18:12:56.618663852 -0600
+@@ -23,7 +23,7 @@
+ # this. If ntpd seems to disappear after a while assume TICKADJ
+ # above is set to a totally incorrect value.
+ echo -n "Starting ntpd: "
+- start-stop-daemon --start -x /usr/sbin/ntpd -- -u ntp:ntp -p /var/run/ntp.pid "$@"
++ start-stop-daemon -N -20 --start -x /usr/sbin/ntpd -- -u ntp:ntp -p /var/run/ntp.pid "$@"
+ echo "done"
+ }
+ stopdaemon(){
diff --git a/recipes-support/ntp/ntp_4.2.6p5.bbappend b/recipes-support/ntp/ntp_4.2.6p5.bbappend
new file mode 100644
index 0000000..528c6c9
--- /dev/null
+++ b/recipes-support/ntp/ntp_4.2.6p5.bbappend
@@ -0,0 +1,11 @@
+PR .= ".mlinux1"
+
+SRC_URI += " file://ntpd-init.patch;patchdir=.. \
+ "
+FILESEXTRAPATHS_prepend := "${THISDIR}/files"
+
+python do_patch_prepend () {
+ import os
+ cwd = os.getcwd()
+ bb.note("Hello %s",cwd)
+}