summaryrefslogtreecommitdiff
path: root/recipes-support/softdog-mon_0.1.bb
diff options
context:
space:
mode:
authorJohn Klug <john.klug@multitech.com>2021-01-19 11:42:15 -0600
committerJohn Klug <john.klug@multitech.com>2021-06-22 09:10:14 -0500
commit9c2d0c0d6cf0c4bafce393c76b5035632aed37dd (patch)
tree0259ea79e2bfab7e415285a641aef80ca4449d60 /recipes-support/softdog-mon_0.1.bb
parentcfba9d58320fe254b1160e0a9899fd5305594d52 (diff)
downloadmeta-mlinux-9c2d0c0d6cf0c4bafce393c76b5035632aed37dd.tar.gz
meta-mlinux-9c2d0c0d6cf0c4bafce393c76b5035632aed37dd.tar.bz2
meta-mlinux-9c2d0c0d6cf0c4bafce393c76b5035632aed37dd.zip
Add softdog-mon for customer suppot
Diffstat (limited to 'recipes-support/softdog-mon_0.1.bb')
-rw-r--r--recipes-support/softdog-mon_0.1.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/recipes-support/softdog-mon_0.1.bb b/recipes-support/softdog-mon_0.1.bb
new file mode 100644
index 0000000..5ddcf7c
--- /dev/null
+++ b/recipes-support/softdog-mon_0.1.bb
@@ -0,0 +1,33 @@
+DESCRIPTION = "MultiTech Softdog monitor"
+LICENSE = "MIT"
+RDEPENDS_${PN} += "kernel-module-softdog bash"
+
+inherit autotools
+
+inherit update-rc.d systemd
+
+INITSCRIPT_NAME = "${PN}"
+# should we ever stop?
+INITSCRIPT_PARAMS = "start 99 3 5 . stop 20 0 1 2 6 ."
+
+LIC_FILES_CHKSUM = "file://COPYING;md5=30e3dd411ec20099cbf782f420ae7ec2"
+PR = "r0"
+SRCREV="${PV}"
+FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
+PACKAGES =+ "${PN}-test"
+FILES_${PN}-test = "${sbindir}/hog"
+
+SRC_URI = "git://git.multitech.net/softdog-mon.git;protocol=git \
+ file://init \
+ file://default \
+"
+
+S = "${WORKDIR}/git"
+
+do_install_append() {
+ echo $(pwd)
+ install -d ${D}/${sysconfdir}/init.d
+ install -d ${D}/${sysconfdir}/default
+ install -m 0755 ${WORKDIR}/init ${D}/${sysconfdir}/init.d/${PN}
+ install ${WORKDIR}/default ${D}/${sysconfdir}/default/${PN}
+}