summaryrefslogtreecommitdiff
path: root/recipes-support/pps-tools
diff options
context:
space:
mode:
authorJohn Klug <john.klug@multitech.com>2016-09-06 16:32:36 -0500
committerJohn Klug <john.klug@multitech.com>2016-09-06 16:32:36 -0500
commit32158e7166e67dd30ee1444d0ad30d083b9e130c (patch)
tree83c433842e748ffc2923b05f5cd39d9294e903c1 /recipes-support/pps-tools
parent3183d27dcb8d662dba7c49467960fc9e596dc2cb (diff)
downloadmeta-mlinux-32158e7166e67dd30ee1444d0ad30d083b9e130c.tar.gz
meta-mlinux-32158e7166e67dd30ee1444d0ad30d083b9e130c.tar.bz2
meta-mlinux-32158e7166e67dd30ee1444d0ad30d083b9e130c.zip
Add pps-tools to evaluate the PPS driver
Diffstat (limited to 'recipes-support/pps-tools')
-rw-r--r--recipes-support/pps-tools/pps-tools_git.bb17
1 files changed, 17 insertions, 0 deletions
diff --git a/recipes-support/pps-tools/pps-tools_git.bb b/recipes-support/pps-tools/pps-tools_git.bb
new file mode 100644
index 0000000..ddcfe67
--- /dev/null
+++ b/recipes-support/pps-tools/pps-tools_git.bb
@@ -0,0 +1,17 @@
+SUMMARY = "User-space tools for LinuxPPS"
+PRIORITY = "optional"
+
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
+
+PV = "0.0.0+git${SRCPV}"
+SRCREV = "0deb9c7e135e9380a6d09e9d2e938a146bb698c8"
+SRC_URI = "git://github.com/ago/pps-tools.git"
+
+S = "${WORKDIR}/git"
+
+do_install() {
+ install -d ${D}${bindir} ${D}${includedir} \
+ ${D}${includedir}/sys
+ oe_runmake 'DESTDIR=${D}' install
+}