summaryrefslogtreecommitdiff
path: root/recipes-support/multitech/softdog-mon_0.1.bb
diff options
context:
space:
mode:
authorJohn Klug <john.klug@multitech.com>2021-01-29 04:44:00 -0600
committerJohn Klug <john.klug@multitech.com>2021-06-22 09:17:12 -0500
commit26efe7485d71d4e1df5358aa8bfb3815401f6daa (patch)
treeb65d5934ebed487628fbda93ff0d96a6fe51b77d /recipes-support/multitech/softdog-mon_0.1.bb
parent2499b733a1507a479582190c009e058a49e994be (diff)
downloadmeta-mlinux-26efe7485d71d4e1df5358aa8bfb3815401f6daa.tar.gz
meta-mlinux-26efe7485d71d4e1df5358aa8bfb3815401f6daa.tar.bz2
meta-mlinux-26efe7485d71d4e1df5358aa8bfb3815401f6daa.zip
Move softdog-mon recipes into correct part of tree
Diffstat (limited to 'recipes-support/multitech/softdog-mon_0.1.bb')
-rw-r--r--recipes-support/multitech/softdog-mon_0.1.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/recipes-support/multitech/softdog-mon_0.1.bb b/recipes-support/multitech/softdog-mon_0.1.bb
new file mode 100644
index 0000000..5ddcf7c
--- /dev/null
+++ b/recipes-support/multitech/softdog-mon_0.1.bb
@@ -0,0 +1,33 @@
+DESCRIPTION = "MultiTech Softdog monitor"
+LICENSE = "MIT"
+RDEPENDS_${PN} += "kernel-module-softdog bash"
+
+inherit autotools
+
+inherit update-rc.d systemd
+
+INITSCRIPT_NAME = "${PN}"
+# should we ever stop?
+INITSCRIPT_PARAMS = "start 99 3 5 . stop 20 0 1 2 6 ."
+
+LIC_FILES_CHKSUM = "file://COPYING;md5=30e3dd411ec20099cbf782f420ae7ec2"
+PR = "r0"
+SRCREV="${PV}"
+FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
+PACKAGES =+ "${PN}-test"
+FILES_${PN}-test = "${sbindir}/hog"
+
+SRC_URI = "git://git.multitech.net/softdog-mon.git;protocol=git \
+ file://init \
+ file://default \
+"
+
+S = "${WORKDIR}/git"
+
+do_install_append() {
+ echo $(pwd)
+ install -d ${D}/${sysconfdir}/init.d
+ install -d ${D}/${sysconfdir}/default
+ install -m 0755 ${WORKDIR}/init ${D}/${sysconfdir}/init.d/${PN}
+ install ${WORKDIR}/default ${D}/${sysconfdir}/default/${PN}
+}