summaryrefslogtreecommitdiff
path: root/recipes-support/multitech/jsparser_0.3.bb
diff options
context:
space:
mode:
authorJeff Hatch <jhatch@multitech.com>2016-01-29 14:49:30 -0600
committerJeff Hatch <jhatch@multitech.com>2016-01-29 14:49:30 -0600
commitfb3371e39dfdf4502c375d56a350b839c441e03d (patch)
treea73dba81520812dc5a88d53beb7cd2b8856ae359 /recipes-support/multitech/jsparser_0.3.bb
parente8647c9aefbe53cd91f70671330be3e69f010e7e (diff)
downloadmeta-mlinux-fb3371e39dfdf4502c375d56a350b839c441e03d.tar.gz
meta-mlinux-fb3371e39dfdf4502c375d56a350b839c441e03d.tar.bz2
meta-mlinux-fb3371e39dfdf4502c375d56a350b839c441e03d.zip
Update jsparser recipe to point to 0.3 tagged version
Diffstat (limited to 'recipes-support/multitech/jsparser_0.3.bb')
-rw-r--r--recipes-support/multitech/jsparser_0.3.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/recipes-support/multitech/jsparser_0.3.bb b/recipes-support/multitech/jsparser_0.3.bb
new file mode 100644
index 0000000..b3c7313
--- /dev/null
+++ b/recipes-support/multitech/jsparser_0.3.bb
@@ -0,0 +1,22 @@
+DESCRIPTION = "MultiTech Command Line JSON Parser"
+LICENSE = "GPL-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=94d55d512a9ba36caa9b7df079bae19f"
+DEPENDS = "jsoncpp libmts"
+
+PR = "r0"
+SRCREV="${PV}"
+
+SRC_URI = "git://git.multitech.net/jsparser;branch=master \
+ file://jspp \
+"
+
+S = "${WORKDIR}/git"
+
+inherit autotools
+
+do_install_append() {
+ install -d ${D}/usr/bin
+ install -m 755 ${WORKDIR}/jspp ${D}/usr/bin/jspp
+}
+
+