summaryrefslogtreecommitdiff
path: root/recipes-support/multitech/jsparser_0.2.bb
diff options
context:
space:
mode:
authorJesse Gilles <jgilles@multitech.com>2015-04-30 17:01:28 -0500
committerJesse Gilles <jgilles@multitech.com>2015-04-30 17:01:28 -0500
commite98a76f48a683056be716c78fb342127cee0bc15 (patch)
treeb1db3eab7d511b5cddfa702950d5eb51e6d641dc /recipes-support/multitech/jsparser_0.2.bb
parentfc50030ce81f0aea0dbfdc8325aa19f7d54877f8 (diff)
downloadmeta-mlinux-e98a76f48a683056be716c78fb342127cee0bc15.tar.gz
meta-mlinux-e98a76f48a683056be716c78fb342127cee0bc15.tar.bz2
meta-mlinux-e98a76f48a683056be716c78fb342127cee0bc15.zip
add recipes for MultiTech libmts, libmts-io, radio-cmd, radio-query, jsparser
Diffstat (limited to 'recipes-support/multitech/jsparser_0.2.bb')
-rw-r--r--recipes-support/multitech/jsparser_0.2.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/recipes-support/multitech/jsparser_0.2.bb b/recipes-support/multitech/jsparser_0.2.bb
new file mode 100644
index 0000000..b3c7313
--- /dev/null
+++ b/recipes-support/multitech/jsparser_0.2.bb
@@ -0,0 +1,22 @@
+DESCRIPTION = "MultiTech Command Line JSON Parser"
+LICENSE = "GPL-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=94d55d512a9ba36caa9b7df079bae19f"
+DEPENDS = "jsoncpp libmts"
+
+PR = "r0"
+SRCREV="${PV}"
+
+SRC_URI = "git://git.multitech.net/jsparser;branch=master \
+ file://jspp \
+"
+
+S = "${WORKDIR}/git"
+
+inherit autotools
+
+do_install_append() {
+ install -d ${D}/usr/bin
+ install -m 755 ${WORKDIR}/jspp ${D}/usr/bin/jspp
+}
+
+