summaryrefslogtreecommitdiff
path: root/recipes-support/jsoncpp/jsoncpp_1.6.0.bb
diff options
context:
space:
mode:
authorSean Godinez <sgodinez@multitech.com>2015-03-19 21:37:43 -0500
committerSean Godinez <sgodinez@multitech.com>2015-03-19 21:37:43 -0500
commit2ff06ea3dcd9aed943b7edb210affa9609ef95d1 (patch)
tree2943b3a19fbeb308dcc5905151d9ebbfdf67e1c8 /recipes-support/jsoncpp/jsoncpp_1.6.0.bb
parent7d3e97d354ae2f73e1f0f113e47c72c014341757 (diff)
downloadmeta-mlinux-2ff06ea3dcd9aed943b7edb210affa9609ef95d1.tar.gz
meta-mlinux-2ff06ea3dcd9aed943b7edb210affa9609ef95d1.tar.bz2
meta-mlinux-2ff06ea3dcd9aed943b7edb210affa9609ef95d1.zip
jsoncpp: added recipe for version 1.6.0
Diffstat (limited to 'recipes-support/jsoncpp/jsoncpp_1.6.0.bb')
-rw-r--r--recipes-support/jsoncpp/jsoncpp_1.6.0.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/recipes-support/jsoncpp/jsoncpp_1.6.0.bb b/recipes-support/jsoncpp/jsoncpp_1.6.0.bb
new file mode 100644
index 0000000..01a1c2f
--- /dev/null
+++ b/recipes-support/jsoncpp/jsoncpp_1.6.0.bb
@@ -0,0 +1,28 @@
+DESCRIPTION = "Json C++ Library"
+HOMEPAGE = "https://github.com/open-source-parsers/jsoncpp"
+# Public Domain
+LICENSE = "PD"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=c56ee55c03a55f8105b969d8270632ce"
+DEPENDS = ""
+BBCLASSEXTEND = "native"
+
+#tag 1.6.0
+SRCREV="cbe7e7c9cbd39d864588c5cf2436690634562d3f"
+
+SRC_URI = " git://github.com/open-source-parsers/jsoncpp.git;protocol=git \
+ file://Makefile \
+ "
+
+PR = "r0"
+
+S = "${WORKDIR}/git"
+
+do_compile() {
+ cp ${WORKDIR}/Makefile .
+ oe_runmake
+}
+
+do_install() {
+ oe_runmake install DESTDIR=${D}
+}
+