summaryrefslogtreecommitdiff
path: root/recipes-support/jsoncpp/jsoncpp-0.5.0/Makefile
diff options
context:
space:
mode:
authorJesse Gilles <jgilles@multitech.com>2015-05-06 11:27:40 -0500
committerJesse Gilles <jgilles@multitech.com>2015-05-06 11:27:40 -0500
commit40f75adea4f466eae9cac82b71009c75a8710ae1 (patch)
treebf950cad37b91c518e9570887bd1eaae6c4b76e5 /recipes-support/jsoncpp/jsoncpp-0.5.0/Makefile
parentaaa961e85d6ad5088d9d8fb5bd6a81df6b3f9d89 (diff)
downloadmeta-mlinux-40f75adea4f466eae9cac82b71009c75a8710ae1.tar.gz
meta-mlinux-40f75adea4f466eae9cac82b71009c75a8710ae1.tar.bz2
meta-mlinux-40f75adea4f466eae9cac82b71009c75a8710ae1.zip
jsoncpp: remove 0.5.0
Diffstat (limited to 'recipes-support/jsoncpp/jsoncpp-0.5.0/Makefile')
-rw-r--r--recipes-support/jsoncpp/jsoncpp-0.5.0/Makefile46
1 files changed, 0 insertions, 46 deletions
diff --git a/recipes-support/jsoncpp/jsoncpp-0.5.0/Makefile b/recipes-support/jsoncpp/jsoncpp-0.5.0/Makefile
deleted file mode 100644
index 3be3743..0000000
--- a/recipes-support/jsoncpp/jsoncpp-0.5.0/Makefile
+++ /dev/null
@@ -1,46 +0,0 @@
-includedir ?= /usr/include
-libdir ?= /usr/lib
-
-CPP_SRCS += \
-src/lib_json/json_reader.cpp \
-src/lib_json/json_value.cpp \
-src/lib_json/json_writer.cpp
-
-OBJS += \
-json_reader.o \
-json_value.o \
-json_writer.o
-
-CPP_DEPS += \
-json_reader.d \
-json_value.d \
-json_writer.d
-
-all: libjsoncpp.a
-
-libjsoncpp.a: $(OBJS)
- @echo 'Building target: $@'
- $(AR) -r libjsoncpp.a $(OBJS)
- @echo 'Finished building target: $@'
- @echo ' '
-
-%.o: src/lib_json/%.cpp
- @echo 'Building file: $<'
- $(CXX) $(CFLAGS) -Iinclude -Wall -c -fmessage-length=0 -MMD -MP -MF"$(@:%.o=%.d)" -MT"$(@:%.o=%.d)" -o "$@" "$<"
- @echo 'Finished building: $<'
- @echo ' '
-
-install:
- mkdir -p $(DESTDIR)$(libdir)
- mkdir -p $(DESTDIR)$(includedir)/jsoncpp/json
- cp libjsoncpp.a $(DESTDIR)$(libdir)/
- cp include/json/* $(DESTDIR)$(includedir)/jsoncpp/json/
-
-# Other Targets
-clean:
- -$(RM) $(OBJS)$(CPP_DEPS) libjsoncpp.a
- -@echo ' '
-
-.PHONY: all clean dependents
-.SECONDARY:
-