summaryrefslogtreecommitdiff
path: root/recipes-ruby
diff options
context:
space:
mode:
authorJohn Klug <john.klug@multitech.com>2017-04-11 16:37:07 -0500
committerJohn Klug <john.klug@multitech.com>2017-05-23 15:21:54 -0500
commitee18b442388c36edd3f12e2249d0a59639857e13 (patch)
tree9e1a9cfb63ce29ab18c9e744cd11f541778bcfa5 /recipes-ruby
parent6160f537666c4c6ab443e70856f72898db0ed031 (diff)
downloadmeta-mlinux-ee18b442388c36edd3f12e2249d0a59639857e13.tar.gz
meta-mlinux-ee18b442388c36edd3f12e2249d0a59639857e13.tar.bz2
meta-mlinux-ee18b442388c36edd3f12e2249d0a59639857e13.zip
Gets us to the GCC compatibility bug
Diffstat (limited to 'recipes-ruby')
-rw-r--r--recipes-ruby/ruby-serialport/ruby-serialport_1.3.0.bb7
1 files changed, 5 insertions, 2 deletions
diff --git a/recipes-ruby/ruby-serialport/ruby-serialport_1.3.0.bb b/recipes-ruby/ruby-serialport/ruby-serialport_1.3.0.bb
index f00c45c..6767e55 100644
--- a/recipes-ruby/ruby-serialport/ruby-serialport_1.3.0.bb
+++ b/recipes-ruby/ruby-serialport/ruby-serialport_1.3.0.bb
@@ -18,8 +18,11 @@ S = "${WORKDIR}/git"
B = "${S}"
do_compile() {
- ${CC} ${CFLAGS} ${LDFLAGS} -Iext/native -I${STAGING_INCDIR}/ruby-1.9.1 -I${STAGING_INCDIR}/ruby-1.9.1/arm-linux-eabi -c ext/native/*.c
- ${CC} ${CFLAGS} ${LDFLAGS} --shared -o ext/native/serialport.so serialport.o posix_serialport_impl.o
+ ls -d ${STAGING_INCDIR}/ruby-* >/tmp/ruby.txt
+ rp=$(ls -d ${STAGING_INCDIR}/ruby-* | head -1)
+ echo ${rp} >/tmp/ruby2.txt
+ ${CC} -v ${CFLAGS} ${LDFLAGS} -Iext/native -I${rp} -I${rp}/arm-linux-gnueabi -c ext/native/*.c
+ ${CC} -v ${CFLAGS} ${LDFLAGS} --shared -o ext/native/serialport.so serialport.o posix_serialport_impl.o
}
do_install() {