summaryrefslogtreecommitdiff
path: root/recipes-ruby
diff options
context:
space:
mode:
authorJohn Klug <john.klug@multitech.com>2017-04-19 14:19:26 -0500
committerJohn Klug <john.klug@multitech.com>2017-05-23 15:21:54 -0500
commit0641240a3fe5f3dd0856c9a24aa1b13e98c56e59 (patch)
tree849a1af494e31bd6599c5beebd32ead37e7ad21c /recipes-ruby
parent4979ec261513b5dae7da34fe9a1b8f35de4a72c7 (diff)
downloadmeta-mlinux-0641240a3fe5f3dd0856c9a24aa1b13e98c56e59.tar.gz
meta-mlinux-0641240a3fe5f3dd0856c9a24aa1b13e98c56e59.tar.bz2
meta-mlinux-0641240a3fe5f3dd0856c9a24aa1b13e98c56e59.zip
logrotate and openjdk-8
Diffstat (limited to 'recipes-ruby')
-rw-r--r--recipes-ruby/ruby-sqlite3/ruby-sqlite3_1.3.13.bb19
1 files changed, 2 insertions, 17 deletions
diff --git a/recipes-ruby/ruby-sqlite3/ruby-sqlite3_1.3.13.bb b/recipes-ruby/ruby-sqlite3/ruby-sqlite3_1.3.13.bb
index fa1ff9e..35e473c 100644
--- a/recipes-ruby/ruby-sqlite3/ruby-sqlite3_1.3.13.bb
+++ b/recipes-ruby/ruby-sqlite3/ruby-sqlite3_1.3.13.bb
@@ -1,32 +1,17 @@
DESCRIPTION = "Ruby bindings for the SQLite3 embedded database"
HOMEPAGE = "https://github.com/sparklemotion/sqlite3-ruby"
-LICENSE = "custom-freely-distributable"
+LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://LICENSE;md5=f24ce0d57c8f8576a36e2803d35bcfec"
SECTION = "console/utils"
PRIORITY = "optional"
DEPENDS = "ruby sqlite3"
+inherit ruby
PR = "r0"
SRC_URI = "git://github.com/sparklemotion/sqlite3-ruby.git;tag=v${PV};branch=1-3-stable;protocol=git"
S = "${WORKDIR}/git"
-B = "${S}"
-
-# RUBY_VERSION
-do_compile() {
- fn=$(ls ${STAGING_INCDIR}/ruby-*/ruby.h | head -1)
- pn=$(dirname $fn)
- pn2=$(ls -d ${STAGING_INCDIR}/ruby-*/arm-linux-*)
- ${CC} ${CFLAGS} ${LDFLAGS} -Iext/sqlite3 -Iext/native -I${pn} -I${pn2} -c ext/sqlite3/*.c
- ${CC} ${CFLAGS} ${LDFLAGS} --shared -o ext/sqlite3/sqlite3_native.so *.o -lsqlite3
-}
-
-do_install() {
- install -d ${D}${libdir}/ruby ${D}${libdir}/ruby/sqlite3
- install lib/sqlite3.rb ${D}${libdir}/ruby/sqlite3.rb
- install lib/sqlite3/* ext/sqlite3/sqlite3_native.so -t ${D}${libdir}/ruby/sqlite3
-}
FILES_${PN} = "${libdir}/ruby/sqlite3*"
FILES_${PN}-dbg += "${libdir}/ruby/sqlite3/.debug*"