summaryrefslogtreecommitdiff
path: root/recipes-ruby/ruby-sqlite3/ruby-sqlite3_1.3.13.bb
diff options
context:
space:
mode:
authorJohn Klug <john.klug@multitech.com>2017-04-03 14:54:24 -0500
committerJohn Klug <john.klug@multitech.com>2017-05-23 15:21:54 -0500
commit0f2dca7de250ebb262e4d6e305b15008cc354281 (patch)
tree5d9b800a697449daef6db96c60ecce82b10e7b5a /recipes-ruby/ruby-sqlite3/ruby-sqlite3_1.3.13.bb
parent18ce886647f912cc77cd1f78236061f9ba0b5db0 (diff)
downloadmeta-mlinux-0f2dca7de250ebb262e4d6e305b15008cc354281.tar.gz
meta-mlinux-0f2dca7de250ebb262e4d6e305b15008cc354281.tar.bz2
meta-mlinux-0f2dca7de250ebb262e4d6e305b15008cc354281.zip
make ruby-sqlite3 compatible with new ruby/sqlite3
Diffstat (limited to 'recipes-ruby/ruby-sqlite3/ruby-sqlite3_1.3.13.bb')
-rw-r--r--recipes-ruby/ruby-sqlite3/ruby-sqlite3_1.3.13.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/recipes-ruby/ruby-sqlite3/ruby-sqlite3_1.3.13.bb b/recipes-ruby/ruby-sqlite3/ruby-sqlite3_1.3.13.bb
new file mode 100644
index 0000000..fa1ff9e
--- /dev/null
+++ b/recipes-ruby/ruby-sqlite3/ruby-sqlite3_1.3.13.bb
@@ -0,0 +1,32 @@
+DESCRIPTION = "Ruby bindings for the SQLite3 embedded database"
+HOMEPAGE = "https://github.com/sparklemotion/sqlite3-ruby"
+LICENSE = "custom-freely-distributable"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=f24ce0d57c8f8576a36e2803d35bcfec"
+SECTION = "console/utils"
+PRIORITY = "optional"
+DEPENDS = "ruby sqlite3"
+
+PR = "r0"
+
+SRC_URI = "git://github.com/sparklemotion/sqlite3-ruby.git;tag=v${PV};branch=1-3-stable;protocol=git"
+
+S = "${WORKDIR}/git"
+B = "${S}"
+
+# RUBY_VERSION
+do_compile() {
+ fn=$(ls ${STAGING_INCDIR}/ruby-*/ruby.h | head -1)
+ pn=$(dirname $fn)
+ pn2=$(ls -d ${STAGING_INCDIR}/ruby-*/arm-linux-*)
+ ${CC} ${CFLAGS} ${LDFLAGS} -Iext/sqlite3 -Iext/native -I${pn} -I${pn2} -c ext/sqlite3/*.c
+ ${CC} ${CFLAGS} ${LDFLAGS} --shared -o ext/sqlite3/sqlite3_native.so *.o -lsqlite3
+}
+
+do_install() {
+ install -d ${D}${libdir}/ruby ${D}${libdir}/ruby/sqlite3
+ install lib/sqlite3.rb ${D}${libdir}/ruby/sqlite3.rb
+ install lib/sqlite3/* ext/sqlite3/sqlite3_native.so -t ${D}${libdir}/ruby/sqlite3
+}
+
+FILES_${PN} = "${libdir}/ruby/sqlite3*"
+FILES_${PN}-dbg += "${libdir}/ruby/sqlite3/.debug*"