summaryrefslogtreecommitdiff
path: root/recipes-ruby/ruby-serialport/ruby-serialport_1.3.1.bb
diff options
context:
space:
mode:
authorJohn Klug <john.klug@multitech.com>2017-04-11 17:14:40 -0500
committerJohn Klug <john.klug@multitech.com>2017-05-23 15:21:54 -0500
commitc9515b69abd1fcf8182c930651e9677d249a8212 (patch)
treeeb185abeafd8fd45c5775bdd99451391f36e6bf7 /recipes-ruby/ruby-serialport/ruby-serialport_1.3.1.bb
parentee18b442388c36edd3f12e2249d0a59639857e13 (diff)
downloadmeta-mlinux-c9515b69abd1fcf8182c930651e9677d249a8212.tar.gz
meta-mlinux-c9515b69abd1fcf8182c930651e9677d249a8212.tar.bz2
meta-mlinux-c9515b69abd1fcf8182c930651e9677d249a8212.zip
Need ruby-serialport 1.3.1 to avoid gcc errors
Diffstat (limited to 'recipes-ruby/ruby-serialport/ruby-serialport_1.3.1.bb')
-rw-r--r--recipes-ruby/ruby-serialport/ruby-serialport_1.3.1.bb35
1 files changed, 35 insertions, 0 deletions
diff --git a/recipes-ruby/ruby-serialport/ruby-serialport_1.3.1.bb b/recipes-ruby/ruby-serialport/ruby-serialport_1.3.1.bb
new file mode 100644
index 0000000..c0510e9
--- /dev/null
+++ b/recipes-ruby/ruby-serialport/ruby-serialport_1.3.1.bb
@@ -0,0 +1,35 @@
+DESCRIPTION = "A Ruby library that provides a class for using RS-232 serial ports"
+HOMEPAGE = "https://github.com/hparra/ruby-serialport"
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=751419260aa954499f7abaabaa882bbe"
+SECTION = "console/utils"
+PRIORITY = "optional"
+
+DEPENDS = "ruby"
+
+PR = "r2"
+
+# tag v1.3.0
+SRCREV = "2781dbb1ffbf33d7c65478aa25dad5f954d0d3bf"
+
+SRC_URI = "git://github.com/hparra/ruby-serialport.git;protocol=git"
+
+S = "${WORKDIR}/git"
+B = "${S}"
+
+do_compile() {
+ ls -d ${STAGING_INCDIR}/ruby-* >/tmp/ruby.txt
+ rp=$(ls -d ${STAGING_INCDIR}/ruby-* | head -1)
+ echo ${rp} >/tmp/ruby2.txt
+ ${CC} -v ${CFLAGS} ${LDFLAGS} -Iext/native -I${rp} -I${rp}/arm-linux-gnueabi -c ext/native/*.c
+ ${CC} -v ${CFLAGS} ${LDFLAGS} --shared -o ext/native/serialport.so serialport.o posix_serialport_impl.o
+}
+
+do_install() {
+ install -d ${D}${libdir}/ruby/serialport
+ install lib/serialport.rb ${D}${libdir}/ruby/serialport.rb
+ install ext/native/serialport.so -t ${D}${libdir}/ruby
+}
+
+FILES_${PN} = "${libdir}/ruby/serialport*"
+FILES_${PN}-dbg += "${libdir}/ruby/.debug"