summaryrefslogtreecommitdiff
path: root/recipes-ruby/ruby-serialport/ruby-serialport_1.3.1.bb
diff options
context:
space:
mode:
authorJohn Klug <john.klug@multitech.com>2020-11-11 18:48:27 -0600
committerJohn Klug <john.klug@multitech.com>2020-11-11 18:48:27 -0600
commitb00be59bbc49535097c450b6b8c5fc10c1efd6dd (patch)
tree25cf0e14f66c5fca1cfe41b31bf862d60a36cf12 /recipes-ruby/ruby-serialport/ruby-serialport_1.3.1.bb
parentdb088915be6dca3f09dedbcdaa7264d9271b1c74 (diff)
downloadmeta-mlinux-b00be59bbc49535097c450b6b8c5fc10c1efd6dd.tar.gz
meta-mlinux-b00be59bbc49535097c450b6b8c5fc10c1efd6dd.tar.bz2
meta-mlinux-b00be59bbc49535097c450b6b8c5fc10c1efd6dd.zip
Merge multiarch project to: added missing index file 2020 June 11GitosisMultiarch
Diffstat (limited to 'recipes-ruby/ruby-serialport/ruby-serialport_1.3.1.bb')
-rw-r--r--recipes-ruby/ruby-serialport/ruby-serialport_1.3.1.bb2
1 files changed, 2 insertions, 0 deletions
diff --git a/recipes-ruby/ruby-serialport/ruby-serialport_1.3.1.bb b/recipes-ruby/ruby-serialport/ruby-serialport_1.3.1.bb
index d06be09..8f524e3 100644
--- a/recipes-ruby/ruby-serialport/ruby-serialport_1.3.1.bb
+++ b/recipes-ruby/ruby-serialport/ruby-serialport_1.3.1.bb
@@ -17,6 +17,8 @@ SRC_URI = "git://github.com/hparra/ruby-serialport.git;protocol=git"
S = "${WORKDIR}/git"
B = "${S}"
+CFLAGS_append +="-fPIC"
+
do_compile() {
rp=$(ls -d ${STAGING_INCDIR}/ruby-* | head -1)
${CC} -v ${CFLAGS} ${LDFLAGS} -Iext/native -I${rp} -I${rp}/arm-linux-gnueabi -c ext/native/*.c