summaryrefslogtreecommitdiff
path: root/recipes-navigation
diff options
context:
space:
mode:
authorJohn Klug <john.klug@multitech.com>2018-10-26 19:17:40 -0500
committerJohn Klug <john.klug@multitech.com>2018-10-26 19:17:40 -0500
commitddd6393d49462d1b3dcde8a0347ba39db1890305 (patch)
tree9d313bfcc6bd3732e97cfb1076779e6caa0ea3ab /recipes-navigation
parent93c54c893f9f0f0acdc6b273d546298aed1448ca (diff)
downloadmeta-mlinux-ddd6393d49462d1b3dcde8a0347ba39db1890305.tar.gz
meta-mlinux-ddd6393d49462d1b3dcde8a0347ba39db1890305.tar.bz2
meta-mlinux-ddd6393d49462d1b3dcde8a0347ba39db1890305.zip
gpsd 3.18.1
Diffstat (limited to 'recipes-navigation')
-rw-r--r--recipes-navigation/gpsd/gpsd-3.18.1/0001-SConstruct-prefix-includepy-with-sysroot-and-drop-sy.patch (renamed from recipes-navigation/gpsd/gpsd-3.17/0001-SConstruct-prefix-includepy-with-sysroot-and-drop-sy.patch)41
-rw-r--r--recipes-navigation/gpsd/gpsd-3.18.1/0001-include-sys-ttydefaults.h.patch (renamed from recipes-navigation/gpsd/gpsd-3.17/0001-include-sys-ttydefaults.h.patch)0
-rw-r--r--recipes-navigation/gpsd/gpsd-3.18.1/0004-SConstruct-disable-html-and-man-docs-building-becaus.patch (renamed from recipes-navigation/gpsd/gpsd-3.17/0004-SConstruct-disable-html-and-man-docs-building-becaus.patch)12
-rw-r--r--recipes-navigation/gpsd/gpsd-3.18.1/0005-suppress-text-in-binary.patch (renamed from recipes-navigation/gpsd/gpsd-3.17/0005-suppress-text-in-binary.patch)0
-rw-r--r--recipes-navigation/gpsd/gpsd-3.18.1/0006-itu_r_tf_460_6.patch23
-rw-r--r--recipes-navigation/gpsd/gpsd-3.18.1/0006-ubxtimelps.patch (renamed from recipes-navigation/gpsd/gpsd-3.17/0006-ubxtimelps.patch)87
-rw-r--r--recipes-navigation/gpsd/gpsd-3.18.1/leap2017Aug31.patch (renamed from recipes-navigation/gpsd/gpsd-3.17/leap2017Aug31.patch)0
-rw-r--r--recipes-navigation/gpsd/gpsd-3.18.1/leap2017Aug31.readme.txt (renamed from recipes-navigation/gpsd/gpsd-3.17/leap2017Aug31.readme.txt)0
-rw-r--r--recipes-navigation/gpsd/gpsd_3.18.1.bb (renamed from recipes-navigation/gpsd/gpsd_3.17.bb)14
9 files changed, 95 insertions, 82 deletions
diff --git a/recipes-navigation/gpsd/gpsd-3.17/0001-SConstruct-prefix-includepy-with-sysroot-and-drop-sy.patch b/recipes-navigation/gpsd/gpsd-3.18.1/0001-SConstruct-prefix-includepy-with-sysroot-and-drop-sy.patch
index 1fa27c2..a1e71cf 100644
--- a/recipes-navigation/gpsd/gpsd-3.17/0001-SConstruct-prefix-includepy-with-sysroot-and-drop-sy.patch
+++ b/recipes-navigation/gpsd/gpsd-3.18.1/0001-SConstruct-prefix-includepy-with-sysroot-and-drop-sy.patch
@@ -38,11 +38,10 @@ Signed-off-by: Peter A. Bigot <pab@pabigot.com>
SConstruct | 9 +++++++++
1 file changed, 9 insertions(+)
-diff --git a/SConstruct b/SConstruct
-index 3318bb48..e1c4f963 100644
---- a/SConstruct
-+++ b/SConstruct
-@@ -934,7 +934,7 @@ else:
+diff -Naru gpsd-3.18.1.orig/SConstruct gpsd-3.18.1/SConstruct
+--- gpsd-3.18.1.orig/SConstruct 2018-10-26 15:31:33.890410700 -0500
++++ gpsd-3.18.1/SConstruct 2018-10-26 17:25:45.202207869 -0500
+@@ -980,7 +980,7 @@
# Set up configuration for target Python
@@ -51,7 +50,18 @@ index 3318bb48..e1c4f963 100644
PYTHON_CONFIG_NAMES = ['CC', 'CXX', 'OPT', 'BASECFLAGS',
'CCSHARED', 'LDSHARED', 'SO', 'INCLUDEPY', 'LDFLAGS']
-@@ -1364,7 +1364,7 @@ else:
+@@ -1034,8 +1034,8 @@
+ # follow FHS, put in /usr/local/libXX, not /usr/libXX
+ # may be lib, lib32 or lib64
+ python_libdir = polystr(python_libdir)
+- python_libdir = python_libdir.replace("/usr/lib",
+- "/usr/local/lib")
++# python_libdir = python_libdir.replace("/usr/lib",
++# "/usr/local/lib")
+
+ py_config_text = config.GetPythonValue('config vars',
+ PYTHON_SYSCONFIG_IMPORT,
+@@ -1506,7 +1506,7 @@
LINK=ldshared,
SHLIBPREFIX="",
SHLIBSUFFIX=python_config['SO'],
@@ -60,22 +70,19 @@ index 3318bb48..e1c4f963 100644
CPPFLAGS=python_config['OPT'],
CFLAGS=python_config['BASECFLAGS'],
CXXFLAGS=python_config['BASECFLAGS'])
-@@ -1662,12 +1662,15 @@ if ((not env['debug'] and not env['profiling'] and not env['nostrip']
- if not env['python']:
- python_install = []
- else:
+@@ -1808,12 +1808,15 @@
+ env.AddPostAction(binaryinstall, '$STRIP $TARGET')
+
+ if env['python']:
+ python_libdir = python_libdir.replace(env['sysroot'], '')
- python_module_dir = python_libdir + os.sep + 'gps'
+ python_module_dir = str(python_libdir) + os.sep + 'gps'
python_extensions_install = python_env.Install(DESTDIR + python_module_dir,
python_built_extensions)
- if ((not env['debug'] and not env['profiling']
- and not env['nostrip'] and not sys.platform.startswith('darwin'))):
+ if ((not env['debug'] and not env['profiling'] and
+ not env['nostrip'] and not sys.platform.startswith('darwin'))):
python_env.AddPostAction(python_extensions_install, '$STRIP $TARGET')
+ env.AddPostAction(python_extensions_install, '$CHRPATH -r "%s" "$TARGET"' \
-+ % (python_libdir, ))
++ % (python_libdir, ))
python_modules_install = python_env.Install(DESTDIR + python_module_dir,
python_modules)
---
-2.1.0
-
diff --git a/recipes-navigation/gpsd/gpsd-3.17/0001-include-sys-ttydefaults.h.patch b/recipes-navigation/gpsd/gpsd-3.18.1/0001-include-sys-ttydefaults.h.patch
index e91e4e9..e91e4e9 100644
--- a/recipes-navigation/gpsd/gpsd-3.17/0001-include-sys-ttydefaults.h.patch
+++ b/recipes-navigation/gpsd/gpsd-3.18.1/0001-include-sys-ttydefaults.h.patch
diff --git a/recipes-navigation/gpsd/gpsd-3.17/0004-SConstruct-disable-html-and-man-docs-building-becaus.patch b/recipes-navigation/gpsd/gpsd-3.18.1/0004-SConstruct-disable-html-and-man-docs-building-becaus.patch
index ba3d205..ad690ce 100644
--- a/recipes-navigation/gpsd/gpsd-3.17/0004-SConstruct-disable-html-and-man-docs-building-becaus.patch
+++ b/recipes-navigation/gpsd/gpsd-3.18.1/0004-SConstruct-disable-html-and-man-docs-building-becaus.patch
@@ -28,11 +28,10 @@ Signed-off-by: Peter A. Bigot <pab@pabigot.com>
SConstruct | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
-diff --git a/SConstruct b/SConstruct
-index 3318bb48..a5bb756d 100644
---- a/SConstruct
-+++ b/SConstruct
-@@ -889,11 +889,11 @@ else:
+diff -Naru gpsd-3.18.1.orig/SConstruct gpsd-3.18.1/SConstruct
+--- gpsd-3.18.1.orig/SConstruct 2018-10-26 18:17:17.102116334 -0500
++++ gpsd-3.18.1/SConstruct 2018-10-26 18:18:40.102113877 -0500
+@@ -935,11 +935,11 @@
manbuilder = htmlbuilder = None
if env['manbuild']:
@@ -46,6 +45,3 @@ index 3318bb48..a5bb756d 100644
xmlto = "xmlto %s $SOURCE || mv `basename $TARGET` " \
"`dirname $TARGET`"
htmlbuilder = xmlto % "html-nochunks"
---
-1.8.5.5
-
diff --git a/recipes-navigation/gpsd/gpsd-3.17/0005-suppress-text-in-binary.patch b/recipes-navigation/gpsd/gpsd-3.18.1/0005-suppress-text-in-binary.patch
index f338126..f338126 100644
--- a/recipes-navigation/gpsd/gpsd-3.17/0005-suppress-text-in-binary.patch
+++ b/recipes-navigation/gpsd/gpsd-3.18.1/0005-suppress-text-in-binary.patch
diff --git a/recipes-navigation/gpsd/gpsd-3.18.1/0006-itu_r_tf_460_6.patch b/recipes-navigation/gpsd/gpsd-3.18.1/0006-itu_r_tf_460_6.patch
new file mode 100644
index 0000000..8e8d814
--- /dev/null
+++ b/recipes-navigation/gpsd/gpsd-3.18.1/0006-itu_r_tf_460_6.patch
@@ -0,0 +1,23 @@
+diff -Naur old/ntpshmwrite.c new/ntpshmwrite.c
+--- old/ntpshmwrite.c 2017-01-23 10:00:05.497129473 -0600
++++ new/ntpshmwrite.c 2017-01-23 09:47:58.881627772 -0600
+@@ -32,11 +32,18 @@
+ * NTP expects leap pending for only 1 month prior to insertion
+ * Per http://bugs.ntp.org/1090 */
+ (void)gmtime_r( &(td->real.tv_sec), &tm);
++/* This code contradicts page 3 section 2.1 of ITU-R RV.460-6 that
++ * leap second may occur at the last second of a month, with
++ * preference for December and June, 2nd preference to March and
++ * September.
++ * https://www.itu.int/dms_pubrec/itu-r/rec/tf/R-REC-TF.460-6-200202-I!!PDF-E.pdf
++ */
++#ifdef NOTITU_R_TF_460_6
+ if ( 5 != tm.tm_mon && 11 != tm.tm_mon ) {
+ /* Not june, not December, no way */
+ leap_notify = LEAP_NOWARNING;
+ }
+-
++#endif /* NOTITU_R_TF_460_6 */
+ /* we use the shmTime mode 1 protocol
+ *
+ * ntpd does this:
diff --git a/recipes-navigation/gpsd/gpsd-3.17/0006-ubxtimelps.patch b/recipes-navigation/gpsd/gpsd-3.18.1/0006-ubxtimelps.patch
index e715847..38154a8 100644
--- a/recipes-navigation/gpsd/gpsd-3.17/0006-ubxtimelps.patch
+++ b/recipes-navigation/gpsd/gpsd-3.18.1/0006-ubxtimelps.patch
@@ -1,6 +1,6 @@
-diff -Naur old/driver_ubx.c new/driver_ubx.c
---- old/driver_ubx.c 2017-01-19 14:12:25.099231346 -0600
-+++ new/driver_ubx.c 2017-01-19 15:13:58.552152991 -0600
+diff -Naru gpsd-3.18.1.orig/driver_ubx.c gpsd-3.18.1/driver_ubx.c
+--- gpsd-3.18.1.orig/driver_ubx.c 2018-10-26 16:01:08.010358178 -0500
++++ gpsd-3.18.1/driver_ubx.c 2018-10-26 16:49:16.262272672 -0500
@@ -57,6 +57,29 @@
#define UBX_CFG_LEN 20
#define outProtoMask 14
@@ -30,8 +30,8 @@ diff -Naur old/driver_ubx.c new/driver_ubx.c
+
static gps_mask_t ubx_parse(struct gps_device_t *session, unsigned char *buf,
size_t len);
- static gps_mask_t ubx_msg_nav_dop(struct gps_device_t *session,
-@@ -237,6 +260,89 @@
+ static gps_mask_t ubx_msg_nav_eoe(struct gps_device_t *session,
+@@ -397,6 +420,90 @@
return mask;
}
@@ -118,36 +118,31 @@ diff -Naur old/driver_ubx.c new/driver_ubx.c
+ }
+}
+#endif /* UBLOXTIMELS_ENABLE */
++
/**
* Geodetic position solution message
*/
-@@ -523,13 +629,22 @@
- case UBX_NAV_EKFSTATUS:
- gpsd_log(&session->context->errout, LOG_DATA, "UBX_NAV_EKFSTATUS\n");
+@@ -1129,6 +1236,9 @@
break;
--
-+ case UBX_NAV_TIMELS:
-+ gpsd_log(&session->context->errout, LOG_DATA, "UBX_NAV_TIMELS\n");
+ case UBX_NAV_TIMELS:
+ gpsd_log(&session->context->errout, LOG_DATA, "UBX_NAV_TIMELS\n");
+#ifdef UBLOXTIMELS_ENABLE
+ ubx_msg_nav_timels(session, &buf[UBX_PREFIX_LEN],data_len);
+#endif // UBLOXTIMELS_ENABLE
-+ break;
- case UBX_RXM_RAW:
- gpsd_log(&session->context->errout, LOG_DATA, "UBX_RXM_RAW\n");
break;
- case UBX_RXM_SFRB:
-+ gpsd_log(&session->context->errout, LOG_DATA, "UBX_RXM_SFRB\n");
- mask = ubx_msg_sfrb(session, &buf[UBX_PREFIX_LEN]);
+ case UBX_NAV_TIMEUTC:
+ gpsd_log(&session->context->errout, LOG_DATA, "UBX_NAV_TIMEUTC\n");
+@@ -1172,6 +1282,7 @@
+ gpsd_log(&session->context->errout, LOG_DATA, "UBX_RXM_RTCM\n");
break;
-+ case UBX_RXM_SFRBX:
-+ gpsd_log(&session->context->errout, LOG_DATA, "UBX_RXM_SFRBX\n");
-+ break;
- case UBX_RXM_SVSI:
- gpsd_log(&session->context->errout, LOG_PROG, "UBX_RXM_SVSI\n");
+ case UBX_RXM_SFRB:
++ gpsd_log(&session->context->errout, LOG_DATA, "UBX_RXM_SFRB\n");
+ mask = ubx_rxm_sfrb(session, &buf[UBX_PREFIX_LEN]);
break;
-@@ -955,6 +1070,12 @@
+ case UBX_RXM_SFRBX:
+@@ -1474,6 +1585,12 @@
msg[1] = 0x20; /* msg id = UBX_NAV_TIMEGPS */
- msg[2] = 0x01; /* rate */
+ msg[2] = 0x00; /* rate */
(void)ubx_write(session, 0x06u, 0x01, msg, 3);
+#ifdef UBLOXTIMELS_ENABLE
+ msg[0] = 0x01; /* class */
@@ -157,44 +152,28 @@ diff -Naur old/driver_ubx.c new/driver_ubx.c
+ (void)ubx_write(session, 0x06u, 0x01, msg, 3);
msg[0] = 0x01; /* class */
msg[1] = 0x30; /* msg id = NAV-SVINFO */
- msg[2] = 0x0a; /* rate */
-diff -Naur old/driver_ubx.h new/driver_ubx.h
---- old/driver_ubx.h 2017-01-19 14:12:25.099231346 -0600
-+++ new/driver_ubx.h 2017-01-19 14:01:48.177653001 -0600
-@@ -35,6 +35,7 @@
- UBX_NAV_TIMEGPS = UBX_MSGID(UBX_CLASS_NAV, 0x20),
- UBX_NAV_TIMEUTC = UBX_MSGID(UBX_CLASS_NAV, 0x21),
- UBX_NAV_CLOCK = UBX_MSGID(UBX_CLASS_NAV, 0x22),
-+ UBX_NAV_TIMELS = UBX_MSGID(UBX_CLASS_NAV, 0x26),
- UBX_NAV_SVINFO = UBX_MSGID(UBX_CLASS_NAV, 0x30),
- UBX_NAV_DGPS = UBX_MSGID(UBX_CLASS_NAV, 0x31),
- UBX_NAV_SBAS = UBX_MSGID(UBX_CLASS_NAV, 0x32),
-@@ -42,6 +43,7 @@
-
- UBX_RXM_RAW = UBX_MSGID(UBX_CLASS_RXM, 0x10),
- UBX_RXM_SFRB = UBX_MSGID(UBX_CLASS_RXM, 0x11),
-+ UBX_RXM_SFRBX = UBX_MSGID(UBX_CLASS_RXM, 0x13),
- UBX_RXM_SVSI = UBX_MSGID(UBX_CLASS_RXM, 0x20),
- UBX_RXM_ALM = UBX_MSGID(UBX_CLASS_RXM, 0x30),
- UBX_RXM_EPH = UBX_MSGID(UBX_CLASS_RXM, 0x31),
-@@ -102,6 +104,9 @@
+ msg[2] = 0x00; /* rate */
+diff -Naru gpsd-3.18.1.orig/driver_ubx.h gpsd-3.18.1/driver_ubx.h
+--- gpsd-3.18.1.orig/driver_ubx.h 2018-10-26 16:01:08.010358178 -0500
++++ gpsd-3.18.1/driver_ubx.h 2018-10-26 16:26:09.114313738 -0500
+@@ -210,6 +210,9 @@
#define UBX_SOL_VALID_WEEK 0x04
#define UBX_SOL_VALID_TIME 0x08
+#define UBX_TIMELS_VALID_CURR_LS 0x01
+#define UBX_TIMELS_VALID_TIME_LS_EVT 0x01
+
- /* from UBX_NAV_SVINFO */
- #define UBX_SAT_USED 0x01
- #define UBX_SAT_DGPS 0x02
-diff -Naur old/SConstruct new/SConstruct
---- old/SConstruct 2017-01-19 14:51:35.638466569 -0600
-+++ new/SConstruct 2017-01-19 15:20:02.488159765 -0600
-@@ -113,6 +113,7 @@
+ #define UBX_TIMEGPS_VALID_TIME 0x01
+ #define UBX_TIMEGPS_VALID_WEEK 0x02
+ #define UBX_TIMEGPS_VALID_LEAP_SECOND 0x04
+diff -Naru gpsd-3.18.1.orig/SConstruct gpsd-3.18.1/SConstruct
+--- gpsd-3.18.1.orig/SConstruct 2018-10-26 15:53:30.174371732 -0500
++++ gpsd-3.18.1/SConstruct 2018-10-26 15:55:33.726368074 -0500
+@@ -178,6 +178,7 @@
("tripmate", True, "DeLorme TripMate support"),
("tsip", True, "Trimble TSIP support"),
("ublox", True, "u-blox Protocol support"),
+ ("ubloxtimels", False, "u-blox UBX-NAV-TIMELS support (leap second)"),
- ("fury", True, "Jackson Labs Fury and Firefly support"),
- ("nmea2000", True, "NMEA2000/CAN support"),
# Non-GPS protocols
+ ("aivdm", True, "AIVDM support"),
+ ("gpsclock", True, "GPSClock support"),
diff --git a/recipes-navigation/gpsd/gpsd-3.17/leap2017Aug31.patch b/recipes-navigation/gpsd/gpsd-3.18.1/leap2017Aug31.patch
index 658b757..658b757 100644
--- a/recipes-navigation/gpsd/gpsd-3.17/leap2017Aug31.patch
+++ b/recipes-navigation/gpsd/gpsd-3.18.1/leap2017Aug31.patch
diff --git a/recipes-navigation/gpsd/gpsd-3.17/leap2017Aug31.readme.txt b/recipes-navigation/gpsd/gpsd-3.18.1/leap2017Aug31.readme.txt
index d9bf4b1..d9bf4b1 100644
--- a/recipes-navigation/gpsd/gpsd-3.17/leap2017Aug31.readme.txt
+++ b/recipes-navigation/gpsd/gpsd-3.18.1/leap2017Aug31.readme.txt
diff --git a/recipes-navigation/gpsd/gpsd_3.17.bb b/recipes-navigation/gpsd/gpsd_3.18.1.bb
index 08566c2..da73e76 100644
--- a/recipes-navigation/gpsd/gpsd_3.17.bb
+++ b/recipes-navigation/gpsd/gpsd_3.18.1.bb
@@ -8,11 +8,15 @@ PR="m1"
EXTRANATIVEPATH += "chrpath-native"
+# sysclockcrash is fixed for gpsd
+# suppress text in binary is fixed for gpsctl
+
SRC_URI = "${SAVANNAH_GNU_MIRROR}/${BPN}/${BP}.tar.gz \
file://0001-SConstruct-prefix-includepy-with-sysroot-and-drop-sy.patch \
file://0004-SConstruct-disable-html-and-man-docs-building-becaus.patch \
file://0001-include-sys-ttydefaults.h.patch \
file://0006-ubxtimelps.patch \
+ file://0006-itu_r_tf_460_6.patch \
file://gpsd-default \
file://gpsd \
file://gpsd_ubx_fixed.sh \
@@ -20,9 +24,8 @@ SRC_URI = "${SAVANNAH_GNU_MIRROR}/${BPN}/${BP}.tar.gz \
file://gpsd.rules \
file://gpsd.service \
"
-SRC_URI[md5sum] = "e0cfadcf4a65dfbdd2afb11c58f4e4a1"
-SRC_URI[sha256sum] = "68e0dbecfb5831997f8b3d6ba48aed812eb465d8c0089420ab68f9ce4d85e77a"
-
+SRC_URI[md5sum] = "3b11f26b295010666b1767b308f90bc5"
+SRC_URI[sha256sum] = "5cb1e6d880ec9a52c62492dd0e3d77451b7c7ad625895bd652f6354215aec23e"
inherit scons update-rc.d python-dir pythonnative systemd
@@ -54,6 +57,7 @@ EXTRA_OESCONS = " \
pps='yes' \
gpsd_group='gps' \
ntpshm='yes' \
+ prefix='usr' \
${PACKAGECONFIG_CONFARGS} \
"
# this cannot be used, because then chrpath is not found and only static lib is built
@@ -110,6 +114,10 @@ do_install_append() {
install -m 0644 ${S}/gpsd_config.h ${D}/${includedir}/gps
install -m 0644 ${S}/compiler.h ${D}/${includedir}/gps
install -m 0644 ${S}/ppsthread.h ${D}/${includedir}/gps
+
+ # New ubxtool
+ install -m 0755 ${S}/ubxtool ${D}/${bindir}
+ install -m 0644 ${S}/ubxtool.1 ${D}/${mandir}/man1
}
RDEPENDS_${PN}-conf += "bash"