summaryrefslogtreecommitdiff
path: root/recipes-navigation
diff options
context:
space:
mode:
authorJohn Klug <john.klug@multitech.com>2017-01-03 17:05:53 -0600
committerJohn Klug <john.klug@multitech.com>2017-01-03 17:05:53 -0600
commitc8bc3592c3bb003aba165b0fd5a609e455931d45 (patch)
tree81a5317322fdaffe770063d1508c0f56369aeb42 /recipes-navigation
parent0f6b23997881f6e683f425cb8529434248a50577 (diff)
downloadmeta-mlinux-c8bc3592c3bb003aba165b0fd5a609e455931d45.tar.gz
meta-mlinux-c8bc3592c3bb003aba165b0fd5a609e455931d45.tar.bz2
meta-mlinux-c8bc3592c3bb003aba165b0fd5a609e455931d45.zip
Fix broken gpsctl -x option
Diffstat (limited to 'recipes-navigation')
-rw-r--r--recipes-navigation/gpsd/gpsd-3.16/0005-suppress-text-in-binary.patch29
-rw-r--r--recipes-navigation/gpsd/gpsd_3.16.bb1
2 files changed, 30 insertions, 0 deletions
diff --git a/recipes-navigation/gpsd/gpsd-3.16/0005-suppress-text-in-binary.patch b/recipes-navigation/gpsd/gpsd-3.16/0005-suppress-text-in-binary.patch
new file mode 100644
index 0000000..34c9924
--- /dev/null
+++ b/recipes-navigation/gpsd/gpsd-3.16/0005-suppress-text-in-binary.patch
@@ -0,0 +1,29 @@
+diff -u old/gpsctl.c new/gpsctl.c
+--- old/gpsctl.c 2017-01-03 15:57:50.517120891 -0600
++++ new/gpsctl.c 2017-01-03 15:58:05.025120861 -0600
+@@ -175,7 +175,7 @@
+ int option, status;
+ char *device = NULL, *devtype = NULL;
+ char *speed = NULL, *control = NULL, *rate = NULL;
+- bool to_binary = false, to_nmea = false, reset = false;
++ bool to_binary = false, to_nmea = false, reset = false, cstring = false;
+ bool lowlevel=false, echo=false;
+ struct gps_data_t gpsdata;
+ const struct gps_type_t *forcetype = NULL;
+@@ -205,6 +205,7 @@
+ #ifdef CONTROLSEND_ENABLE
+ control = optarg;
+ lowlevel = true;
++ cstring = true;
+ if ((cooklen = hex_escapes(cooked, control)) <= 0) {
+ gpsd_log(&context.errout, LOG_ERROR,
+ "invalid escape string (error %d)\n", (int)cooklen);
+@@ -443,7 +444,7 @@
+ }
+
+ /* if no control operation was specified, just ID the device */
+- if (speed==NULL && rate == NULL && !to_nmea && !to_binary && !reset) {
++ if (speed==NULL && rate == NULL && !to_nmea && !to_binary && !reset && !cstring) {
+ (void)printf("%s identified as a %s",
+ gpsdata.dev.path, gpsdata.dev.driver);
+ if (gpsdata.dev.subtype[0] != '\0') {
diff --git a/recipes-navigation/gpsd/gpsd_3.16.bb b/recipes-navigation/gpsd/gpsd_3.16.bb
index 19603b9..100edcc 100644
--- a/recipes-navigation/gpsd/gpsd_3.16.bb
+++ b/recipes-navigation/gpsd/gpsd_3.16.bb
@@ -12,6 +12,7 @@ SRC_URI = "${SAVANNAH_GNU_MIRROR}/${BPN}/${BP}.tar.gz \
file://0001-SConstruct-prefix-includepy-with-sysroot-and-drop-sy.patch \
file://0004-SConstruct-disable-html-and-man-docs-building-becaus.patch \
file://0001-include-sys-ttydefaults.h.patch \
+ file://0005-suppress-text-in-binary.patch \
file://gpsd-default \
file://gpsd \
file://60-gpsd.rules \