summaryrefslogtreecommitdiff
path: root/recipes-navigation
diff options
context:
space:
mode:
authorJohn Klug <john.klug@multitech.com>2017-01-03 18:38:47 -0600
committerJohn Klug <john.klug@multitech.com>2017-01-03 18:38:47 -0600
commit9aa4e52f96315a3ee7ca4e03935b90d27a6cde7f (patch)
tree2578013513dd7139755a96d2a427e417e0a3a110 /recipes-navigation
parentc8bc3592c3bb003aba165b0fd5a609e455931d45 (diff)
downloadmeta-mlinux-9aa4e52f96315a3ee7ca4e03935b90d27a6cde7f.tar.gz
meta-mlinux-9aa4e52f96315a3ee7ca4e03935b90d27a6cde7f.tar.bz2
meta-mlinux-9aa4e52f96315a3ee7ca4e03935b90d27a6cde7f.zip
suppress the correct message
Diffstat (limited to 'recipes-navigation')
-rw-r--r--recipes-navigation/gpsd/gpsd-3.16/0005-suppress-text-in-binary.patch21
-rw-r--r--recipes-navigation/gpsd/gpsd_3.16.bb1
2 files changed, 12 insertions, 10 deletions
diff --git a/recipes-navigation/gpsd/gpsd-3.16/0005-suppress-text-in-binary.patch b/recipes-navigation/gpsd/gpsd-3.16/0005-suppress-text-in-binary.patch
index 34c9924..f338126 100644
--- a/recipes-navigation/gpsd/gpsd-3.16/0005-suppress-text-in-binary.patch
+++ b/recipes-navigation/gpsd/gpsd-3.16/0005-suppress-text-in-binary.patch
@@ -1,12 +1,12 @@
diff -u old/gpsctl.c new/gpsctl.c
--- old/gpsctl.c 2017-01-03 15:57:50.517120891 -0600
-+++ new/gpsctl.c 2017-01-03 15:58:05.025120861 -0600
++++ new/gpsctl.c 2017-01-03 18:31:21.421101434 -0600
@@ -175,7 +175,7 @@
int option, status;
char *device = NULL, *devtype = NULL;
char *speed = NULL, *control = NULL, *rate = NULL;
- bool to_binary = false, to_nmea = false, reset = false;
-+ bool to_binary = false, to_nmea = false, reset = false, cstring = false;
++ bool to_binary = false, to_nmea = false, reset = false, control_string = false;
bool lowlevel=false, echo=false;
struct gps_data_t gpsdata;
const struct gps_type_t *forcetype = NULL;
@@ -14,16 +14,17 @@ diff -u old/gpsctl.c new/gpsctl.c
#ifdef CONTROLSEND_ENABLE
control = optarg;
lowlevel = true;
-+ cstring = true;
++ control_string = true;
if ((cooklen = hex_escapes(cooked, control)) <= 0) {
gpsd_log(&context.errout, LOG_ERROR,
"invalid escape string (error %d)\n", (int)cooklen);
-@@ -443,7 +444,7 @@
+@@ -704,7 +705,8 @@
+ }
}
- /* if no control operation was specified, just ID the device */
-- if (speed==NULL && rate == NULL && !to_nmea && !to_binary && !reset) {
-+ if (speed==NULL && rate == NULL && !to_nmea && !to_binary && !reset && !cstring) {
- (void)printf("%s identified as a %s",
- gpsdata.dev.path, gpsdata.dev.driver);
- if (gpsdata.dev.subtype[0] != '\0') {
+- (void)printf("%s identified as a %s at %u baud.\n",
++ if(!control_string)
++ (void)printf("%s identified as a %s at %u baud.\n",
+ device, gpsd_id(&session),
+ session.gpsdata.dev.baudrate);
+
diff --git a/recipes-navigation/gpsd/gpsd_3.16.bb b/recipes-navigation/gpsd/gpsd_3.16.bb
index 100edcc..20b2cad 100644
--- a/recipes-navigation/gpsd/gpsd_3.16.bb
+++ b/recipes-navigation/gpsd/gpsd_3.16.bb
@@ -4,6 +4,7 @@ LICENSE = "BSD"
LIC_FILES_CHKSUM = "file://COPYING;md5=d217a23f408e91c94359447735bc1800"
DEPENDS = "dbus dbus-glib ncurses python libusb1 chrpath-replacement-native pps-tools"
PROVIDES = "virtual/gpsd"
+PR="m1"
EXTRANATIVEPATH += "chrpath-native"