summaryrefslogtreecommitdiff
path: root/recipes-extended
diff options
context:
space:
mode:
authorJesse Gilles <jgilles@multitech.com>2015-04-07 14:14:40 -0500
committerJesse Gilles <jgilles@multitech.com>2015-04-07 14:14:40 -0500
commitf144bbefff161a2d80decc9178cfdc48f8d23497 (patch)
tree899148876d0b3e815808734a5b0939e015160bff /recipes-extended
parent2ae4f90cbf4a7536c745c285c89e92804a2afbfb (diff)
downloadmeta-mlinux-f144bbefff161a2d80decc9178cfdc48f8d23497.tar.gz
meta-mlinux-f144bbefff161a2d80decc9178cfdc48f8d23497.tar.bz2
meta-mlinux-f144bbefff161a2d80decc9178cfdc48f8d23497.zip
logrotate: rotate logs often, fix cron job
Diffstat (limited to 'recipes-extended')
-rw-r--r--recipes-extended/logrotate/logrotate_3.8.7.bbappend7
1 files changed, 4 insertions, 3 deletions
diff --git a/recipes-extended/logrotate/logrotate_3.8.7.bbappend b/recipes-extended/logrotate/logrotate_3.8.7.bbappend
index 98b7b60..300b9b7 100644
--- a/recipes-extended/logrotate/logrotate_3.8.7.bbappend
+++ b/recipes-extended/logrotate/logrotate_3.8.7.bbappend
@@ -1,8 +1,9 @@
+PR .= "mlinux1"
do_install_append() {
-# rotate logs hourly instead of daily
+ # setup cron to run logrotate more often
rm -f ${D}${sysconfdir}/cron.daily/logrotate
- install -d ${D}${sysconfdir}/cron.hourly
- install -p -m 755 examples/logrotate.cron ${D}${sysconfdir}/cron.hourly/logrotate
+ install -d ${D}${sysconfdir}/cron.d
+ echo "*/5 * * * * root /usr/sbin/logrotate /etc/logrotate.conf" > ${D}${sysconfdir}/cron.d/logrotate
}