summaryrefslogtreecommitdiff
path: root/recipes-extended
diff options
context:
space:
mode:
authorJesse Gilles <jgilles@multitech.com>2015-04-27 17:20:48 -0500
committerJesse Gilles <jgilles@multitech.com>2015-04-27 17:22:01 -0500
commite9de87ae96038f07b325cbd99ded9e6e285f7348 (patch)
tree0f8e3b58474010caf06015e02960329c6efd3817 /recipes-extended
parente310beaf18513ea10cd49bba71fd08f69a346fff (diff)
downloadmeta-mlinux-e9de87ae96038f07b325cbd99ded9e6e285f7348.tar.gz
meta-mlinux-e9de87ae96038f07b325cbd99ded9e6e285f7348.tar.bz2
meta-mlinux-e9de87ae96038f07b325cbd99ded9e6e285f7348.zip
logrotate: add logrotate.conf and turn off dateext by default
Diffstat (limited to 'recipes-extended')
-rw-r--r--recipes-extended/logrotate/logrotate/logrotate.conf36
-rw-r--r--recipes-extended/logrotate/logrotate_3.8.7.bbappend8
2 files changed, 43 insertions, 1 deletions
diff --git a/recipes-extended/logrotate/logrotate/logrotate.conf b/recipes-extended/logrotate/logrotate/logrotate.conf
new file mode 100644
index 0000000..353d9d0
--- /dev/null
+++ b/recipes-extended/logrotate/logrotate/logrotate.conf
@@ -0,0 +1,36 @@
+# see "man logrotate" for details
+# rotate log files weekly
+weekly
+
+# keep 4 weeks worth of backlogs
+rotate 4
+
+# create new (empty) log files after rotating old ones
+create
+
+# do not use date as a suffix of the rotated file
+# this seems to prevent multiple rotations of logs per day
+nodateext
+
+# uncomment this if you want your log files compressed
+#compress
+
+# RPM packages drop log rotation information into this directory
+include /etc/logrotate.d
+
+# no packages own wtmp and btmp -- we'll rotate them here
+/var/log/wtmp {
+ monthly
+ create 0664 root utmp
+ minsize 1M
+ rotate 1
+}
+
+/var/log/btmp {
+ missingok
+ monthly
+ create 0600 root utmp
+ rotate 1
+}
+
+# system-specific logs may be also be configured here.
diff --git a/recipes-extended/logrotate/logrotate_3.8.7.bbappend b/recipes-extended/logrotate/logrotate_3.8.7.bbappend
index 300b9b7..577fe53 100644
--- a/recipes-extended/logrotate/logrotate_3.8.7.bbappend
+++ b/recipes-extended/logrotate/logrotate_3.8.7.bbappend
@@ -1,9 +1,15 @@
-PR .= "mlinux1"
+PR .= "mlinux2"
+
+FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}"
+
+SRC_URI += "file://logrotate.conf"
do_install_append() {
# setup cron to run logrotate more often
rm -f ${D}${sysconfdir}/cron.daily/logrotate
install -d ${D}${sysconfdir}/cron.d
echo "*/5 * * * * root /usr/sbin/logrotate /etc/logrotate.conf" > ${D}${sysconfdir}/cron.d/logrotate
+
+ install -m 0644 ${WORKDIR}/logrotate.conf ${D}${sysconfdir}/
}