summaryrefslogtreecommitdiff
path: root/recipes-extended
diff options
context:
space:
mode:
authorJesse Gilles <jgilles@multitech.com>2015-04-06 16:43:59 -0500
committerJesse Gilles <jgilles@multitech.com>2015-04-06 16:43:59 -0500
commita1feb35f9c6d2105574ceb5593f65a3f9f90b369 (patch)
treebf110d457e45c2b6ee18c93595f3c15e5e1d28a8 /recipes-extended
parenta15382ed91f6a66029319f86cd0cdcc5ff4e5c05 (diff)
downloadmeta-mlinux-a1feb35f9c6d2105574ceb5593f65a3f9f90b369.tar.gz
meta-mlinux-a1feb35f9c6d2105574ceb5593f65a3f9f90b369.tar.bz2
meta-mlinux-a1feb35f9c6d2105574ceb5593f65a3f9f90b369.zip
logrotate: add bbappend to rotate logs hourly instead of daily
Diffstat (limited to 'recipes-extended')
-rw-r--r--recipes-extended/logrotate/logrotate_3.8.7.bbappend8
1 files changed, 8 insertions, 0 deletions
diff --git a/recipes-extended/logrotate/logrotate_3.8.7.bbappend b/recipes-extended/logrotate/logrotate_3.8.7.bbappend
new file mode 100644
index 0000000..98b7b60
--- /dev/null
+++ b/recipes-extended/logrotate/logrotate_3.8.7.bbappend
@@ -0,0 +1,8 @@
+
+do_install_append() {
+# rotate logs hourly instead of daily
+ rm -f ${D}${sysconfdir}/cron.daily/logrotate
+ install -d ${D}${sysconfdir}/cron.hourly
+ install -p -m 755 examples/logrotate.cron ${D}${sysconfdir}/cron.hourly/logrotate
+}
+