summaryrefslogtreecommitdiff
path: root/recipes-extended/lighttpd/lighttpd_1.4.48.bbappend
diff options
context:
space:
mode:
authorPatrick Murphy <Patrick.Murphy@multitech.com>2020-06-11 15:35:52 -0500
committerJohn Klug <john.klug@multitech.com>2020-06-18 20:22:08 -0500
commit37dc88b8b9ef46d3722c1a349719fa0aa10c7c3a (patch)
tree8fa8da7f70001094de5b0ea3b37e09c728db6a3a /recipes-extended/lighttpd/lighttpd_1.4.48.bbappend
parent1612656579381828fb1e7d0fc4df25e4968e177f (diff)
downloadmeta-mlinux-37dc88b8b9ef46d3722c1a349719fa0aa10c7c3a.tar.gz
meta-mlinux-37dc88b8b9ef46d3722c1a349719fa0aa10c7c3a.tar.bz2
meta-mlinux-37dc88b8b9ef46d3722c1a349719fa0aa10c7c3a.zip
iterated lighttpd_1.4.41bbappend to lighttpd1.4.48bbappend
Diffstat (limited to 'recipes-extended/lighttpd/lighttpd_1.4.48.bbappend')
-rw-r--r--recipes-extended/lighttpd/lighttpd_1.4.48.bbappend21
1 files changed, 21 insertions, 0 deletions
diff --git a/recipes-extended/lighttpd/lighttpd_1.4.48.bbappend b/recipes-extended/lighttpd/lighttpd_1.4.48.bbappend
new file mode 100644
index 0000000..d6d4f02
--- /dev/null
+++ b/recipes-extended/lighttpd/lighttpd_1.4.48.bbappend
@@ -0,0 +1,21 @@
+PR .= ".mlinux1"
+
+# build with openssl support
+DEPENDS += " openssl "
+RDEPENDS_${PN} += " openssl logrotate "
+
+EXTRA_OECONF += "--with-openssl"
+
+FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
+
+SRC_URI += "file://lighttpd.logrotate.conf \
+ file://lighttpd.default"
+
+do_install_append() {
+ install -d ${D}${sysconfdir}/logrotate.d
+ install -d ${D}${sysconfdir}/default
+ install -m 0644 ${WORKDIR}/lighttpd.logrotate.conf ${D}${sysconfdir}/logrotate.d/lighttpd.conf
+ install -m 0644 ${WORKDIR}/lighttpd.default ${D}${sysconfdir}/default/lighttpd
+}
+
+CONFFILES_${PN} += "${sysconfdir}/default/lighttpd ${sysconfdir}/logrotate.d/lighttpd.conf ${sysconfdir}/init.d/lighttpd"