summaryrefslogtreecommitdiff
path: root/recipes-extended/lighttpd/lighttpd_1.4.41.bbappend
diff options
context:
space:
mode:
authorJeff Hatch <jhatch@multitech.com>2017-05-26 09:04:24 -0500
committerJeff Hatch <jhatch@multitech.com>2017-05-26 09:04:24 -0500
commit5d7686064960f8e239563832a194aa208e351455 (patch)
treef987f7971b58d62ae9a69875e032b5afc1e849e5 /recipes-extended/lighttpd/lighttpd_1.4.41.bbappend
parent497fb088cc000e900bc270003766c20333fbdcb6 (diff)
downloadmeta-mlinux-5d7686064960f8e239563832a194aa208e351455.tar.gz
meta-mlinux-5d7686064960f8e239563832a194aa208e351455.tar.bz2
meta-mlinux-5d7686064960f8e239563832a194aa208e351455.zip
Sync up bbappedn with yocto-2.2 version of lighttpd
Diffstat (limited to 'recipes-extended/lighttpd/lighttpd_1.4.41.bbappend')
-rw-r--r--recipes-extended/lighttpd/lighttpd_1.4.41.bbappend21
1 files changed, 21 insertions, 0 deletions
diff --git a/recipes-extended/lighttpd/lighttpd_1.4.41.bbappend b/recipes-extended/lighttpd/lighttpd_1.4.41.bbappend
new file mode 100644
index 0000000..8171f17
--- /dev/null
+++ b/recipes-extended/lighttpd/lighttpd_1.4.41.bbappend
@@ -0,0 +1,21 @@
+PR .= ".mlinux1"
+
+# build with openssl support
+DEPENDS += " openssl "
+RDEPENDS_${PN} += " openssl logrotate "
+
+EXTRA_OECONF += "--with-openssl"
+
+FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
+
+SRC_URI += "file://lighttpd.logrotate.conf \
+ file://lighttpd.default"
+
+do_install_append() {
+ install -d ${D}${sysconfdir}/logrotate.d
+ install -d ${D}${sysconfdir}/default
+ install -m 0644 ${WORKDIR}/lighttpd.logrotate.conf ${D}${sysconfdir}/logrotate.d/lighttpd.conf
+ install -m 0644 ${WORKDIR}/lighttpd.default ${D}${sysconfdir}/default/lighttpd
+}
+
+CONFFILES_${PN} += "${sysconfdir}/default/lighttpd ${sysconfdir}/logrotate.d/lighttpd.conf"