summaryrefslogtreecommitdiff
path: root/recipes-extended/lighttpd/lighttpd_1.4.33.bbappend
diff options
context:
space:
mode:
authorJesse Gilles <jgilles@multitech.com>2015-04-27 16:55:30 -0500
committerJesse Gilles <jgilles@multitech.com>2015-04-27 16:55:30 -0500
commite310beaf18513ea10cd49bba71fd08f69a346fff (patch)
treec40da8e8162fa05930cc7d05c91f7d12c5b6632b /recipes-extended/lighttpd/lighttpd_1.4.33.bbappend
parent2b06fd93e6c522d0a1896536a5f6b2c428007e6e (diff)
downloadmeta-mlinux-e310beaf18513ea10cd49bba71fd08f69a346fff.tar.gz
meta-mlinux-e310beaf18513ea10cd49bba71fd08f69a346fff.tar.bz2
meta-mlinux-e310beaf18513ea10cd49bba71fd08f69a346fff.zip
lighttpd: disable debug logging, add log rotation, no start on boot by default
Diffstat (limited to 'recipes-extended/lighttpd/lighttpd_1.4.33.bbappend')
-rw-r--r--recipes-extended/lighttpd/lighttpd_1.4.33.bbappend18
1 files changed, 17 insertions, 1 deletions
diff --git a/recipes-extended/lighttpd/lighttpd_1.4.33.bbappend b/recipes-extended/lighttpd/lighttpd_1.4.33.bbappend
index 885737e..5ef310b 100644
--- a/recipes-extended/lighttpd/lighttpd_1.4.33.bbappend
+++ b/recipes-extended/lighttpd/lighttpd_1.4.33.bbappend
@@ -1,5 +1,21 @@
+PR .= "mlinux1"
+
# build with openssl support
DEPENDS += " openssl "
-RDEPENDS_${PN} += " openssl "
+RDEPENDS_${PN} += " openssl logrotate "
EXTRA_OECONF += "--with-openssl"
+
+FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}"
+
+SRC_URI += "file://lighttpd.logrotate.conf \
+ file://lighttpd.default"
+
+do_install_append() {
+ install -d ${D}${sysconfdir}/logrotate.d
+ install -d ${D}${sysconfdir}/default
+ install -m 0644 ${WORKDIR}/lighttpd.logrotate.conf ${D}${sysconfdir}/logrotate.d/lighttpd.conf
+ install -m 0644 ${WORKDIR}/lighttpd.default ${D}${sysconfdir}/default/lighttpd
+}
+
+CONFFILES_${PN} += "${sysconfdir}/default/lighttpd ${sysconfdir}/logrotate.d/lighttpd.conf"