summaryrefslogtreecommitdiff
path: root/recipes-devtools/python/python-pyserial_3.4.bb
diff options
context:
space:
mode:
authorJeff Hatch <jhatch@multitech.com>2018-02-16 15:27:06 -0600
committerJeff Hatch <jhatch@multitech.com>2018-02-16 15:27:06 -0600
commit1ded8b3f438736895c0353d374f211660c9c5d1d (patch)
tree1c892480a0282517335c7f5bed14ae4e3e1051c7 /recipes-devtools/python/python-pyserial_3.4.bb
parentb641466c1a05d45a1d1625187980d9d05dbf4a9c (diff)
downloadmeta-mlinux-1ded8b3f438736895c0353d374f211660c9c5d1d.tar.gz
meta-mlinux-1ded8b3f438736895c0353d374f211660c9c5d1d.tar.bz2
meta-mlinux-1ded8b3f438736895c0353d374f211660c9c5d1d.zip
Add python serial 3.4 recipe to override 3.1.1 one in mLinux 4. This RDEPENDS importlib which is not in python 2.7.12 by default for some reason
Diffstat (limited to 'recipes-devtools/python/python-pyserial_3.4.bb')
-rw-r--r--recipes-devtools/python/python-pyserial_3.4.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/recipes-devtools/python/python-pyserial_3.4.bb b/recipes-devtools/python/python-pyserial_3.4.bb
new file mode 100644
index 0000000..2c81416
--- /dev/null
+++ b/recipes-devtools/python/python-pyserial_3.4.bb
@@ -0,0 +1,23 @@
+SUMMARY = "Serial Port Support for Python"
+SECTION = "devel/python"
+LICENSE = "BSD"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=d476d94926db6e0008a5b3860d1f5c0d"
+SRCNAME = "pyserial"
+PR = "ml5"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/${SRCNAME}/${SRCNAME}-${PV}.tar.gz"
+S = "${WORKDIR}/${SRCNAME}-${PV}"
+
+inherit setuptools
+
+# FIXME might stop packaging serialwin32 and serialjava files
+
+RDEPENDS_${PN} = "\
+ python-fcntl \
+ python-io \
+ python-stringold \
+ python-importlib \
+"
+
+SRC_URI[md5sum] = "ed6183b15519a0ae96675e9c3330c69b"
+SRC_URI[sha256sum] = "6e2d401fdee0eab996cf734e67773a0143b932772ca8b42451440cfed942c627"