summaryrefslogtreecommitdiff
path: root/recipes-devtools/nodejs/nodejs_0.8.27.bb
diff options
context:
space:
mode:
authorJesse Gilles <jgilles@multitech.com>2015-01-22 17:22:22 -0600
committerJesse Gilles <jgilles@multitech.com>2015-01-22 17:22:22 -0600
commit8946c51abbd3fb41b855213b3edc648b79a28469 (patch)
treef4f146e03ccc7cfbc6a76850a689e7309d10f786 /recipes-devtools/nodejs/nodejs_0.8.27.bb
parent8b58b47532922530d89555c79d8a1beb8c2d8565 (diff)
downloadmeta-mlinux-8946c51abbd3fb41b855213b3edc648b79a28469.tar.gz
meta-mlinux-8946c51abbd3fb41b855213b3edc648b79a28469.tar.bz2
meta-mlinux-8946c51abbd3fb41b855213b3edc648b79a28469.zip
nodejs: update to 0.8.28
Diffstat (limited to 'recipes-devtools/nodejs/nodejs_0.8.27.bb')
-rw-r--r--recipes-devtools/nodejs/nodejs_0.8.27.bb56
1 files changed, 0 insertions, 56 deletions
diff --git a/recipes-devtools/nodejs/nodejs_0.8.27.bb b/recipes-devtools/nodejs/nodejs_0.8.27.bb
deleted file mode 100644
index 7a2b1d7..0000000
--- a/recipes-devtools/nodejs/nodejs_0.8.27.bb
+++ /dev/null
@@ -1,56 +0,0 @@
-DESCRIPTION = "nodeJS Evented I/O for V8 JavaScript"
-HOMEPAGE = "http://nodejs.org"
-LICENSE = "MIT & BSD"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=95a589a3257ab7dfe37d8a8379e3c72d"
-
-DEPENDS = "openssl"
-
-# use newer npm version that supports caret (^) versions
-# https://github.com/npm/npm/issues/4849
-SRCREV_npm = "v1.4.23"
-
-SRC_URI = "http://nodejs.org/dist/v${PV}/node-v${PV}.tar.gz \
- file://0001-gcc-has-a-builtin-define-to-denote-hard-abi-when-in-.patch \
- git://github.com/npm/npm.git;destsuffix=npm;name=npm \
-"
-SRC_URI[md5sum] = "afb113584498d2248825650b94e590a9"
-SRC_URI[sha256sum] = "30608f9dcd9ad122f7e8e6212f95969979e3dc35309d0c422a56486334a9369e"
-
-S = "${WORKDIR}/node-v${PV}"
-
-# v8 errors out if you have set CCACHE
-CCACHE = ""
-
-ARCHFLAGS_arm = "${@bb.utils.contains('TUNE_FEATURES', 'callconvention-hard', '--with-arm-float-abi=hard', '--with-arm-float-abi=softfp', d)}"
-ARCHFLAGS ?= ""
-
-# Node is way too cool to use proper autotools, so we install two wrappers to forcefully inject proper arch cflags to workaround gypi
-do_configure () {
- export LD="${CXX}"
-
- ./configure --prefix=${prefix} --without-snapshot ${ARCHFLAGS}
-}
-
-do_compile () {
- export LD="${CXX}"
- make BUILDTYPE=Release
-}
-
-do_install () {
- # backup original bundled npm
- if [ ! -d deps/npm.orig ]; then
- mv deps/npm deps/npm.orig
- else
- rm -rf deps/npm
- fi
- # install updated npm from git repo
- cp -r ${WORKDIR}/npm deps/npm
-
- oe_runmake install DESTDIR=${D}
-}
-
-RDEPENDS_${PN} = "curl python-shell python-datetime python-subprocess python-crypt python-textutils python-netclient "
-RDEPENDS_${PN}_class-native = ""
-
-FILES_${PN} += "${libdir}/node/wafadmin ${libdir}/node_modules ${libdir}/dtrace"
-BBCLASSEXTEND = "native"