summaryrefslogtreecommitdiff
path: root/recipes-core/useradd
diff options
context:
space:
mode:
authorJohn Klug <john.klug@multitech.com>2017-06-06 15:57:32 -0500
committerJohn Klug <john.klug@multitech.com>2017-06-06 15:57:32 -0500
commitcb560a2d27a63190c83ac3329d50066fa754b5c7 (patch)
tree9ca039a0cf3e891437a1e806493eba449ef55357 /recipes-core/useradd
parentfa905ea07df7229ded71691e85f8fa4d504b7180 (diff)
downloadmeta-mlinux-cb560a2d27a63190c83ac3329d50066fa754b5c7.tar.gz
meta-mlinux-cb560a2d27a63190c83ac3329d50066fa754b5c7.tar.bz2
meta-mlinux-cb560a2d27a63190c83ac3329d50066fa754b5c7.zip
Add /sbin and usr/sbin to the mtadm PATH
Diffstat (limited to 'recipes-core/useradd')
-rw-r--r--recipes-core/useradd/useradd.bb10
1 files changed, 10 insertions, 0 deletions
diff --git a/recipes-core/useradd/useradd.bb b/recipes-core/useradd/useradd.bb
index 0afa3b1..458facf 100644
--- a/recipes-core/useradd/useradd.bb
+++ b/recipes-core/useradd/useradd.bb
@@ -45,3 +45,13 @@ FILES_${PN} = "/home/mtadm/.ssh"
# debugsources.list: No such file or directory:
INHIBIT_PACKAGE_DEBUG_SPLIT = "1"
+pkg_postinst_${PN} () {
+ profile=/home/mtadm/.profile
+ if ! grep 'sbin' ${profile} ; then
+ Sub='${PA'
+ Sub=${Sub}'TH}:/sbin:/usr/sbin'
+ echo 'PATH='${Sub} >>/home/mtadm/.profile
+ echo 'export PATH' >>/home/mtadm/.profile
+ fi
+}
+