summaryrefslogtreecommitdiff
path: root/recipes-core/useradd
diff options
context:
space:
mode:
authorJohn Klug <john.klug@multitech.com>2019-08-22 14:41:56 -0500
committerJohn Klug <john.klug@multitech.com>2019-11-11 11:34:00 -0600
commitb31ec5d0f8d4fee31ac0f2ddd55dcd273eaa2e9e (patch)
tree58630f146c17dd9c3ac30e70efb32fd1ecef4c0b /recipes-core/useradd
parentacbc01400a529c425c2981d55af705c89d1f10f3 (diff)
downloadmeta-mlinux-b31ec5d0f8d4fee31ac0f2ddd55dcd273eaa2e9e.tar.gz
meta-mlinux-b31ec5d0f8d4fee31ac0f2ddd55dcd273eaa2e9e.tar.bz2
meta-mlinux-b31ec5d0f8d4fee31ac0f2ddd55dcd273eaa2e9e.zip
Add mtadm to dialout in upgrade case, and create /run/radio in dialout group
Diffstat (limited to 'recipes-core/useradd')
-rw-r--r--recipes-core/useradd/useradd.bb8
1 files changed, 7 insertions, 1 deletions
diff --git a/recipes-core/useradd/useradd.bb b/recipes-core/useradd/useradd.bb
index 9f7ef05..78fc981 100644
--- a/recipes-core/useradd/useradd.bb
+++ b/recipes-core/useradd/useradd.bb
@@ -1,7 +1,7 @@
SUMMARY = "Add mtadm user"
DESCRIPTION = "Add mtadm user for security purposes"
SECTION = "mtadm"
-PR = "r2"
+PR = "r3"
LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=4d92cd373abda3937c2bc47fbc49d690 \
file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
@@ -53,5 +53,11 @@ pkg_postinst_${PN} () {
echo 'PATH='${Sub} >>/home/mtadm/.profile
echo 'export PATH' >>/home/mtadm/.profile
fi
+ # If doing an update, we need to add mtadm to dialout.
+ # If the admin has been changed, then the user must
+ # do something himself.
+ if [[ -z ${D} ]] ; then
+ sudo groupmems -a mtadm -g dialout || true
+ fi
}